Build Thread Designing a new router called Brevis-HD - Page 26


Page 26 of 28 FirstFirst ... 16232425262728 LastLast
Results 501 to 520 of 553

Thread: Designing a new router called Brevis-HD

  1. #501
    Member peteeng's Avatar
    Join Date
    Jul 2018
    Location
    dum dum
    Posts
    3486
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Hi Jayne - The machine has run for several hours successfully in its current form. The electronics have also run for years on another machine with the same loom. I expect the BOB has failed somehow. I have ordered a new one. I shall do a bit more digging then wait until the BOBs here. Peter



  2. #502
    Member peteeng's Avatar
    Join Date
    Jul 2018
    Location
    dum dum
    Posts
    3486
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Hi All - I picked up Brevis' resprayed parts today and the painter has done a top job. Makes me feel like revisiting it in production.... I'll recover Brevis from the Mens Shed and rebuild here. They have introduced a 2 jab policy to be on site and I don't get my second for 6 weeks.. Waiting for the new BOB for YaG patiently... Peter

    Attached Thumbnails Attached Thumbnails Designing a new router called Brevis-HD-repaint-1-jpg  


  3. #503
    Member peteeng's Avatar
    Join Date
    Jul 2018
    Location
    dum dum
    Posts
    3486
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Evening all - been a long day. I got up early today so I could finish early and get into YaG. I dislike Gremlins and I was convinced the BOB was the culprit, But I had an old laptop and a new UC100 put aside for Brevis#1 which I thought I could get running and use on YaG as an independent test to eliminate UCCNC and the UC100 from the mix. So I uploaded uccnc, failed, as it was Win7 so had to update the USB drives and the .NET software but that went smoothly. So now I had a functioning UCCNC/UC100 and connected that to YaG. Same behavior so that's "good" but not a solution. I've been running YaG with a false gantry so when the cars go different ways I don't break it! So I'm convinced its the BOB so have a good poke at it and the wires and one of the 5V outputs to a drive falls out. So check that out, replace and screw hard. Now it seems to run properly. So I set up a program and let it run and run. I jog this way and that and all seems good. But how far do you go until you trust this sucker!! So tomorrow I'm going to dial the current back on all the drives and do some more false gantry runs then reconnect the gantry... So it seems it was the BOB but its the wiring not the unit. That's fine the new BOB can go with Frankenrouter... hopefully all goes smooth tomorrow... Peter

    Attached Thumbnails Attached Thumbnails Designing a new router called Brevis-HD-loose-jpg   Designing a new router called Brevis-HD-false-gantry-dance-jpg  


  4. #504
    Member JayneV's Avatar
    Join Date
    Aug 2021
    Posts
    164
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Hi Peter,

    Glad you found where the gremlin was hiding. Hope everything behaves well from now on so you can make lots of dust.
    Jayne



  5. #505
    Member peteeng's Avatar
    Join Date
    Jul 2018
    Location
    dum dum
    Posts
    3486
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Not quite - The Y/A axis has been very good today but occasionally the X axis is odd. The g code says go left but it goes right on the first instruction which offsets the entire programme. So more trialing tomorrow and digging around. I'll put the other computer and UC100 onto the same programme and see what it does... I wasn't confident in the split connector block so changed that for a conventional one... Still random so very unexplainable...Peter



  6. #506
    Member peteeng's Avatar
    Join Date
    Jul 2018
    Location
    dum dum
    Posts
    3486
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Hi All - Some clues have come up today. I have been using the 5V output for the drives signal out of the BOB. I measure that voltage as 2.8V not 5V. So I got out the driver manual and it seems 3.5V is the trigger value so the voltage is low. So I plugged in a USB into the BOB and the voltage went to 4.8V and now all seems to be good. I'll do more trialing until I feel its solid then get some resistors and run at higher voltage from the PS or get a separate PS for the drives... hopefully have turned the corner on this little speed bump... Maybe the BOB is getting on so its V is down and this would explain why sometimes it doesn't move, sometimes it goes the wrong way and sometimes it plays ....Maybe in the past I've just been lucky using this output.. but thats what the diagram says to do...Peter

    Attached Thumbnails Attached Thumbnails Designing a new router called Brevis-HD-elec-cnc-5axis-breakout-07-jpg   Designing a new router called Brevis-HD-connection-2-jpg   Designing a new router called Brevis-HD-connection-1-jpg  


  7. #507
    Member peteeng's Avatar
    Join Date
    Jul 2018
    Location
    dum dum
    Posts
    3486
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Afternoon All - If I had a happy dance and you were here you'd see it. I've run my diagnostic start up, 2 test programs (one of which the X always goes the wrong way first move), return to zeros and high speed jogging (on 2 computers and UC100's) and all's GOOD Machines aren't haptic but this one now feels solid as the proverbial. So a quick rebuild and I can get Making again... what a difference 2V makes.

    I also have to rebuild Brevis#1 so have a few things on my plate....Peter



  8. #508
    Member peteeng's Avatar
    Join Date
    Jul 2018
    Location
    dum dum
    Posts
    3486
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Hi All - Back on track. Threshold 2 is done. Getting confident in YaG again. Now I need cleats for the workshop storage and the parts for the new bench....Peter

    Attached Thumbnails Attached Thumbnails Designing a new router called Brevis-HD-threshold-2-jpg  


  9. #509
    Member
    Join Date
    Apr 2007
    Location
    u s a
    Posts
    251
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    there is not much of a spread on the 5V logic for an active high or low signal so 2V is a big deal on that end. i think if you were to add a 5V power supply it would be solid for the system. those cheap breakout boards are touchy. i have the same one on the gantry machine i have and it has it's moments with the 5V logic getting power from the USB connection.



  10. #510
    Member peteeng's Avatar
    Join Date
    Jul 2018
    Location
    dum dum
    Posts
    3486
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Hi MD - Agreed, what sort of amperage for the power supply for 4 drives? Wouldn't need much being a signal voltage? I dug around in my old transformer box yesterday but no joy on 5V lots of 9V and 12V... may get some resistors for the 24V supply but that looks meshy....Peter



  11. #511
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    13128
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Quote Originally Posted by peteeng View Post
    Hi All - Some clues have come up today. I have been using the 5V output for the drives signal out of the BOB. I measure that voltage as 2.8V not 5V. So I got out the driver manual and it seems 3.5V is the trigger value so the voltage is low. So I plugged in a USB into the BOB and the voltage went to 4.8V and now all seems to be good. I'll do more trialing until I feel its solid then get some resistors and run at higher voltage from the PS or get a separate PS for the drives... hopefully have turned the corner on this little speed bump... Maybe the BOB is getting on so its V is down and this would explain why sometimes it doesn't move, sometimes it goes the wrong way and sometimes it plays ....Maybe in the past I've just been lucky using this output.. but thats what the diagram says to do...Peter
    All these Breakout Boards need a 5V supply, this turns on the opto's, they won't work very well with out it, just like the 12v it requires this is for the inputs and the spindle control don't use above 12v as the 12v to 24v is not correct, the voltage regulator will over heat with the 24v

    For the 5v supply 1A, old phone chargers are ideal

    Attached Thumbnails Attached Thumbnails Designing a new router called Brevis-HD-phone-charger-png  
    Mactec54


  12. #512
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    13128
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    If you are serious about your electrical you would be using this type of power supply, which you would have a 5v and a 12v just for the low voltage electronics

    Attached Thumbnails Attached Thumbnails Designing a new router called Brevis-HD-power-supply-png  
    Mactec54


  13. #513
    Member peteeng's Avatar
    Join Date
    Jul 2018
    Location
    dum dum
    Posts
    3486
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Hi M54 - yes that looks good. In future I'm thinking not to use this BOB. Does an AXBB-E ($320AUD) replace this BOB ($18AUD) and the UC100 ($200AUD) ? Reading thru stuff now for next router. Because what you are saying is the BOB still needs the USB power in for its opto system and the drivers still need the 5V supply....Peter



  14. #514
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    13128
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Quote Originally Posted by peteeng View Post
    Hi M54 - yes that looks good. In future I'm thinking not to use this BOB. Does an AXBB-E ($320AUD) replace this BOB ($18AUD) and the UC100 ($200AUD) ? Reading thru stuff now for next router. Because what you are saying is the BOB still needs the USB power in for its opto system and the drivers still need the 5V supply....Peter
    No almost all Breakout Boards need the 5v supply, unless they are 24v, you only need one 5v supply for that Breakout Board and a 12v for the inputs this is normal for any Breakout Board

    So if you have a 5v power supply connected to the Breakout Board, then you don't need the USB 5v supply, I don't know if the Breakout Board you have has the 2 option's.

    The opto's are there to protect the computer

    You still need a 5v and a 24v for the AXBB motion controller, it is Ethernet which can be better than USB, but for what you are doing with these builds the UC-100 is more than enough

    Mactec54


  15. #515
    Member
    Join Date
    Apr 2007
    Location
    u s a
    Posts
    251
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Quote Originally Posted by peteeng View Post
    Hi M54 - yes that looks good. In future I'm thinking not to use this BOB. Does an AXBB-E ($320AUD) replace this BOB ($18AUD) and the UC100 ($200AUD) ? Reading thru stuff now for next router. Because what you are saying is the BOB still needs the USB power in for its opto system and the drivers still need the 5V supply....Peter
    i do believe that would be an all in one solution Peter. the connection to the software is over a Ethernet cable. it does away with the BOB and UC100. looks like it has a 400kHz stepping frequency. i would think that should be fast enough for your needs.



  16. #516
    Member peteeng's Avatar
    Join Date
    Jul 2018
    Location
    dum dum
    Posts
    3486
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Hi - I'm always trying to reduce the part count and complexity. But the AXBB-E still needs 5V and 24V power. For the electronics guys, why do they make a device with a double power supply requirement? Why not make a device that only has the one input? Is a 5V power supply too big or onerous to include in the package? Not my area. My BrevisNo1 used a one box solution and it was so easy and cheap but stepperonline don't sell it anymore. 4 axis TB6560 driver $82AUD in an aluminium box plugs etc. Looking fwd to my Robot design I will need 6 or 7 axes... or more... Peter



  17. #517
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    13128
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Quote Originally Posted by peteeng View Post
    Hi - I'm always trying to reduce the part count and complexity. But the AXBB-E still needs 5V and 24V power. For the electronics guys, why do they make a device with a double power supply requirement? Why not make a device that only has the one input? Is a 5V power supply too big or onerous to include in the package? Not my area. My BrevisNo1 used a one box solution and it was so easy and cheap but stepperonline don't sell it anymore. 4 axis TB6560 driver $82AUD in an aluminium box plugs etc. Looking fwd to my Robot design I will need 6 or 7 axes... or more... Peter
    The Robot only needs 5 Axis for machining any more would be redundant

    Mactec54


  18. #518
    Member peteeng's Avatar
    Join Date
    Jul 2018
    Location
    dum dum
    Posts
    3486
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Hi M54 - but some of the axes need two motors so the slave count goes up.... Peter



  19. #519
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    13128
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Quote Originally Posted by peteeng View Post
    Hi M54 - but some of the axes need two motors so the slave count goes up.... Peter
    No if an Axis needs ( 2 ) motors ( 1 ) Axis output can run ( 2 ) motors, which is the best way to do it.

    Eding CNC only needs ( 1 ) 24v Power Supply this is a very good control package.

    Mactec54


  20. #520
    Member JayneV's Avatar
    Join Date
    Aug 2021
    Posts
    164
    Downloads
    0
    Uploads
    0

    Default Re: Designing a new router called Brevis-HD

    Quote Originally Posted by mactec54 View Post
    No if an Axis needs ( 2 ) motors ( 1 ) Axis output can run ( 2 ) motors, which is the best way to do it.

    Eding CNC only needs ( 1 ) 24v Power Supply this is a very good control package.
    If 1 output is running 2 motors, can each of the motor drive lines be properly homed? Is it possible due to tolerances between the drive screws or if one motor misses steps for some reason, tiny errors would accumulate over time and cause binding if both screws aren’t homed independently?
    Jayne



Page 26 of 28 FirstFirst ... 16232425262728 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Designing a new router called Brevis-HD

Designing a new router called Brevis-HD

Designing a new router called Brevis-HD