Problem Puma 400XLM M31 not working.

Results 1 to 5 of 5

Thread: Puma 400XLM M31 not working.

  1. #1

    Default Puma 400XLM M31 not working.

    Hi.

    I work on a Puma 400XLM with Fanuc 21iT control,
    To set up and move around the tailstock and steady rest I have written macros assigned to M codes, but these will only run when the chuck is clamped.

    I would like to be able to run these from MDI with an unclamped chuck.

    Any pointers to how I could get this working or how I should incorporate M31 in the macro to get it to work?

    Kind regards.

    Similar Threads:


  2. #2
    Member
    Join Date
    Nov 2007
    Location
    Canada and Nothern ireland
    Posts
    220
    Downloads
    0
    Uploads
    0

    Default Re: Puma 400XLM M31 not working.

    The Answer is in the Keep Replays but use at own risk and have a great day



  3. #3
    Member
    Join Date
    Sep 2007
    Location
    the netherlands
    Posts
    63
    Downloads
    4
    Uploads
    0

    Default Re: Puma 400XLM M31 not working.

    hi

    try starting with a closed chuck(with a dummy workpiece ) then M31 .

    O0001;
    M31;
    M69: (OPEN CHUCK)
    G461 V5; (GET TAILSTOCK ,)
    M32; (CANCEL SAFETY OVERRIDE)
    ; (youre program text)
    ;
    ;
    G460; (RETURN TAILSTOCK BACK TO REF POINT Z)
    M30

    Programs O9013 / O9014 are programmed by Doosan


    %
    O9013(G461 AUTO TAIL STOCK)
    (HK 08-09-2016)
    (SET PARA.6053 = 461)
    #3003=1(SINGLE BLOCK DISABLED)
    #20=#4120(GET TOOL NO.)
    #1101=1
    G28U0.
    T0000(OFFSET CANCEL)
    M05P11
    M79(TAIL STOCK QUILL RETRACT)
    G53G00Z[#500]
    (MOVING TO PTS POS.)
    M46(BAR INJECT)
    #21=#4005(GET MODAL)
    #100=#3005AND4(INCH/METRIX)
    IF[#100EQ4]THEN#23=80(INCH)
    IF[#100EQ0]THEN#23=1000(METRIX)

    #1=#4005
    IF[#1EQ98]GOTO100(G98 MODE CHECK)
    IF[#1EQ99]GOTO100(G99 MODE CHECK)
    GOTO101
    N100G98G1W2.5F200
    G53Z795F1000 (Z VALUE LENGTH OF MACHINE )
    N101
    G[#21]
    (MOVING WORKPIECE CORD.ZERO POS.)
    M47(BAR RETRACT)
    T[#20](RETURN OFFSET)
    #1101=0
    #500=#5022(SAVING PTS POSITION)
    #3003=0
    M99

    %
    O9014(G460 AUTO TAIL STOCK)
    (VER5.2,2A.M.Y TYPE,2011-08-17)
    (SET PARA.6054 = 460)
    #3003=1(SINGLE BLOCK DISABLED)
    #20=#4120(GET TOOL NO.)
    #1101=1
    G28U0.
    T0000(OFFSET CANCEL)
    M05P11
    M79(TAIL STOCK QUILL RETRACT)
    G53G00Z[#500]
    (MOVING TO PTS POS.)
    M46(BAR INJECT)
    #21=#4005(GET MODAL)
    #100=#3005AND4(INCH/METRIX)
    IF[#100EQ4]THEN#23=80(INCH)
    IF[#100EQ0]THEN#23=2000(METRIX)

    #1=#4005
    IF[#1EQ98]GOTO100(G98 MODE CHECK)
    IF[#1EQ99]GOTO100(G99 MODE CHECK)
    G94G01Z[#22]F[#23](G CODE SYSTEM B)
    GOTO101
    N100G98G01Z[#22]F[#23](G CODE SYSTEM A)
    N101
    G[#21]
    (MOVING WORKPIECE CORD.ZERO POS.)
    M47(BAR RETRACT)
    T[#20](RETURN OFFSET)
    #1101=0
    #500=#5022(SAVING PTS POSITION)
    #3003=0
    M99

    This is wath i juse on my machines
    trying is at youre owne risk

    hoop it works for you


    greetings Bertus.nl



  4. #4

    Default Re: Puma 400XLM M31 not working.

    Quote Originally Posted by lshingleton View Post
    The Answer is in the Keep Replays but use at own risk and have a great day
    I've looked it up and I have found the relevant Keep Relays and that would indeed sound like a solution. Only that leaves the possibility open that the program gets started with unclamped workpieces unless the operator is very careful and observant. I don't know if I trust my colleagues enough for that, and I don't want to get sacked when they **** it up for changes I made.

    @Bertus.nl Yes I have gotten M31 to work from a clamped situation, but that entirely defeats the purpose for my use. Our parts are the full range of the chuck and the full length range of the machine.
    I would like to be able the re setup the machine completely without needing to clamp or have clamped something of the current diameter.
    .
    I have attached the description of the M code in the reference book.

    Attached Thumbnails Attached Thumbnails Puma 400XLM M31 not working.-img_20210401_003727-jpg  


  5. #5
    Member
    Join Date
    Nov 2007
    Location
    Canada and Nothern ireland
    Posts
    220
    Downloads
    0
    Uploads
    0

    Default Re: Puma 400XLM M31 not working.

    Yes we ran many Automated machines this way and the real issue is the machine looking for the switches but if they are removed via this but it all comes with risk
    The ones i did it on was using the tail stock so the use of the Tail stock sensor made sure the part had been seated
    Good luck



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Puma 400XLM M31 not working.

Puma 400XLM M31 not working.

Puma 400XLM M31 not working.