Problem NVCM - outputs not functionning


Results 1 to 3 of 3

Thread: NVCM - outputs not functionning

  1. #1
    Member
    Join Date
    Mar 2021
    Posts
    7
    Downloads
    0
    Uploads
    0

    Default NVCM - outputs not functionning

    Hi,
    I have the NVCM6V2.1 board and I'm using Mach3.
    I'm trying to set an output and control it using M11/M10 but for some reason it does not succeed.
    What I've done so far: I have connected output TX16 to my laser module and defined it as output6 in Mach.
    For the test - If I'm setting the coolant to out 6 it can start and stop the laser, SO I know all electronics is connected fine. the pin is correct and output 6 is set properly.

    BUT...
    When I'm trying to use m11 command it does nothing. (tried all kind of syntaxes including the ones that includes movement like M11P6 G0 X100)

    How do I trigger outputs on the NVCM via Gcode?

    BTW,
    Just for the test, I created a new profile in Mach based on my current one and replaced the breakout board with an old LPT one that I have and there M11 does work so I assume mach's macros are ok (cannot use that board because it is short on ports)

    Thanks
    Gil

    Similar Threads:


  2. #2
    Member Khalid's Avatar
    Join Date
    Apr 2006
    Location
    Pakistan
    Posts
    3498
    Downloads
    0
    Uploads
    0

    Default Re: NVCM - outputs not functionning

    I trashed these boards ( had two of them ) , purchased UCCNC AXBB-E for my 4 axis and RosettaCNC for my 5 axes...

    http://free3dscans.blogspot.com/ http://my-woodcarving.blogspot.com/
    http://my-diysolarwind.blogspot.com/


  3. #3
    Member
    Join Date
    Mar 2021
    Posts
    7
    Downloads
    0
    Uploads
    0

    Default Re: NVCM - outputs not functionning

    Quote Originally Posted by Khalid View Post
    I trashed these boards ( had two of them ) , purchased UCCNC AXBB-E for my 4 axis and RosettaCNC for my 5 axes...
    I'm half way there ....
    Took this board off and connected my old, 1st lpt 5$ board and it is already better....



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

NVCM - outputs not functionning

NVCM - outputs not functionning

NVCM - outputs not functionning