Need Help! WIXHC MK6-V Motion card on Mach3 Enable output


Results 1 to 4 of 4

Thread: WIXHC MK6-V Motion card on Mach3 Enable output

  1. #1
    Member
    Join Date
    Feb 2016
    Posts
    41
    Downloads
    0
    Uploads
    0

    Default WIXHC MK6-V Motion card on Mach3 Enable output

    I have upgraded my breakout board with a USB MK6-V motion card. I'm having an issue with the enables outputs from Mach3. My gantry mill servo drives are staying enabled. I'm using outputs 3 and 4 for enables pin set. Mach 3 has them showing they are off when estopped. But the terminals stay on. I have checked the pinout 2 and 3 for the outputs on the card. When I hit my estop or click the reset"estop" on Mach3 screen they are staying on. Before the sway they would turn off. Then when cleared from Mach3 screen would enable. I tested the pinout as an output conf. and can turn the terminals on and off just fine. But set as an enable in output setting with the pinout 2 and 3 they just stay on? I would like the drives to be disabled when I hit the estop or as usually click the on screen reset "estop". Maybe the motion card doesn't work with MACH3 enable conf.? Can I set something to use a normal output setting to use as an enable when estopped?
    ThX

    Similar Threads:


  2. #2
    Member
    Join Date
    Feb 2016
    Posts
    41
    Downloads
    0
    Uploads
    0

    Default Re: WIXHC MK6-V Motion card on Mach3 Enable output

    The enable settings in Mach3 output conf. does not turn off the card output when the estop is pushed. Can a macro or brain be writen to make a mach3 "output" come on/off with the estop or mach3 screen estop?
    So the Mach3 screen would be turning on/off output #3 with estop. Rather than the enable #1. I have the pinout # set right I can manually turn them on/off when set as output #x.



  3. #3
    Community Moderator ger21's Avatar
    Join Date
    Mar 2003
    Location
    Shelby Township
    Posts
    34536
    Downloads
    0
    Uploads
    0

    Default Re: WIXHC MK6-V Motion card on Mach3 Enable output

    Most likely an issue with the plugin. Most if not all Chinese Mach3 controllers have some features that don't work properly.

    Gerry

    UCCNC 2017 Screenset
    http://www.thecncwoodworker.com/2017.html

    Mach3 2010 Screenset
    http://www.thecncwoodworker.com/2010.html

    JointCAM - CNC Dovetails & Box Joints
    http://www.g-forcecnc.com/jointcam.html

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)


  4. #4
    Member
    Join Date
    Feb 2016
    Posts
    41
    Downloads
    0
    Uploads
    0

    Default Re: WIXHC MK6-V Motion card on Mach3 Enable output

    OK. I figured how to fix my issue. I made a macro. M202 Activatesignal(OUTPUT3). Then went to General Config. to initialzation string added m202 and clicked ALL RESETS. Now Output #3 comes on/off on Mach3 and terminal. I tried all the same for ENABLE but didn't work. But that is fine I can use the labeled Outputs for each of my enables needed. Anyone could probably do this for anything on a output they would want to come on for when an estop isn't set. Enable just doesn't work for me with this card.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

WIXHC MK6-V Motion card on Mach3 Enable output

WIXHC MK6-V Motion card on Mach3 Enable output

WIXHC MK6-V Motion card on Mach3 Enable output