Hello All,
I have an older Full Spectrum 90 watt CO2 laser machine that continues to freeze up when the laser is to fire. The LCD says “job in progress” and the software freezes also. I have been in communication with the company and they have no clue why it is doing this. I’ve tested the connection to the machine by keeping the lid up to begin with, but as soon as I shut the lid, causing the laser to fire, there’s a loud jamming sound and it completely freezes. I’ve replaced the laser tube and the tube’s power supply, and the same thing happens (obviously, it has happened for quite a while!). At first, it would do it occasionally. I would take the air hose and blow out the connections around the tube, power supply, inside, control panel, etc., and it would start working. I thought I had it going ok, then the tube’s power supply went out and I had to replace it. Now it’s doing this every. Single. Time.... The techs at FS laser thought it was a grounding issue, but I’ve disconnected, cleaned, and reconnected all the ground wires securely with no luck. I’ve also tried disconnecting the LCD panel (another suggestion by them), and still does it. My laser is my main source of my business, and it has been months since I’ve been able to use it. Of course, the tech support at this company only communicates via email and it takes days (or weeks) for them to get back to me. I’ve tried googling this problem, and cannot find any solutions or possible causes for this. I cannot be the only person on the planet with this problem! Any and all suggestions would be appreciative! Thanks!

I’ll try to post a link to the video that shows what it is doing. Hopefully, you can view it.

Similar Threads: