Problem Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing! - Page 2


Page 2 of 2 FirstFirst 12
Results 21 to 36 of 36

Thread: Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

  1. #21
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    10683
    Downloads
    0
    Uploads
    0

    Default Re: Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

    Quote Originally Posted by dangerfox View Post
    How I set the spoil board thickness.

    1. plain spoil board on both sides.
    2. I load my compression bit in the spindle
    3. Zero out the spoil board thickness number in the machine control.
    4. I touch off the compression bit.
    5. Then manually touch the compression bit to the top of the spoil board.
    6. I go to the machine coordinates and the z access number on the "zero point access" page gives me my spoil board thickness.
    7. I enter that number into the zspoil box in settings and home the machine.
    8. I touch off every tool 2 times each and log all lengths in our machine note book.
    9. Start test cuts to make sure there are no issues. ( This part #9 has NEVER gone to plan with cut depths. )


    Thank you for all of your help!! It really means a lot to me!
    Looks like you have a good understanding of your control, I did not see this part in your list when you did your tool touch off after or at line #5

    Press TOOLS button to go to the tool page, then press "TEACH TOOL LOCATION" and then press "SET TOOL DATA

    Mactec54


  2. #22
    Member
    Join Date
    Sep 2017
    Posts
    21
    Downloads
    0
    Uploads
    0

    Default Re: Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

    Sorry I forgot to mention I have a "tool touch off" switch. When I touch each tool off it writes it in the control. Well in theory it does.



  3. #23
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    10683
    Downloads
    0
    Uploads
    0

    Default Re: Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

    Quote Originally Posted by dangerfox View Post
    Sorry I forgot to mention I have a "tool touch off" switch. When I touch each tool off it writes it in the control. Well in theory it does.
    I though you where trying it by manual setting the Tool OffSetts, Yes I know you have an auto Tool Setter

    So if you use the Auto Tool Setter you will be able to see what the Tool OffSets are, and then do a manual Tool Set and see if there is a difference, they should be both the same numbers in the Tool OffSet screen, use the same tool for both tests

    Mactec54


  4. #24
    Member
    Join Date
    Sep 2017
    Posts
    21
    Downloads
    0
    Uploads
    0

    Default Re: Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

    Quote Originally Posted by mactec54 View Post
    I though you where trying it by manual setting the Tool OffSetts, Yes I know you have an auto Tool Setter

    So if you use the Auto Tool Setter you will be able to see what the Tool OffSets are, and then do a manual Tool Set and see if there is a difference, they should be both the same numbers in the Tool OffSet screen, use the same tool for both tests

    Yes, I was doing the manual set as well. I would compare the two and they were pretty much right on together.



  5. #25
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    10683
    Downloads
    0
    Uploads
    0

    Default Re: Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

    Quote Originally Posted by dangerfox View Post
    Yes, I was doing the manual set as well. I would compare the two and they were pretty much right on together.
    So it seems that everything is working correct with the control, so all you have to do now is to get Vcarve to work correct which by the program that you posted, you have the Z axes settings setup incorrect as they are way off for the Z axes moves, you where trying to do

    In your program if you where trying to cut through the part The Z axes move would be Z0.00
    The Z moves in your program are Z.933 and some are Z- so anything with a Z-this number will cut into the spoil board

    N180 G01 Z0.2793 F70.9 ( Cutting into the Part )
    \
    N190 G00 Z0.9320 ( This is in most of the program and this would keep the Tool .200 above the part )

    N1080 G01 Z-0.0130 F70.9 ( This is cutting into the Spoil Board by .013" not much but is what you programed )

    Mactec54


  6. #26
    Member
    Join Date
    Sep 2017
    Posts
    21
    Downloads
    0
    Uploads
    0

    Default Re: Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

    Quote Originally Posted by mactec54 View Post
    So it seems that everything is working correct with the control, so all you have to do now is to get Vcarve to work correct which by the program that you posted, you have the Z axes settings setup incorrect as they are way off for the Z axes moves, you where trying to do

    In your program if you where trying to cut through the part The Z axes move would be Z0.00
    The Z moves in your program are Z.933 and some are Z- so anything with a Z-this number will cut into the spoil board

    N180 G01 Z0.2793 F70.9 ( Cutting into the Part )
    \
    N190 G00 Z0.9320 ( This is in most of the program and this would keep the Tool .200 above the part )

    N1080 G01 Z-0.0130 F70.9 ( This is cutting into the Spoil Board by .013" not much but is what you programed )

    Hey so sorry ive been out since Sunday due to my 2 yr old son broke his femur on Sunday afternoon. We just got home from the hospital yesterday. Its been a wild last few days!

    This makes sense. I was reading the code and trying to follow the moves it would be making. Im not sure why any of the Z would be changing + or -. Also why the depth would ever go to the .9320.

    Im doing a screen capture recording on the exact process to export code in VCarve. I'll upload it in a few min.

    Thanks again for your continued support!



  7. #27
    Member
    Join Date
    Sep 2017
    Posts
    21
    Downloads
    0
    Uploads
    0

    Default Re: Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

    Heres the link to the video I made of my VCarve process. Let me know if I'm doing anything wrong or if I need to change something.

    https://www.dropbox.com/s/l4uxhwwi3z...ocess.mov?dl=0



  8. #28

    Join Date
    Jun 2019
    Location
    ha noi
    Posts
    5
    Downloads
    0
    Uploads
    0

    Default

    Thank you. have a nice day!!!



  9. #29
    Member
    Join Date
    Sep 2017
    Posts
    21
    Downloads
    0
    Uploads
    0

    Default Re: Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

    Quote Originally Posted by mactec54 View Post
    So it seems that everything is working correct with the control, so all you have to do now is to get Vcarve to work correct which by the program that you posted, you have the Z axes settings setup incorrect as they are way off for the Z axes moves, you where trying to do

    In your program if you where trying to cut through the part The Z axes move would be Z0.00
    The Z moves in your program are Z.933 and some are Z- so anything with a Z-this number will cut into the spoil board

    N180 G01 Z0.2793 F70.9 ( Cutting into the Part )
    \
    N190 G00 Z0.9320 ( This is in most of the program and this would keep the Tool .200 above the part )

    N1080 G01 Z-0.0130 F70.9 ( This is cutting into the Spoil Board by .013" not much but is what you programed )
    Did you happen to catch the video?



  10. #30
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    10683
    Downloads
    0
    Uploads
    0

    Default Re: Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

    Quote Originally Posted by dangerfox View Post
    Did you happen to catch the video?
    Sorry missed it, I had a quick look and most seemed ok, do you do a preview of the cut before you make the G-code file, and then post the code here and I will check it

    Mactec54


  11. #31
    Member
    Join Date
    Sep 2017
    Posts
    21
    Downloads
    0
    Uploads
    0

    Default Re: Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

    Quote Originally Posted by mactec54 View Post
    Sorry missed it, I had a quick look and most seemed ok, do you do a preview of the cut before you make the G-code file, and then post the code here and I will check it
    I checked two different files. The first file is what I've been working on, The second is a new file with a new shape, same thickness material and same cut depth. The tool is a stock .25 vCarve tool. Compare the two.

    Attached Files Attached Files


  12. #32
    Member
    Join Date
    Sep 2017
    Posts
    21
    Downloads
    0
    Uploads
    0

    Default Re: Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

    I'm still thinking it's the machine. I've been reading the coding and it seems to be right. if the machine is changing the tool lengths that would cause the problem-- especially since the cut depths are very erratic and never the same from file to file. But my cut depths and material stays the exact same in every file.



  13. #33
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    10683
    Downloads
    0
    Uploads
    0

    Default Re: Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

    Quote Originally Posted by dangerfox View Post
    I checked two different files. The first file is what I've been working on, The second is a new file with a new shape, same thickness material and same cut depth. The tool is a stock .25 vCarve tool. Compare the two.
    I did check your programs, they are no processed very well, and I could not run either until I changed some of the lines

    Dwell is normally G4 P5 not G04 5 I'm surprised it runs on your control like this although I have seen this before and can be just for your control

    These lines need the inside brackets removed

    (T5 = End Mill (0.25 inch))

    (T5 = Vortex - 1/4 Compression (.25))

    N90 (Tool: End Mill (0.25 inch))


    (T5 = Vortex - 1/4 Compression .25 ) This is normal

    N90 (Tool: End Mill 0.25 inch )

    Measure the amount the cutter is out of the holder, and then after you have used it, the tool could be moving out in the holder from not being torqued up enough

    Both programs are using the same cut depths but the Z clearance is very different

    Mactec54


  14. #34
    Member
    Join Date
    Sep 2017
    Posts
    21
    Downloads
    0
    Uploads
    0

    Default

    Quote Originally Posted by mactec54 View Post
    I did check your programs, they are no processed very well, and I could not run either until I changed some of the lines

    Dwell is normally G4 P5 not G04 5 I'm surprised it runs on your control like this although I have seen this before and can be just for your control

    These lines need the inside brackets removed

    (T5 = End Mill (0.25 inch))

    (T5 = Vortex - 1/4 Compression (.25))

    N90 (Tool: End Mill (0.25 inch))


    (T5 = Vortex - 1/4 Compression .25 ) This is normal

    N90 (Tool: End Mill 0.25 inch )

    Measure the amount the cutter is out of the holder, and then after you have used it, the tool could be moving out in the holder from not being torqued up enough

    Both programs are using the same cut depths but the Z clearance is very different
    When you say “dwell” are you meaning the dwell at the bottoms of a hole function? If so, that function has never been checked in any of the drill tool paths I have.

    It’s funny you say they are not processed very well, cause this is the post processor Laguna provides. The longer I have this machine the more I want to get rid of it. The deeper I get into learning about these machines and how they function, the more I notice details Laguna failed to quality check. For a $50k+ price tag those issues shouldn’t be there!

    I’m gonna get on the phone with Laguna today and see if They have a solution as well. Maybe work it from the machine side for a min.

    Any other thoughts moving forward?

    I also went and bought a surface pro 6 to run VCarve from. I’ve been using Parallels on my MacBook Pro to run everything. I though that might be causing an issue. But that’s not been the case with the latest round of gcoding I’ve sent.



  15. #35
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    10683
    Downloads
    0
    Uploads
    0

    Default Re: Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

    Quote Originally Posted by dangerfox View Post
    When you say “dwell” are you meaning the dwell at the bottoms of a hole function? If so, that function has never been checked in any of the drill tool paths I have.

    It’s funny you say they are not processed very well, cause this is the post processor Laguna provides. The longer I have this machine the more I want to get rid of it. The deeper I get into learning about these machines and how they function, the more I notice details Laguna failed to quality check. For a $50k+ price tag those issues shouldn’t be there!

    I’m gonna get on the phone with Laguna today and see if They have a solution as well. Maybe work it from the machine side for a min.

    Any other thoughts moving forward?

    I also went and bought a surface pro 6 to run VCarve from. I’ve been using Parallels on my MacBook Pro to run everything. I though that might be causing an issue. But that’s not been the case with the latest round of gcoding I’ve sent.
    No the Dwell is at each tool change it is normally used to wait for the spindle to get up to speed, so this is normal to have this for machines like this it is just the format they are using that is different, and this may be just to suit your control

    I'm sure the postprocessor can corrected there is a G70 in there also that is being used incorrectly and the brackets the dwell is normal they are just using a different format for it

    I don't think it is a computer problem but a windows computer is more suited to the programs you are using

    Everything looks to be ok and the programs do run, so I would be checking next that the Cutters are not pulling out of the tool holder going that deep this can happen

    Mactec54


  16. #36
    Member
    Join Date
    Mar 2017
    Location
    United States
    Posts
    273
    Downloads
    0
    Uploads
    0

    Default Re: Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

    Is it possible that your home switch is moving from home cycle to home cycle?



  17. #37
    jackvo183's Avatar
    Join Date
    Sep 2019
    Location
    Ho Chi Minh
    Posts
    2
    Downloads
    0
    Uploads
    0

    Default

    Thanks Too,
    How to get started?
    To get started you have a few options, By default all tutorial videos are displayed in the recommended order, this will help you understand all of the features within the software, however we appreciate that you may only be using Vectric software to accomplish a specific type of job, like sign making for instance. So we have created playlists to help shortcut your learning in a more tailored way. Use the options to choose your most preferred method of learning.



Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!

Laguna SmartShop 2 or Vcarve issue? - Tool Lengths changing!