Need Help! CNC 6040 - X-Axis stutters and Jitters when moving x-, x+ is fine


Results 1 to 6 of 6

Thread: CNC 6040 - X-Axis stutters and Jitters when moving x-, x+ is fine

  1. #1
    Member k0s's Avatar
    Join Date
    Aug 2020
    Posts
    6
    Downloads
    0
    Uploads
    0

    Question CNC 6040 - X-Axis stutters and Jitters when moving x-, x+ is fine

    Hello,

    This is my first post and "hi everyone".

    I recently started with milling machines (again.. its been 20 years ago and i aint had problems,.. just Carbon cutting) - but i am more a FDM - SLA - mSLA guy.
    Anyway

    Pre Problem : I bought a CNC 6040 which is chinaware from a german warehouse - aside from that it seemed to be a used one i was quit happy except the Y-Axis which is not stiff enough (not railed).

    When i started the first milling trys on MDF i noticed that several things happen and can be reduced to the same problem:

    Problem 1: Multilayer Carving - the second and third layers are always shifted between 1 and 2 mm to the right.
    Switched X and Y Axis and the problem persists - so its shifting upwards about 1-2 mm.

    I read it might be a defective driver - well.... tell me ?

    Problem 2:

    Z-axis does start to stutter/Jitter SOMETIMES when moving down - sounds it like skipping steps (same as you would hear when watching the video - but more seldom but heavier.. and you see the handwheel jumps)

    What RALLY makes me wonder is: Jog Movements or using Arrow Keys with Mach3 makes no problem - Typing in the MDI related gcode like x-140 makes the trouble.
    Thanks for ANY input!

    Video :



    Machine :

    CNC 6040 - watercooled
    1.5 kw
    BSMCE04U-PP Board
    TX14207 Drivers

    If you need anything else, please drop me a line.
    Thank you VERY MUCH

    Similar Threads:


  2. #2
    Member k0s's Avatar
    Join Date
    Aug 2020
    Posts
    6
    Downloads
    0
    Uploads
    0

    Default Re: CNC 6040 - X-Axis stutters and Jitters when moving x-, x+ is fine

    Thanks, it is a hardware / driver fault. I switched the 4th (A) axis with the X, since i barely use the A Axis - problem solved.
    Just waiting to get a new exchange.

    But while i am on this and the Drivers are REALLY QUIT GARBAGE :

    Do you know DECENT drivers which can be used in exchange for the TX14207? Do i really need to go for Leadshine? - on the other hand 59Bucks for a Driver shouldnt be the problem - if thats the price

    regArts



  3. #3
    Member k0s's Avatar
    Join Date
    Aug 2020
    Posts
    6
    Downloads
    0
    Uploads
    0

    Default Re: CNC 6040 - X-Axis stutters and Jitters when moving x-, x+ is fine

    Ok,

    i tried simple elements like circles and what i have noticed as well is shown in the video :



    At the moment where the direction change occours for the circle, the motor is like jittering or losing steps...
    i have forgotten where i did read how to fix that... it was by adjusting values for the motor tuning.



    This is the "off" for the axis for small circles 15mm and 60mm ... at the end you see the result after the 4th repeat of the same gcode..



    thanks and regards



  4. #4
    Member
    Join Date
    Sep 2020
    Posts
    5
    Downloads
    0
    Uploads
    0

    Default

    Quote Originally Posted by k0s View Post
    Ok,

    i tried simple elements like circles and what i have noticed as well is shown in the video :



    At the moment where the direction change occours for the circle, the motor is like jittering or losing steps...
    i have forgotten where i did read how to fix that... it was by adjusting values for the motor tuning.



    This is the "off" for the axis for small circles 15mm and 60mm ... at the end you see the result after the 4th repeat of the same gcode..



    thanks and regards
    Did you even fix that? Im having a similar problem on all my axis . I have the EXACT same machine as yours



  5. #5
    Member
    Join Date
    Feb 2015
    Posts
    11
    Downloads
    0
    Uploads
    0

    Default Re: CNC 6040 - X-Axis stutters and Jitters when moving x-, x+ is fine

    To me that sounds like a bearing that is running really ruff in the negative direction. What are they using for bearings?



  6. #6
    Member k0s's Avatar
    Join Date
    Aug 2020
    Posts
    6
    Downloads
    0
    Uploads
    0

    Angry Re: CNC 6040 - X-Axis stutters and Jitters when moving x-, x+ is fine

    The simple solution was:

    get a new driver i just ordererd new Lichuan drivers, set them up and et voila - sound was more like with pro driver boards (like you hear nothing) movement was smooth and everything was fine.

    i received a replacement driver by the manufacturer but this one was **** as well. so i gone for new ones. the lichuan are around 35€ for me.

    as a side node: the new driver boards fit perfectly in, even the holes are already made in the case xD looks like they shipped a while ago more quality boards with that unit


    enjoy good luck...
    and @jimgeo7 :

    no .. why you think its a bearing? this would lead any other user to a complete wrong direction.. so better keep such guessing for you

    thanks anyways for nothing

    Attached Thumbnails Attached Thumbnails CNC 6040 - X-Axis stutters and Jitters when moving x-, x+ is fine-lichuan-jpg  


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

CNC 6040 - X-Axis stutters and Jitters when moving x-, x+ is fine

CNC 6040 - X-Axis stutters and Jitters when moving x-, x+ is fine

CNC 6040 - X-Axis stutters and Jitters when moving x-, x+ is fine