My First Mill/Turn Post


Results 1 to 2 of 2

Thread: My First Mill/Turn Post

  1. #1
    Member
    Join Date
    Oct 2008
    Location
    USA
    Posts
    3
    Downloads
    1
    Uploads
    0

    Default My First Mill/Turn Post

    I am trying to make my first mill/turn post for a Haas ST30Y and running into a couple issues.

    First question... I'm using the tutorial 5 axis post source as a starting point. Is that a good idea or is there a better source file to start from?

    Second question: Trying to understand how they calculate things between all the different files. I'm trying to put the live tool rpm in with a P instead of an S. How do I get the variable for the Spindle speed? I tried this:

    Code:
    :T:IF OPR_SPEED>0 THEN <N><G!:97><M!:SPINDLE_DIR><P!:OPR_SPEED_RPM><EOL>ENDIF
    in my :SECTION=SUB_TOOL_CHANGE_MILL and get this output:

    Code:
    G97 M133 P1   (<--Supposed to be P5000)
    The tutorial Post uses <S!> to output S and the spindle speed (S5000 in this example). I can't follow exactly what is happening with it. I think that it is calling the attribute S in the millturn.lib file which is calling the CALC_DEC_REGISTER section? I tried imitating this with a P attribute but didn't work out for me.

    Any help would sure be appreciated.

    Similar Threads:


  2. #2
    Member
    Join Date
    Oct 2008
    Location
    USA
    Posts
    3
    Downloads
    1
    Uploads
    0

    Default Re: My First Mill/Turn Post

    I answered one of my questions. The mill spindle speeds are a different system variable than the lathe spindle speeds so this worked:

    Code:
    :T:IF OPR_SPEED>0 THEN <N><G!:97><M!:SPINDLE_DIR> P<%:OPR_SPEED><EOL>ENDIF
    and gave me the code I was expecting:

    Code:
    G97 M133 P5000
    I had tried this before the op but I didn't have the integer casting % in front of it so it didn't work.

    I'd still love some input on my other question... Is the tutorial mill/turn post the best way to start a new mill/turn post processor file? Are there any major known issues with it? With 3 axis mill and 2 axis lathe posts, I have always started from a file generated in the UPG but it seems that option isn't available for mill/turn and the tutorial ones are the only ones I can find to start from. We've been using HSM Works for the past few years and I got spoiled because they have a slew of posts available in source code that can be easily modified in java. I haven't written a CAMWorks post for about 10 years so I'm a little rusty with this frustrating mess.

    Thank you much,
    Ryan



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

My First Mill/Turn Post

My First Mill/Turn Post

My First Mill/Turn Post