Need Help! G41 BOMBS every time in post process Haas VF3 CAMWorks


Results 1 to 3 of 3

Thread: G41 BOMBS every time in post process Haas VF3 CAMWorks

  1. #1
    Registered hutch07's Avatar
    Join Date
    Sep 2007
    Location
    usa
    Posts
    120
    Downloads
    0
    Uploads
    0

    Default G41 BOMBS every time in post process Haas VF3 CAMWorks

    I have a simple profile and no matter what I choose on CAMWorks for Solidworks 2018 , the post processor will not get it correct. I am running this on a Haas VF3 and this actually calculates I and J incorrectly every time. Below is the post. I did find a reference to the lead in value but nothing seems to work there either. I have a 0.498" Endmill and it has the correct diameter offset in the machine. The roughing post works but there is no G41 in that one. I get Tool Compensation errors every time.
    %
    O03106(LEAD IN AMOUNT)
    G20 G17 G40 G80 G90
    T06 M06 (1/2 EM CRB 4FL 1 LOC)
    G54 G90 G94
    S3000 M03
    G00 G90 X-.4631 Y.2204
    G43 H06 Z1.1 M08
    G01 Z.75 F35.
    G90 G41 X-.2793 Y.4043 D06
    G03 X-.25 Y.475 I-.0707 J.0707 (dead here)
    G01 Y1.75
    X.5
    G02 X1.35 Y.9 I0 J-.85
    G01 Y.6663

    Similar Threads:


  2. #2
    Registered hutch07's Avatar
    Join Date
    Sep 2007
    Location
    usa
    Posts
    120
    Downloads
    0
    Uploads
    0

    Default Re: G41 BOMBS every time in post process Haas VF3 CAMWorks

    It looks like if I use near zero "D" offsets this will run. This post processor looks like it sucks.... Is there a way to have it use actual tool diameters in the machine or only zero with a bit of wear?



  3. #3
    Registered hutch07's Avatar
    Join Date
    Sep 2007
    Location
    usa
    Posts
    120
    Downloads
    0
    Uploads
    0

    Default Re: G41 BOMBS every time in post process Haas VF3 CAMWorks

    G41 BOMBS every time in post process Haas VF3 CAMWorks-comp2018-jpg I had to add compensation to the lead in lead out and tweak the settings on the profile. There must be a default setting to make sure this is always on. I'll check.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

G41 BOMBS every time in post process Haas VF3 CAMWorks

G41 BOMBS every time in post process Haas VF3 CAMWorks