Need Help! Heidenhain TNC 150B Problem on Bridgeport Interact 1


Results 1 to 7 of 7

Thread: Heidenhain TNC 150B Problem on Bridgeport Interact 1

  1. #1
    Member
    Join Date
    May 2006
    Location
    United Kingdom
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default Heidenhain TNC 150B Problem on Bridgeport Interact 1

    Hi, I have a problem with a TNC 150B on an Interact 1. When the machine is turned on the control goes through it's start up sequence apparently normally and ends up at it's normal POWER INTERRUPTED display with the normal various position coordinates. All the Leds are lit on the panel as normal, but when I press CE to proceed to the referencing stage nothing happens. I have tested all of the buttons on the front panel and they all work as they should. I have also tested the 24v DC supply and all of the inputs i.e. reference switches, limit switches etc. I think the fault is probably in the control itself but if anyone has any ideas on where the fault may lie or what may be causing it I would be grateful.
    Thank you
    S P Hill

    Similar Threads:


  2. #2
    Member
    Join Date
    Nov 2016
    Location
    United Kingdom
    Posts
    28
    Downloads
    0
    Uploads
    0

    Default

    As stupid as it sounds check all the emergency stops are out. I thought it was CE then cycle start to punch through each referencing but I maybe misremembering

    Quote Originally Posted by sphill View Post
    Hi, I have a problem with a TNC 150B on an Interact 1. When the machine is turned on the control goes through it's start up sequence apparently normally and ends up at it's normal POWER INTERRUPTED display with the normal various position coordinates. All the Leds are lit on the panel as normal, but when I press CE to proceed to the referencing stage nothing happens. I have tested all of the buttons on the front panel and they all work as they should. I have also tested the 24v DC supply and all of the inputs i.e. reference switches, limit switches etc. I think the fault is probably in the control itself but if anyone has any ideas on where the fault may lie or what may be causing it I would be grateful.
    Thank you
    S P Hill




  3. #3
    Member
    Join Date
    May 2006
    Location
    United Kingdom
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default Re: Heidenhain TNC 150B Problem on Bridgeport Interact 1

    Hi, Yes I checked the emergency stops and just about every other reference and limit switch I could find on the circuit diagram. I have also checked the supplies 110ac and 24Vdc and all of the overloads on the motors etc. The control just ignores me pushing the CE button and will not proceed to the next stage. I have come to the conclusion that the fault is in the control itself but I am open to any help or advice that would help me solve this problem.
    Thank you for your reply.



  4. #4
    Member
    Join Date
    Jan 2005
    Location
    us
    Posts
    1098
    Downloads
    0
    Uploads
    0

    Default Re: Heidenhain TNC 150B Problem on Bridgeport Interact 1

    When you press CE do the LED's go out ?

    Is this machine new to you? IOW has it run before?

    the process is CE, Power Enable, then run[Z home], run[[Xor Y home] ,[Yor X home]

    If you hit CE and the leds go out, and the screen shows the axis waiting to home, hit power enable, then when you hit 'run' it does nothing, it is most likely the EMO.

    Check the oil

    If the LEDS don't go out, then something is internally wrong



  5. #5
    Member
    Join Date
    May 2006
    Location
    United Kingdom
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default Re: Heidenhain TNC 150B Problem on Bridgeport Interact 1

    Hi Gus, thanks for your reply. In answer to your questions.

    No, I have had the machine for over ten years and yes it has run properly before. It started out with a TNC145 control but that died and I upgraded it to a TNC 150B at least eight years ago and it has worked fine up until about 18 months ago when it was working one day and the next it was like it is now.

    When I hit CE it does nothing, the leds do not go out and the screen does not change. As you can see from my earlier posts I think that I have checked pretty much every thing that I can think of, including the lube oil.

    I had come to the conclusion that there was something wrong with the control itself rather than the machine as you seem to have at the end of your reply.

    Thanks Simon.



  6. #6
    Member
    Join Date
    Nov 2016
    Location
    United Kingdom
    Posts
    28
    Downloads
    0
    Uploads
    0

    Default Re: Heidenhain TNC 150B Problem on Bridgeport Interact 1

    What happens if you disconnect the axis from the controller one by one? Might be a way of working out if its the controller or something else.

    I will hopefully have a TNC145 becoming available once I get up the courage to fit the TNC151 and input the parameters. It is concern about getting the latter wrong that is stopping me. Drop me a PM if you are interested.

    Thanks

    Andrew



  7. #7
    Member
    Join Date
    May 2006
    Location
    United Kingdom
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default Re: Heidenhain TNC 150B Problem on Bridgeport Interact 1

    Hi Handi-andi

    I haven't tried that but about 3 years ago the machine would blow a main fuse when the drive power was enabled. This turned out to be carbon deposits on the armature and brush gear of the X axis motor which after dismantling and some careful cleaning was resolved. This fault however did not seem to affect the operation of the controller. I will try what you suggest although I have checked pretty much everything shown on the circuit diagram that is connected to the controller.
    Thanks for the offer of the TNC145 but after using the TNC150 with it's 3D capability I wouldn't want to go back. Upgrading the controller is fairly simple, you may have to rewire the feed rate pot otherwise the wiring is the same as the 145. I guess maybe someone on the forum would be able to supply you with a suitable set of parameters for your machine if you don't have them already.

    Thanks

    Simon.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Heidenhain TNC 150B Problem on Bridgeport Interact 1

Heidenhain TNC 150B Problem on Bridgeport Interact 1

Heidenhain TNC 150B Problem on Bridgeport Interact 1