Problem Posting is showing T code twice in one operation


Results 1 to 5 of 5

Thread: Posting is showing T code twice in one operation

  1. #1
    Member james1701d's Avatar
    Join Date
    Nov 2020
    Posts
    2
    Downloads
    0
    Uploads
    0

    Default Posting is showing T code twice in one operation

    (FEATURE MILL FACING - FACING)
    ( FIRST CUT - FIRST TOOL)
    N05 T6 M06 (2 FACE MILL)
    N06 T1
    N07 G54 G90
    N08 G00 X-4.6024 Y6.0002 S3500 M03
    N09 G43 H6 Z1.

    why is this showing Tool 6, then on the next line it shows T1.

    Very confused.

    James

    Similar Threads:


  2. #2
    Member machinehop5's Avatar
    Join Date
    Aug 2009
    Location
    United States
    Posts
    824
    Downloads
    2
    Uploads
    0

    Default Re: Posting is showing T code twice in one operation

    Quote Originally Posted by james1701d View Post
    (FEATURE MILL FACING - FACING)
    ( FIRST CUT - FIRST TOOL)
    N05 T6 M06 (2 FACE MILL)
    N06 T1
    N07 G54 G90
    N08 G00 X-4.6024 Y6.0002 S3500 M03
    N09 G43 H6 Z1.

    why is this showing Tool 6, then on the next line it shows T1.

    Very confused.

    James
    N06 T1 is pre-staging next tool? If, you have a Auto Tool Changer. Fadal's use T-1



  3. #3
    Flies Fast Superman's Avatar
    Join Date
    Dec 2008
    Location
    Antarctica
    Posts
    2804
    Downloads
    0
    Uploads
    0

    Default Re: Posting is showing T code twice in one operation

    This is called tool pre-staging.

    M6 is actually the toolchange
    The T is placing the tool in the magazine exchange position.

    Obviously you have not run the code in the machine.
    T6 M6 readies and then places the tool into the spindle
    T1 then readies the next tool while the machine is using the T6.

    This programming method is not suitable where tool is exchanged by the spindle into the carousel (tree) type magazine or a tool rack. Your machine should have a toolchange arm that holds 2 tools.



  4. #4
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    11911
    Downloads
    0
    Uploads
    0

    Default Re: Posting is showing T code twice in one operation

    Quote Originally Posted by james1701d View Post
    (FEATURE MILL FACING - FACING)
    ( FIRST CUT - FIRST TOOL)
    N05 T6 M06 (2 FACE MILL)
    N06 T1
    N07 G54 G90
    N08 G00 X-4.6024 Y6.0002 S3500 M03
    N09 G43 H6 Z1.

    why is this showing Tool 6, then on the next line it shows T1.

    Very confused.

    James
    It would depend on your control and machine if it has pre staging of the next tool

    If this is not what you want then it needs to be changed in the Postprocessor or choose another post processor that does not add the T1 you can also delete that line by editing your program

    Mactec54


  5. #5
    Member james1701d's Avatar
    Join Date
    Nov 2020
    Posts
    2
    Downloads
    0
    Uploads
    0

    Default Re: Posting is showing T code twice in one operation

    Thanks guys. That makes sense. Since we updated the software we have seen some odd changes in the code.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Posting is showing T code twice in one operation

Posting is showing T code twice in one operation

Posting is showing T code twice in one operation