M6 START manual tool change trouble


Results 1 to 2 of 2

Thread: M6 START manual tool change trouble

  1. #1
    Registered
    Join Date
    Feb 2014
    Location
    USA
    Posts
    144
    Downloads
    0
    Uploads
    0

    Default M6 START manual tool change trouble

    Ok I have this M6Start Manual tool change macro that I will attach. Background, Motor Home/Soft Limits, Z axis setting Soft Max (0) Soft Min (-9) Slow zone (1.0) Home Off (-.25). I home the machine at start up, move the X,Y, and Z to just a spot on the table. I then type M6T2....ex. for the tool change. The table moves to the Tool change location ask me to insert the tool, I do and then press OK. When I press "OK" the X and Y try to return to the say G54 or 55 so on. The Z however goes up and hits the soft limit and then halts everything, why is the question. The X and Y no problem but the Z sure is.

    My tool change location is X 2.5, Y 2.0, Z -1.0. For the life of me I can not figure this out. Any help would be great or ideas.

    Thanks,

    Similar Threads:
    Attached Files Attached Files


  2. #2
    Registered
    Join Date
    Feb 2014
    Location
    USA
    Posts
    144
    Downloads
    0
    Uploads
    0

    Default Re: M6 START manual tool change trouble

    Quote Originally Posted by ballistic42 View Post
    Ok I have this M6Start Manual tool change macro that I will attach. Background, Motor Home/Soft Limits, Z axis setting Soft Max (0) Soft Min (-9) Slow zone (1.0) Home Off (-.25). I home the machine at start up, move the X,Y, and Z to just a spot on the table. I then type M6T2....ex. for the tool change. The table moves to the Tool change location ask me to insert the tool, I do and then press OK. When I press "OK" the X and Y try to return to the say G54 or 55 so on. The Z however goes up and hits the soft limit and then halts everything, why is the question. The X and Y no problem but the Z sure is.

    My tool change location is X 2.5, Y 2.0, Z -1.0. For the life of me I can not figure this out. Any help would be great or ideas.

    Thanks,
    Ok well try try try until you succeed! Its amazing that just a small line out of place what it will do. Fixed the problem and the code works just like It should.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

M6 START manual tool change trouble

M6 START manual tool change trouble