I need help to solve a ATC issue on a machining center - Page 2

Page 2 of 2 FirstFirst 12
Results 21 to 37 of 37

Thread: I need help to solve a ATC issue on a machining center

  1. #21
    Member kike_c's Avatar
    Join Date
    Mar 2020
    Posts
    17
    Downloads
    0
    Uploads
    0

    Smile Re: I need help to solve a ATC issue on a machining center

    Quote Originally Posted by kike_c View Post
    Which are these machine condition ?
    What is next logical step?
    Which are diagnostic bit I should check ?
    Hello Guys,

    Any suggestion for questions listed above will be highly appreciated.

    Thank you.



  2. #22
    Member Kelsang-Lungta's Avatar
    Join Date
    Nov 2019
    Posts
    54
    Downloads
    0
    Uploads
    0

    Default Re: I need help to solve a ATC issue on a machining center

    No apologies and no need for sorrow friend.
    We all learn something.
    The moment you recognize you don’t know something, is the very same moment you begin to know something. ????



  3. #23
    Member kike_c's Avatar
    Join Date
    Mar 2020
    Posts
    17
    Downloads
    0
    Uploads
    0

    Default Re: I need help to solve a ATC issue on a machining center

    It is true and you are right, Kelsang-Lungta.



  4. #24
    Member
    Join Date
    Jan 2017
    Location
    Lithuania
    Posts
    17
    Downloads
    0
    Uploads
    0

    Default Re: I need help to solve a ATC issue on a machining center

    in fanuc it is table of tools maybe yoiu want to take tool that doesn't exest in tool table?

    Hurco BMC 2416


  5. #25
    Member kike_c's Avatar
    Join Date
    Mar 2020
    Posts
    17
    Downloads
    0
    Uploads
    0

    Smile Re: I need help to solve a ATC issue on a machining center

    Quote Originally Posted by noexit View Post
    in fanuc it is table of tools maybe yoiu want to take tool that doesn't exest in tool table?
    I tried with twenty different tool number, from T1 to T20. Maybe the tools have a different name, but i do not find a tool screen or tool list.

    If anyone can apoort a machine parameter to initialize tool magazine counter it would be great!



  6. #26
    Member Kelsang-Lungta's Avatar
    Join Date
    Nov 2019
    Posts
    54
    Downloads
    0
    Uploads
    0

    Default Re: I need help to solve a ATC issue on a machining center

    Can you take a photo of your control panel and attach it?



  7. #27
    Member kike_c's Avatar
    Join Date
    Mar 2020
    Posts
    17
    Downloads
    0
    Uploads
    0

    Default Re: I need help to solve a ATC issue on a machining center

    Quote Originally Posted by Kelsang-Lungta View Post
    Can you take a photo of your control panel and attach it?
    Hello Kelsang-Lungta,

    I attached two pics, control panel and display with user message.

    Attached Thumbnails Attached Thumbnails I need help to solve a ATC issue on a machining center-user-message-jpg   I need help to solve a ATC issue on a machining center-panel-control-png  
    Last edited by kike_c; 03-12-2020 at 05:18 PM. Reason: I do no see attached pics


  8. #28
    Member
    Join Date
    May 2016
    Location
    United States
    Posts
    217
    Downloads
    0
    Uploads
    0

    Default Re: I need help to solve a ATC issue on a machining center

    A message like that is going to be MTB defined. It would be in your manufacturer's error code books if you have them. To me that sounds like a physical sensor mounted on or near the tool carousel that counts the carousels individual rotational movements. This could be disconnected or have wet or broken wires or missing completely. To me this does not sound like a missing parameter issue but a control not getting the carousels movement information it needs to know what tool is in what position. It is confused.

    Just my take on it.

    What's funny in this situation is the MTB spelled Magazine wrong. Hilarious!



  9. #29
    Member kike_c's Avatar
    Join Date
    Mar 2020
    Posts
    17
    Downloads
    0
    Uploads
    0

    Default Re: I need help to solve a ATC issue on a machining center

    Quote Originally Posted by the_gentlegiant View Post
    A message like that is going to be MTB defined. It would be in your manufacturer's error code books if you have them. To me that sounds like a physical sensor mounted on or near the tool carousel that counts the carousels individual rotational movements. This could be disconnected or have wet or broken wires or missing completely. To me this does not sound like a missing parameter issue but a control not getting the carousels movement information it needs to know what tool is in what position. It is confused.

    Just my take on it.

    What's funny in this situation is the MTB spelled Magazine wrong. Hilarious!

    I noticed that it's possible to rotate tool magazine in manual mode (there are 3 proximity sensor mounted on tool magazine ).

    I checked the three corresponding signals on the diagnostic screen and bits changed from "0" to "1" or vice versa for each proximity sensor.



  10. #30
    Member
    Join Date
    May 2016
    Location
    United States
    Posts
    217
    Downloads
    0
    Uploads
    0

    Default Re: I need help to solve a ATC issue on a machining center

    Well bit changes like that pretty much shot my idea down.

    Does it say anything in your books about the 2008 error code? If you do not have the books, have you also tried to Google search it?

    I think you're soo close. Something is holding it up. Does this machine have a ladder you can look at? That should tell you something.

    Running out of ideas.



  11. #31
    Member machinehop5's Avatar
    Join Date
    Aug 2009
    Location
    United States
    Posts
    413
    Downloads
    0
    Uploads
    0

    Default Re: I need help to solve a ATC issue on a machining center

    ...can get some photo;s of the I/O PCB board Cables plugs..etc,...maybe the MTB marked them with the M Codes for the TC or loose plug.......one more thing to check for is there an Encoder on the Tool carousel?



  12. #32
    Member kike_c's Avatar
    Join Date
    Mar 2020
    Posts
    17
    Downloads
    0
    Uploads
    0

    Default Re: I need help to solve a ATC issue on a machining center

    Quote Originally Posted by the_gentlegiant View Post
    Well bit changes like that pretty much shot my idea down.

    Does it say anything in your books about the 2008 error code? If you do not have the books, have you also tried to Google search it?

    I think you're soo close. Something is holding it up. Does this machine have a ladder you can look at? That should tell you something.

    Running out of ideas.
    I have three, the connecting manual, operator's manual and maintenance manual, but incredibly there is nothing.

    I tried with google, some first issues were solved. However, I did not find information about ATC issue for yasnac mx1 controller.

    regard to ladder, there is also nothing in the manuals. This machine was manufactured around 80's. Maybe I will need assistance of a technician with experience in very old machines.



  13. #33
    Member jason-weihong's Avatar
    Join Date
    Mar 2020
    Posts
    8
    Downloads
    0
    Uploads
    0

    Default Re: I need help to solve a ATC issue on a machining center

    Quote Originally Posted by kike_c View Post
    Hello everybody,

    I'm trying to start up again with a machining center unused for 5 years or more. The equipment in question is a kuraki machining center, kv-500 model with yasnac mx1 controller.

    I solved some initial issues. Up until this point I can send the machine to first reference position, second reference position, spindle orientation,
    move in Manual, JOG, ATM or MDI mode. Unfortunately for me, I encountered a problem that I cannot solve and this gives me many sleepless nights.

    When I enter the code M06 TXX for the tool change, the following happens:

    1.- The spindle orientation occurs.

    But the machine does not move to second reference after this and a "M"and a "T" blinking on CTR display.


    When I enter the code M19 and G30 , the following happens:

    1.- The spindle orientation occurs.
    2.- The machine goes to second reference.

    But the tool magazine does not move to spindle after this and a "M"and a "T" blinking on CTR display.

    - Maybe it's waiting for a input signal or code, But What is required or needs ?, Is necessary a macro?


    Your prompt response with any suggestion for solve this issue will be appreciated

    If you need new controller, I can offer my company's controller for you to finish your machine. https://www.weihong.com.cn/en/



  14. #34
    Member machinehop5's Avatar
    Join Date
    Aug 2009
    Location
    United States
    Posts
    413
    Downloads
    0
    Uploads
    0

    Default Re: I need help to solve a ATC issue on a machining center

    Quote Originally Posted by the_gentlegiant View Post
    A message like that is going to be MTB defined. It would be in your manufacturer's error code books if you have them. To me that sounds like a physical sensor mounted on or near the tool carousel that counts the carousels individual rotational movements. This could be disconnected or have wet or broken wires or missing completely. To me this does not sound like a missing parameter issue but a control not getting the carousels movement information it needs to know what tool is in what position. It is confused.

    Just my take on it.

    What's funny in this situation is the MTB spelled Magazine wrong. Hilarious!
    I agree....



  15. #35
    Member machinehop5's Avatar
    Join Date
    Aug 2009
    Location
    United States
    Posts
    413
    Downloads
    0
    Uploads
    0

    Default Re: I need help to solve a ATC issue on a machining center

    isthisyour machine type config TC?




  16. #36
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    10897
    Downloads
    0
    Uploads
    0

    Default Re: I need help to solve a ATC issue on a machining center

    Quote Originally Posted by TD-4242 View Post
    good point, Make sure the Z is home'd and at machine zero.

    "G0G28Z0" or "G53Z0"

    btw, is one of these preferred over the other and why?
    Yes if your control can use a G53 then that is the one to use G0G53Z0 would be what may be needed for this to work some controls can use G53Z0

    Mactec54


  17. #37
    Member kike_c's Avatar
    Join Date
    Mar 2020
    Posts
    17
    Downloads
    0
    Uploads
    0

    Thumbs up Re: I need help to solve a ATC issue on a machining center

    Quote Originally Posted by machinehop5 View Post
    isthisyour machine type config TC?
    Yes, is the same machine configuration



Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

I need help to solve a ATC issue on a machining center

I need help to solve a ATC issue on a machining center

I need help to solve a ATC issue on a machining center