Australia constant stopping for no reason - Page 2


Page 2 of 2 FirstFirst 12
Results 21 to 24 of 24

Thread: constant stopping for no reason

  1. #21
    Community Moderator ger21's Avatar
    Join Date
    Mar 2003
    Location
    Shelby Township
    Posts
    34816
    Downloads
    0
    Uploads
    0

    Default Re: constant stopping for no reason

    Quote Originally Posted by mactec54 View Post
    Most likely when you reinstalled Mah3, you lost any debounce settings you may have had, this is where you can set the Debounce to help filter out any small noise problems

    You find the Debounce in the General Logic Configuration page right hand top corner
    Mach3's debounce settings are for the parallel port only.

    The Smoothstepper has it's own noise filtering, which he used.

    Gerry

    UCCNC 2017 Screenset
    http://www.thecncwoodworker.com/2017.html

    Mach3 2010 Screenset
    http://www.thecncwoodworker.com/2010.html

    JointCAM - CNC Dovetails & Box Joints
    http://www.g-forcecnc.com/jointcam.html

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)


  2. #22
    Member
    Join Date
    Jan 2005
    Location
    USA
    Posts
    10934
    Downloads
    0
    Uploads
    0

    Default Re: constant stopping for no reason

    Quote Originally Posted by ger21 View Post
    Mach3's debounce settings are for the parallel port only.

    The Smoothstepper has it's own noise filtering, which he used.
    I did not know he was using a SmoothStepper, these machines are normally basic Parallel port or USB and yes the Smooth Stepper has it's own Noise filtering ( Debounce )

    How do I set up Noise Filtered (debounced) input signals?

    Go to Mach3's Menu -> Plugin Control -> Main Config: ESS-M3-version

    Noise Filtering of inputs (also know as debouncing) will help to eliminate random fluctuations due to noise, by requiring a consistently high input signal before changing the input state high or by requiring a consistently low input signal before changing the input state low. This is very useful in situations where there is a lot of noise that can corrupt signals (like a plasma system), especially for things like limit or home switches, probe signals, EStop, etc...
    Enter values in microseconds (us) that a signal has to be stable for before it has been considered changed. Start with a value of 10 us, and work your way up through 50, 100, 250, 500 or possibly 1000 us (the same as 1 ms). Keep in mind, the higher you go the longer of a delay you are creating before your signal can get through, and this can cause a disaster while probing. If you have more than 100 us worth of noise, you should really look into your wiring and try to rewire or redesign your system to eliminate the noise sources or your wiring's susceptibility to noise.

    Mactec54


  3. #23
    Member ericks's Avatar
    Join Date
    Sep 2019
    Posts
    184
    Downloads
    0
    Uploads
    0

    Default Re: constant stopping for no reason

    I agree, best to make sure you do proper wiring and also choose the correct cable for the application. Placement of items in the box/enclosure is also very important.



  4. #24
    Member
    Join Date
    Jun 2010
    Location
    Australia
    Posts
    3967
    Downloads
    4
    Uploads
    0

    Default Re: constant stopping for no reason

    scroll down to Estop & uncheck "Enable".
    Only one problem...it won't let me disable it?

    Correct. You can NOT disable the eStop signal. Safety reasons. But the SS can filter noise out.

    Cheers
    Roger



Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

constant stopping for no reason

constant stopping for no reason

constant stopping for no reason