PDA

View Full Version : Need Help! G540 and C3 index pulse card



cmanning
06-30-2009, 04:44 PM
Hi folks. I'm hoping someone can help me out with my setup.

I'm currently upgrading my Taig mill from a Xylotex to a G540 motor. In the process I'm trying to get a couple of other bells and whistles added onto the mill. Currently the G540 is setup and working fine to control the steppers.

The current issue is setting up a C3 index pulse card from cnc4pc. I have tried the C3 on my Xylotex and it works fine (output pin on the C3 going to pin 10, and the gnd going to gnd on the BoB.) On the G540, I hooked the output to pin 1 on the BoB, and gnd to the PSU gnd. The C3 is set to Active High. When I fire up the G540, Mach 3 shows pin 10 as active, even though it isn't. If I trigger the C3, the LED on the board turns on, but no change in Mach 3. I've tried a couple of different settings using both Active High and Low, all without any luck.

To check if there was something wrong with the G540, I tried with an NC SPST switch hooked up to pin 1 on the BoB and the PSU gnd. Everything works great with that setup.

So I know that the C3 works fine, and I know that the G540 works fine. They just don't want to work together. Anyone have any thoughts on what I'm doing wrong?

Thanks
Chris

cmanning
06-30-2009, 04:46 PM
Obviously I posted this in the wrong spot. Ignore this thread and I'll open another in the Gecko forum.