PDA

View Full Version : Problem KL- 7220 Power Supply Blowing Fuses



MRM RCModels
03-14-2009, 02:12 PM
I bought the power supply a year ago and have only used it for 4-8 hours until now. I've just started using it again and it's blowing my 5A fuses let and right. I thought maybe it was the fuse holder, so I wired the AC in directly to the power supply. The power supply just hums and won't output any DC power. The power supply be fried or what? Does kelinginc have an exchange policy?

automationtechinc
03-14-2009, 02:51 PM
Hi Sir
If the power supply has problem under one year warrenty, pls ship it back, we will send a brand new one. But in your case, you did not use it, we will send you a new one, pls email me your address.

www.kelinginc.net

Crevice Reamer
03-14-2009, 03:20 PM
Now that is some GOOD customer service!

CR.

MRM RCModels
03-14-2009, 06:31 PM
Hi Sir
If the power supply has problem under one year warranty, please ship it back, we will send a brand new one. But in your case, you did not use it, we will send you a new one, pls email me your address.

www.kelinginc.net

Thank you Sir. Email sent to support"at"kelinginc.net

MRM RCModels
03-17-2009, 10:28 AM
Thank you Sir. Email sent to support"at"kelinginc.net

Kelinginc,

What is you address? Tried emailing, but haven't got a response.

Crevice Reamer
03-17-2009, 10:33 AM
Kelinginc,

What is you address? Tried emailing, but haven't got a response.

If your email to John contained your address, your "response" will probably be a Pri-mail package in today's mail.

CR.