PDA

View Full Version : problems with cnc lathe



todd goff
11-13-2008, 08:09 AM
Hey guys, I am new and hope that I have posted this question in the right forum, if not I do apologize. I want to tell everyone that I am probably not the brightest when it comes to cnc machines and will probably ask some dumb questions. I have 2 smaller cnc machines (neither of which are real workhorses). The first machine is a south bend magnaturn 612 lathe and a maxnc 10 mill. I have a question for everyone in regards to the magnaturn and am hoping I can get some help. When I power the machine up and try to sync the axis I am catching you know what. The machine fails to stop like it should when you go to jog the axis to sync it and it shuts down because it is going to a default mode. I am no electrical or computer troubleshooter, so I am completely lost. I tried swapping the limit switches to check it out that way and it is still the same thing. I was wondering where I need to start and even if there may be someone within 2 or 3 states from me that could repair this machine. I hope that it is something simple, but I doubt it. Also, the x axis is doing it on the machine if it matters (I think it is x anyway).

HuFlungDung
11-13-2008, 10:38 AM
For starters, what kind of controller does this machine have on it?

It sounds like the axis is running away when you are trying to home the machine?

First, make sure that the axis is not already past the limit switch when you power up. Move it back to the operational zone by hand with the power off.

When you power up, do both axis 'hold position'? By this, I mean if you apply some kind of torque to the carriage or cross slide, will they drift or immediately runaway?

Runaway usually indicates some kind of feedback failure, such as no power to an encoder or a bad encoder on the runaway axis. If someone has been mucking around with the wiring, it could also mean that the servo has opposite polarity to the encoder hookup.

todd goff
11-13-2008, 10:57 AM
Hey huflungdung; the machine does fine on the z axis, but it goes mad on the x when I try to sync it. I sent the stepper motor to south bend before they went belly up and they said it sounded like an encoder. Well, after about 2 years of anyone at south bend not knowing what was going on I finally called them up and told them to send it back. I got the motor back and was told by the cnc repair guy that he didn't know if it was fixed or not ( or not). Anyway, I put it back on to try it out and it still does the same thing. The machine is pc based and to be honest, I don't really know what type of control that it uses. I know that the motors are berger lahr is about all that I know. I can go over to the shop later on and see if I can find some information about the controller maybe.

Eduardo Matas
12-17-2008, 12:25 PM
Hello, I need to know if you can help. We are reaparing a MORI SEIKI model SL25 with a control T-10, but the problem that we have its that we dont have the parameters of the control to load in the CNC. Could you please help me with this?
Thanks

Eduardo