PDA

View Full Version : Problem bad code



Tumbleweed Tim
03-18-2008, 10:40 PM
Anyone got any ideas??
Why won't this work? It won't get the #14 offset. Trying to turn a .750 sphere with a .375 dia. neck with a .120 wide 0156r using both edges. I can't get it to get #14 at X.75Z-.375. cuts back side with #4 only. Is this possible to do like this?
G50S4000
G00 X50 Z50
X1.0Z0.050 T040404 G96S800 M03 M08
G85 NBAL D.025 U.010 W.005 F.015
NBAL G81
G00 X-.03 Z.3
G42 I.005
G01Z0.0 F.005
X0.0
G03 X.750 Z-.375 I0 K-.375
G03 X.375 Z-.700 I-.375 K0 T140414
G01 Z-1.0
X1.2
G40 K.005
G80
G00 X50Z50
T040404
G87 NBAL
G00X50Z50
M02
Thanks in advance,
Tim

compuslave
03-19-2008, 06:23 AM
To use offset 14 with tool number 4 you need to say T0414, also check that your tip data is correct on your tool offset page. For a tip that points straight down it should have an 8 for tip direction.



G50S4000
G00 X50 Z50
X1.0Z0.050 T040404 G96S800 M03 M08
G85 NBAL D.025 U.010 W.005 F.015
NBAL G81
G00 X-.03 Z.3
G1 Z0 G42F.005
X0.0
G03 X.750 Z-.375 I0 K-.375
T0414
G03 X.375 Z-.700 I-.375 K0
G01 Z-1.0
X1.2
G40 K-.0004
G80
G00 X50.Z50.
T040404
G87 NBAL
G00X50Z50
M02


Try that. I have never used offsets like that within a LAP cycle. Let me know how it turns out.

compuslave
03-19-2008, 06:31 AM
I seriously doubt your gonna be able to switch offsets like that since cutter comp would be totally lost.

throttle_jockey
03-19-2008, 01:13 PM
This will probably work, but you must remember the 6 digit tool offset, and the order that it reads in. Just like in the tool layout page, R T O, radius, tool, offset. I think if you call the offset with 6 digits you'll get what you're after.

Tumbleweed Tim
03-19-2008, 02:16 PM
Thanks,

Draws fine on the screen. Cuts the shape of football. Does not even show tool going into the part when it gets to start G87. Thanks for your input and I did run the program as copied and pasted.
Okuma can't get it to go either and they say it should work, Really wierd.

Thanks,
Tim

lshingleton
03-19-2008, 03:00 PM
You can try -should work-you are just moving the rear side by a variable


G50S4000
G00 X50 Z50
X1.0Z0.050 T040404 G96S800 M03 M08
G85 NBAL D.025 U.010 W.005 F.015
NBAL G81
G00 X-.03 Z.3
G42 I.005
G01Z0.0 F.005
X0.0
G03 X.750 Z-.375 I0 K-.375
()
V1=.120(or manually enter data )
G03 X.375 Z-.700+V1 I-.375 K0+V1
G01 Z-1.0+V1
()
X1.2
G40 K.005
G80
G00 X50Z50
T040404
G87 NBAL
G00X50Z50
M02

lshingleton
03-19-2008, 03:03 PM
Just check whether the variable should be a minus or a plus value

Tumbleweed Tim
03-19-2008, 04:16 PM
Wow,
Now that looks sneaky. :) I went to full radius tool, but I will try that some time when I can play with it. Thanks.

Now I need to adjust size. I get .750 at center and .7507 everywhere else on the sphere diameter. Is in tol, but I am thinking I can get closer. Offsets are .06/.06. I am getting a little spiral pip at center.
I don't need bearings but I want them. :)
Thanks,
Tim