PDA

View Full Version : Okuma OSP 5020L



al-108
03-05-2008, 01:29 PM
Need some help with this program. I am getting a 452-1 Alarm on my
OSP5020L Control. If some could take the time to check this program
and let me know where my problem is I would appreciate it.

Thanks in advance.

$MOLD-FEMALE.MIN%
G13
G50 S1000
G0 X50 Z50
NAT03 (5/8DIA BORINGBAR)
T030303
G0 X0.05 Z.5 G97 S400 M3 M43 M8
G96 S700
G85 NIDIA D.1 F.01 U.020 W.020
NIDIA G82
G42 X0.05 Z.2 F.005
G1 X0.050 Z-2.2921
G2 X12.4807 Z.0657 I-.0250 K9.4370
G40 X12.3000
G80 M9
G0 Z.5
G0 X50 Z50
M1
NAT13(5/8DIABORINGBAR)
T030303
G0 X0.05 Z.20 S600 M3 M43 M8
G96 S900
G87 NIDIA
G0 Z.5
G80 M9
G0 X50 Z50
M2
%

lshingleton
03-13-2008, 01:40 PM
First of all u an w as incremental moves on an okuma dont work-should be x and z in a ---g91 command--------------the problem is in the G02 line -replace the i and k with an L-----------L on okuma is the same as R on fanuc-----this should also help pick up the ---g42 command properly-make sure radius calculation is also correct-make sure also when using G42 you have put proper radius values in both x and z in the compensation screen under tool radius

phx
03-13-2008, 01:57 PM
First of all u an w as incremental moves on an okuma dont work-should be x and z in a ---g91 command--------------the problem is in the G02 line -replace the i and k with an L-----------L on okuma is the same as R on fanuc-----this should also help pick up the ---g42 command properly-make sure radius calculation is also correct-make sure also when using G42 you have put proper radius values in both x and z in the compensation screen under tool radius

hi
he dont wanna incremental move, u and w ist for finishing.
i and k is corect if the value is right.

lshingleton
03-13-2008, 02:14 PM
The u and w was just an observation that on this control it is ignored

Never got the older i an k to work on this contol only L-when using a G42/41 command

If you get this alarm follow by over end point or cicle calclation check the value set in the word or long word parameter to make sure it has a big enough window for error calculations-----

lshingleton
03-13-2008, 02:21 PM
Actually looking at the program again it is an easier problem-there is no G01 or G00 programmed after the radius move
Program a G00/G01 after the G02 line
Have a good day

throttle_jockey
03-18-2008, 04:17 PM
Looks like you will want to feed off of your profile a bit before you exit cutter comp. If you've got room at the end of your profile pass, feed down a bit off the ID, at least two times the distance of your tool nose radius, i.e. if you're on a 5.00 diameter, with a .0312 tool nose rad, feed down to 4.93, then call the G40, this will also give the machine a direction to exit cutter comp. The I and K values are the INCREMENTAL distance from the start point of the radius. The only time that L will work is if the radius is tangent to both features.
Cheers,
Brian