PDA

View Full Version : Jerky Movement



elogicca
10-15-2007, 05:54 PM
Hi I'm doing some scallop routines in mastercam which output the following moves

<code>N190 G01 Z.1879 F50.
N200 X-1.4597 Y1.4908 Z.1871 F145.
N210 X-1.2639 Y1.2711 Z.1791
N220 X-1.2711 Y1.2555 Z.1797
N230 X-1.316 Y1.2084 Z.1831
N240 X-1.3496 Y1.171 Z.1856
N250 X-1.3968 Y1.1142 Z.1892
N260 X-1.4281 Y1.074 Z.1917
N270 X-1.4671 Y1.02 Z.1948
N280 X-1.4988 Y.973 Z.1973
N290 X-1.5379 Y.9097 Z.2006
N300 X-1.5646 Y.8631 Z.2029
N310 X-1.5976 Y.8003 Z.2058
N320 X-1.6275 Y.7376 Z.2085
N330 X-1.6478 Y.6917 Z.2104
N340 X-1.6732 Y.6277 Z.2128
N350 X-1.6948 Y.5667 Z.215
N360 X-1.715 Y.5022 Z.2172
N370 X-1.7322 Y.4394 Z.2192
N380 X-1.747 Y.3766 Z.221
N390 X-1.7594 Y.3139 Z.2227
N400 X-1.7694 Y.2511 Z.2242
N410 X-1.7753 Y.204 Z.2253
N420 X-1.789 Y.1941 Z.2263
N430 X-2.0872 Y.2112 Z.2434</code>

mach 3 runs this really jerky always accelerating and decelerating even in constant velocity, is there a way to fix this, or is there another controller software i should look at?

Thanks

fatal-exception
10-17-2007, 04:02 PM
If you have backlash compensation turned on, those moves will be very jerky.

Paul

delcon
10-18-2007, 10:54 AM
del

delcon
10-18-2007, 11:53 AM
I have the same problem. it is accel- and decelaraiting like it is not supposed to. I have tried in different forum but no luck / help.

I found out to check:
- check constant velocity
- shuttle accel 0.001
- backlash not enabled

I was thinking if it had anything to do with my second matter: the machine axis can not be zerod by pressing the button. only by autozero!

I hope to get some help because other than that it is a great prog.

Leo

CNCAddict
11-21-2007, 08:33 PM
There are a few things that affect CV.

- CV button (make sure your program isn't turning CV off by accident G61/64)
- shuttle accel (if you have steppers then this needs to be reasonable, if servos then I set it to 0) only affects things when backlash is enabled.
- backlash (this can be enabled, but you need to set the speed higher than your feedrate for it to work smoothly) If you have steppers then this can cause lost steps. For servos set it at 100% at fly!!
- All the other settings for CV should be off, and the lookahead needs to be set very high. Art recommends 200 or so.
-Set the Kernal speed to as low as possible. I have problems at 100Khz, but if you only need 25Khz, then set it there. The program will be much more responsive/smoother.

Khalid
11-21-2007, 09:19 PM
"Jerky Movement"

By seeing the thread name, the first impression in mind was a new Film Release with the name "JERKY MOVEMENT"