PDA

View Full Version : Sporadic axis/motor movement suddenly started in Mach3!



boothie
08-09-2007, 05:10 AM
Hello all,
I have a converted engraver thats running on steppers, driven by Mach3. I had got all the motors tuned and they were running smoothly, real nice pace and hitting the mark to within 0.01mm, when i had adjusted for the backlash. Was playing around in the MDI getting nice results, good pace (same as the calibration tests) and homing to zero fine and moving into the negative range fine. So thought i would give a test run using one of the pre-saved gcode files (road runner i think!) and all of a sudden the motors started having trouble running smoothly! So i tried measuring them and they were losing ground too, re calibrated and they moved fine during this process, so went back to MDI and still sporadic and slightly out. Don't know what has gone on, i'm running in millimeters and most of the pre-saved are in inches but would that affect it? or do the pre-saves have some settings that have over written my settings? Any help would be a few more hairs left in tact!
Boothie

turmite
08-09-2007, 11:06 AM
Hi Boothie,

Sounds like you need to retune to slightly lower settings than you currently have. Typically the tuning process is to tune upwards till you have lost position and steps then drop the tuning back until things a completely stable. I am currently going through the process right now and am having the same problems, but right now mine is only 1 axis that is giving problems. I have Mach2 installed and very stable so I can continue to work while taking my time on the tuning of Mach3.

Mike

RMT
08-20-2007, 07:21 PM
I agree with Mike, I'm working on a milling machine and it was running good even 140in/min but to be on the save side , I set it back down to 100in/min
Increase the spead until motors sputter than lower it 30-50% and try running the program again. Also make sure when You testing You are running at 100% jogging speed when You moving the axis, double check by hiting the tab key and have both jogging speeds set at 100%.

Frank