PDA

View Full Version : POST your success or failed story with G-REX G100 & G101



FPV_GTp
07-15-2007, 08:27 PM
POST your success or failed story with G-REX G100 & G101


hi

Guys there seems to be a lot of confussion with G-REX from Gecko-drive

I would love to hear from people using Gecko-drives products and specially G-REX G100 and G101 and add ons G901 and G902

Link : http://www.geckodrive.com/product.cfm?pid=19


Would loike to working machinery with G-REX controlling , so post pictures and links to websites or your own blog

cheers

123CNC
07-23-2007, 02:53 PM
I'm still in the early stage of getting a gRex 100 up and going. As with all things ethernet/RS232, unless you do networking and or serial communication work frequently, just establishing communication can be very frustrating. Once you get past this what seems an insurmountable hurdle, it usually seems trivial on the other side, when you get there.

However, I thought I had made it and now am having repeated trouble in establishing and keeping the ethernet connection via Mach3 plugin. It seems ify on the gRex loader as well when it starts misbehaving. I'm uncertain if it is gRex firmware and communication protocol, hardware and temperature, or the 1-hour unlicensed plugin difficulty. If it is the later, it seems to me that the 1-hour limit is really short when you are still in the setup/evaluation phase. I may have to further investigate the USB route and non-Mach communications to make a conclusion on if the decison to go with the gRex was a little premature. I think it has great potential, if it proves to be more reliable than the parallel port/BOB direct communication shortcomings.

I anxiously await other posts on their success and failures with the gRex. I'm still hoping that this will be the start of a long and happy relationship with some addtional gRex's to follow, if we don't go our separate ways.

123CNC
08-06-2007, 03:33 PM
Hoping others will post their success stories.

My failure has strong indications that my gRex doesn't really like to get hot under the collar. Temperatures above 92 F and she just doesn't want to give you the time of day. Either invest in air conditioning or move to a more suitable climate to keep her happy. Of course, I might try throwing her into a bucket of ice water when she doesn't want to play. But we all know just how much she'll like that.

Knowing how to deal with her is half the battle. My sails are filling up again, and again anxiously await to hear SUCCESS stories. I strongly feel that the gRex fills a major void and opens up a whole lot of potential at its price level.

Is there anybody out there?

acondit
08-06-2007, 05:44 PM
POST your success or failed story with G-REX G100 & G101


hi

Guys there seems to be a lot of confussion with G-REX from Gecko-drive

I would love to hear from people using Gecko-drives products and specially G-REX G100 and G101 and add ons G901 and G902

Link : http://www.geckodrive.com/product.cfm?pid=19


Would loike to working machinery with G-REX controlling , so post pictures and links to websites or your own blog

cheers

FPV_GTp,

The G901 is a multiplier board basically used to convert a G201 to a G210 or a G202 to a G212.
The G902 is a multiplier board basically used to convert a G320 to a G340. The really have nothing to do with the GRex per se.

Geckodrive has a pdf that sets out the differences between the G101 and the G100.

The G-Rex G101 is basically an OEM version for people building embedded systems or even wanting build a daughter board using a different processor.

The G-Rex G100 is basically an end-user version with connectors, case. It is supported by a Mach3 plugin (for Mach users).

Alan

Bird_E
08-13-2007, 03:45 PM
I have now built 3 Grex based CNC controllers for 3' X 3' router tables for work. 2 of these tables have been in service for 8 months working around the clock. I Haven't had a single issue. We have auxillary equipment including an inspection camera interfaced with the grex and mach3 and it performs sweet!

Bob

eat
08-17-2007, 03:56 PM
It is good to hear your success I believe I will purchase one today.
Could you tell me about the software you are using?
Is it the plug in newest version or what thanks.

Bird_E
08-17-2007, 04:00 PM
I have been using Mach3 and the newest plug in

aghobby
11-14-2007, 08:42 PM
We are running Grex on all the stepper based router we sell, the only bad thing about it is the poor 3d performance, better performance with pp, but as reliability, no issues in 3 month on industrial machines....

Alex

eat
11-21-2007, 10:01 PM
as you can see the from the post above the date I purchased
the grex

I had it connected and it seemed to be working ok but I could not get the motors to turn I contacted a guy at the mach3 forum and he said he would help me

he connected to my computer and started checking the settings in mach3 and the grex quit working altogether
I sent it back with a note that I could not seem to get the motors to turn I received it back with a paper saying reset and operational I reinstalled windows xp pro mach3 the plug in installed updated disconnected the usb internet connection to my computer

and reinstalled the device set up the the connection
flashed the motor tuning flashed the encoder information
checked my settings and I was connected still would not turn motors

rechecked wireing twice disconnected all but one drive
made hot keys to move motor to + and key for -
keys moved dro but not motor red leds lighting up on grex
when I push + key then goes out stays lit when pressing - key until pressing the + again and if I turn shaft by hand fault light comes on temporarily

tried different motor different cable there is power to motor
bought new crossover cable read all documentation
contacted mach3 guy again has something going on

cant help now

did searches on various forums reading reading
tested wires coming from grex no signal coming from step or direction wires

try to use usb to connect but the test.exe program comes up with out the buttons on my computer tried changing settings no good cant get it to work with out the buttons comming up
so cant type in command to test grex threw usb

cant get help to check settings they seem to be right
called Gecko again about 5th time at least as I had to ask some things before there pdf documentation is wrong on some setup things they told me to get a different capacitor
then the one listed and to set the drives with different damping and gain to start they said thats how they should
be set old documentation I guess tried some more stuff
and tried doing some of this over and over
motors still dont move no signal from the grex

the funny thing is I sold my other high end setup and bought this as I thought it would be simpler and liked the look of mach 3

choices at this point
wait
buy another grex
find some help
go on berserk rampage

at this point I am waiting I called gecko this morning
and they said no one would be in until Monday
but they where checking email so I sent a email
I suppose i could go another way but would like to go this way I cant really afford another 400 bucks this time of year
but I don't see a lot of choices if I had another grex
I would have a good chance to know if that is the problem or not and that seems to be where the signal stops

all the motors cables everything is new the drives are wired correctly

I am really just running out of options here
any help would make me grateful

if this sounds bad consider this I left out a lot of stuff
thanks good luck

ger21
11-21-2007, 10:26 PM
Are you sure you have Mach3 setup correctly? Have you ever used Mach3 with the parallel port? Do you need some features that the G100 has that the parallel port does not? Because if you don't, just use the parallel port.

eat
11-21-2007, 11:12 PM
I believe I have it set up right I would like to double check
my settings with some one but cant find help

but acording to the documentation and what I could read
on the forums it should be correct
althow that is my first suspect

but I still have not found anyone having the same problem
so that does not make it easy
I have never used mach3 on the paralel port
I would prefer to use the G100 if I can
it may be that I will go to the parallel port at some
point

I have given myself untill the end of this year
to get it running so if I cant get this thing working right in the next few weeks or make some progress
I may try then

if it seems like I have not allowed myself enough time
this has been going on for months
with this thing but the time is running out

I just cant seem to find anyone with this problem or any ideas
to help me and am having a hard time figuring it out myself
and I hate to give up I think I would rather buy the new Grex
then give up giving up sucks

but there is a point where this is stupid thats why I have the date running by 2008

I will try to do some more reading and keep trying to come up with a solution this week

thanks
yours may very well be the way that ends up working for me

ger21
11-22-2007, 07:36 AM
If you sent it back to Gecko, and they said it is fine, then I doubt buying another would work. Still curious why you want to use the G100?

eat
11-22-2007, 02:49 PM
I believe the firmware was reset to original
but dont believe there was any actual testing done on it
at least that is my understanding
I am pursuing the software end of it and should know something more after the weekend

as far as wanting to use it there is some advantages
althow it seems to be looking a little less atractive as time goes on

but I believe when evreything works out it will fun

eat
11-22-2007, 07:00 PM
hi it would be a big help if some one could just tell me
what lights come on when this is turned on
I just read this (All of my dir. lights come on brightly and a very dim analog out) the onley lights that come on on mine are ch-1 on all axis just barley, very dim
then the green one comes on bright when the firmware starts

little help Please

Mr.Nerd
11-23-2007, 10:39 PM
Yeah, I get the same result, the CH-1 lights come on (very dim) and then 10 seconds later the it boots up and the run LED turns green.

My problem with the GREX is I cant get the firware loaded for MACH because my GREX loader cant find the grex now that the firware is loaded. Im really considering getting rid of the GREX and using a breakout board.

eat
11-28-2007, 04:34 PM
I believe I have found my problem
it was something simple like I thought

I cant be sure until I get my computer straightened out

but I am fairly sure
believe it or not I had all my wires fastened down with zip ties about one every 3 or 4 inches well it seems my
power cables that I am using have shrunk in length
since I installed them
and pulled the connectors out enough
that they where not connecting

might have been the change in temperature
as the room is not heated
I am not positive

I thought all the zip ties would hold them in place
but they seemed to slide threw them a little when they shrunk

figured it was something like this simple and stupid
and my mistake


http://www.cnczone.com/forums/images/smilies/iamwithstupid.gif
:withstupi

eat
02-10-2008, 10:54 PM
Update: I have had everything up and working for a wile now and I love the set up


Here are some suggestions

1. don’t try to run the G-rex with g340 Drives (for servos run the 320s)
2. don’t change your wiring colors in the middle of the build
3. don’t do it your own way, do what everyone says on the forum

Mach 3 is a pleasure 2 axis where right on one was off but I used mach3
Told it to move one inch it prompted me for how far it did move and I typed the measured
Distance in the box took about 20 minutes and now all 3 axis are consistent to ½ a thousandth
I am amazed at the accuracy that’s about a close as I can measure it

DieGuy
10-18-2010, 07:03 PM
What ever happened to the Grex line of controller interfaces?

ger21
10-18-2010, 10:43 PM
The 3rd party writing the firmware for Mach3 never finished it, and Gecko stopped selling them.

DieGuy
10-19-2010, 10:58 AM
The 3rd party writing the firmware for Mach3 never finished it, and Gecko stopped selling them.

That is certainly to bad, When looking back it seems like a great way get a controller on Ethernet.