PDA

View Full Version : Mach rebels 1/2way through part cut.



cephjedi
07-10-2007, 08:28 AM
Hi Gang,

I used the Newfangled Solutions conversational to design the attached simple trimmer router mounts to upgrade the Z axis on my homebrew machine.

In essence, it first cuts a keyway across the parts, then goes to cut a circle out of the inside, and then finishes by cutting a rectangle on the outside. The result is two halves of rectangular bracket with a 2.5" hole in the middle that can be bolted together to clamp the router in.

Seems simple, but Mach loses it's mind after cutting the first half of the first circle. On line 73 the machine halts. It just sits there. It won't do anything else until I give it a stop command. That's strange enough, but get this:

Whatever happened also reversed the homing direction settings. After the error, I tell it to reference home, both X and Y move the wrong direction.

The machine has home switches but no limit switches. I did set the homing directions correctly per the video, but something about this G-code flips it back to the default setting. It's a reliable error- same thing happens everytime at exactly the same place.

I ran the code on another computer (with no machine) and it seemed to go just fine. So I upgraded my main machine to the 2.0 Release lockdown and that didn't work.

Does anyone have any wisdom they can share with me? many thanks in advance!

Cheers, Jim

ger21
07-10-2007, 01:36 PM
Back up your .xml file, then delete it and then redo all the setup. Sometimes the xml file becomes corrupted.

cephjedi
07-10-2007, 08:37 PM
Hi Ger!

Ahhh, once again you come to glasshopper's aide...Thank you!

I took your advice and was immediately reminded of another difficulty I've been having with Mach- I have this one magic XML file that works. Other than that, I can't get the software to do anything at all! It doesn't even see my home switches.

Further indulging your (and other's) help, I've attached the good file and the newest bad XML file. The file that works (othre than original complaint) is the "copy of" file- my backup. I ran it through an XML comparison program and found only a couple lines that are different, but I'm not sure what they mean. A lot of it looks like my motor tuning info, but I don't see anything glaring that would prevent Mach from operating. Then again, Mach is so incredibly complex, I've barely scratched the surface of what it can do.

As I've admitted before, I'm extremely green to the inner workings of hobby CNC, so please forgive ignorant mistakes.

Anyone, got any advice for me? Thank you mucho-ly for all assistance!

:cheers: Jim

/looking forward to the day I can give back the help I've received in CNC zone. ;)

cephjedi
07-10-2007, 08:43 PM
I see....the forum frowns upon xml files. I zipped them up- apologies for the inconvenience.

again, :cheers: Jim

ger21
07-10-2007, 11:10 PM
I'm assuming the so-called "good" .xml is the one that gave you the problems?

I recommend just deleting the .xml completely (after you back it up) and reconfigure Mach3 from scratch. It might take a while, but hopefully it will fix your problem. If not, you can always go back to the old .xml

Actually, I should have asked if other g-code programs run OK? The reason I mentioned the .xml was because of the homing issue. One other suggestion would be to ask Art via the Yahoo group and see if he has an answer.

cephjedi
07-11-2007, 08:12 AM
Hi Ger,

Yep, the "copy of machmill.xml" file is the one that works. I've cut a few things on the mill without issue but this one part is giving me problems. The next troubleshoot I'm going to try is doing each operation by itself, instead of using the conversational scripts to chain them together.

I find it strange that I can't get mach to work at all from a fresh reconfigure. I double checked my double checks and I don't understand why it ain't working.

I'll also chime in on art's yahoo forum.

Man I really want to get this router mount done. The dremel mount is a hack job and it can only cut at about 3 ipm. bleah!

thanks again! -Jim