PDA

View Full Version : Stepper motors not reversing



Cold Fusion
04-17-2004, 09:21 PM
When I hooked up my Centent cn0143 (same as Gecko 201) everything worked great, except my motor direction. Whenever Mach2 told the motor to reverse direction, it would instead keep traveling in the one direction (clockwise). I know it's not the pin setup's problem because I've tried reversing and changing the pin numbers. It's not a faulty wire. It's not Mach2 because I had the same problem in Turbocnc. Any advice?

davesaudio
04-17-2004, 09:45 PM
you confirmed your direction pin into the driver is changing?
bad connection?

Cold Fusion
04-17-2004, 09:48 PM
Connection is solid and good. I forgot to test the voltage coming from the PP when I had it all setup (in pieces now).

radio-op
04-18-2004, 03:06 AM
Cold Fusion, I don't have any hands on with the Centent (or Geckos) so just some thoughts. Your PPort may not be providing enough drive (is it a laptop?), if you can, test with another computer. If possable, check the input specs for the driver, could be you need some pullup if it's an open collector input. Are you using a breakout board? Verify that the logic state on the input is showing up on the output.
Hope some of this helps,
Bill

Stevie
04-18-2004, 07:35 AM
If you need to test the LPT1; grab a small program called "Seebit.exe" it will create a screen with large boxes to represent the LPT1 pins; with your function keys you can turn them off and on; the only weird thing is the pin numbers are reversed from the boxes; i.e. pin 1 is F8; you might also need to change the address of LPT1 in the Bios (it's very easy to reset to 0278) or maybe you can figure out how to change it in seebit (I couldn't; but I didn't spend too much time in it)
It's a handy tool :D

Cold Fusion
06-02-2004, 05:33 PM
I just tried it out on my new camtronics steppers. Same problem. I'm about to go test the voltage for the direction lead.

On the wiring diagram it told me what wires to connect to what phases. It labeled them A, A/, B,B/. How would this match up with the Gecko 1,2,3,4 connections?

Where do I find this program Stevie?

Stevie
06-02-2004, 05:46 PM
Just to go out for a few mins; but once i get back

I'll email it to you if you send me an email first; that way the proxy will not be involved
Send me your email address for it

Cold Fusion
06-02-2004, 06:11 PM
Wow, it works. I was messing around with the voltmeter measuring the outgoing ttl signals. Both Step and Direction read 5v. I thought, "Ok, I'm getting power, why doesn't it work". So I plugged everything back in and it worked! I have no idea why it didn't work before.

High Seas
06-02-2004, 08:06 PM
gremlins?!
X-files case?
No I know - its electronics! Congradulations! It woiks -- No smoke - a GOOD thing!

Stevie
06-02-2004, 09:02 PM
Back from a school thing with the little girl; glad you got it :D

balsaman
06-02-2004, 09:21 PM
Of course, you need 5v at the dir pin only for going in one direction. It should read 0v when going the other. The step pin will be pulsing regardless of rotation (not 5 volts "on")

Eric

DR-Motion
06-03-2004, 08:34 AM
"So I plugged everything back in and it worked! I have no idea why it didn't work before."

Same thing has happened to me... route cause was an intermittent connection to one of the phases of the stepper.

There was enough momentum in the physical system to keep the motion continuous even though it was only powered every other pulse. A telltale sign was a lack of torque at the motor.

regards Gary

Cold Fusion
06-04-2004, 02:50 PM
Dangit! I spent all of today doing a total wiring job for it. When I powered everything up and tested it in Mach2, the evil gremlins are back. Any advice?

Wiring is solid and I'm getting direction changes visible on the voltmeter.