PDA

View Full Version : Axis motors stop while running a program



kevinkoons
05-16-2007, 01:35 AM
Hello everyone!

I am using Mach3 to run an old Bridgeport BOSS CNC mill. I have only had this machine up and running under Mach3 for about a week now. Everything seemed to be going very well and I had machined a few parts!

While running a part and feeding at 10 ipm, the X-Axis motor stopped responding. The DRO in Mach showed movement but the motor was not turning.

After stopping the program I was able to jog the Y and Z axis but not the X axis which had stopped responding. I show off power to the machine and powered it back up. No luck. I powered down the machine and exited out of Mach and restarted Mach. Still not luck. What I found was I had to reboot the computer then restart Mach 3 then power on the machine and all is well, all axis moters are working.

This problem has only happened when the feed rate is low, like 10 ipm. If I am cutting at 20 ipm or more, not problems.

Today the Z axis "froze" as the X or Y were doing. I was drilling holes and the Z stopped feeding down, glad I was standing there waiting to do tool change! The next move would have been a disaster!

Has anyone had issues like this? Any ideas?

I'm running Mach3 on a Dell 400SC with 2Gb RAM and Windows XP Pro (stripped down) and using Campbell Designs combo board with Gecko 212 drives. I also have a VFD controlling the spindle.


When the problem first presented and I was rebooting the PC I forgot to power down the machine one time and the computer froze on reboot. I some how figured out that the power to the machine was still on, turned it off and everything worked. I mention this because it seems like when an axis motor quits, it's like when an application freezes in windows and the only resort is to reboot. Could this be an issue with my computer?

Any ideas would be very much appreciated!

Kevin

kevinkoons
05-22-2007, 02:43 AM
Hello everyone!

When tuning the axis motors using the trim pot on the Gecko drive, the motor will suddenly stop when the trim pot is turned near the end of travel in the clockwise direction. When this happens the only way to get the motor to run again is to remove power from the gecko drive (power down the machine) and exit out of Mach 3, restart Mach 3 and then power the machine back up. Some times it is also necessary to reboot the computer in order to get the motor to function again.

I am also having this same problem with the motors suddenly stopping when running a program when the feed rate is 10 IPM or less. Running at 20 IPM for example, I can cut all day long with no issues at all!


I am running Mach 3, Version 2. I am using Gecko 212 drives. This is a Bridgeport retrofit Series 1 CNC machine with Sigma motors on the X and Y and a Superior on the Z. All axis motors have presented the same problem at one time or another.

When running a program I wrote specifically to trouble shoot the problem, the X Axis motor will quit at randomly. It has ran for as long as 4 hours and for as little as 10 minutes, maybe less.

I am at my whits end, just can't seem to figure this out. I know I am not the first person to use these old Bridgeport steppers, has anyone had a problem like this or something like this? Any ideas what it might be?

I configured the Gecko drive for NEMA 42 motors, and 10-micro step resolution. I have also tried 5-micro step, half step and full step, all with the same results.


Any help on this would be very much appreciated!


Kevin