PDA

View Full Version : Z Axis Reversing



Svelte
05-02-2007, 03:48 AM
I just fired up my new tabletop CNC router table and am in the process of getting things tuned and setup. This is my first build, so please don't laugh just yet. Everything seems to be progressing well except for the Z Axis. For some reason unknown to me, when I jog the Z Axis, the stepper wants to reverse every time that I click on the up or down button in Mach 3. The X and Y Axis work perfectly. The motor also wants to pick its own direction when running under control of the G Code. The X and Y Axis, again, work perfectly.

I have checked all of the wiring and Mach 3 settings and they all are fine. Can anyone give me some suggestions on what might be causing this?

I am running a Xylotex 3-axis controller with their power supply and three of their NEMA 23 motors. This was purchased as one of their complete drive packages. Everything should be properly matched.

I am running the Demo version of Mach 3 Mill Version R1.84.000. I wanted to try it before I purchased it since this is my first attempt. The way things are going, it may be my last. I have a full-sized Shop Sabre table that I purchased new. I just thought that a tabletop machine would be fun to build.

ger21
05-02-2007, 09:00 AM
Are you sure the step and direction pins aren't reversed? If not, there may be some noise on the direction line.

Svelte
05-02-2007, 11:46 AM
I just checked all of the wiring again and it is correct. All of the wiring is shielded and the Z-Axis wiring is actually separated from the rest of the machine wiring more than the X and Y Axis wiring. The spindle has not even got power to it. I can't figure out where any interference would be coming from.
Here's another curiousity. When I get the stepper to move in the correct direction, when it hits either the top or bottom of its travel, it reverses on its own. If it is under control of the G-Code programming (like returning to zero with a G0 Z0 command, it will hit the top of its travel and then reverse and travel slightly in the opposite direction and then stop. The motor is not binding at the end of the travel and is making no funny noises. I even tried slowing it waaaay down in the motor tuning section of the program. This machine has no limit switches (yet). It's almost like it has a mind of its own.

ger21
05-02-2007, 12:07 PM
Try checking and monitoring the voltage on the direction line.

mxtras
05-02-2007, 12:56 PM
If I understand you, the motor is spinning backwards from the way you want it to?

In this case, reverse it in the Motor Home/Soft Limits sub-menu of the Config Menu. I am pretty sure this is where it is done - it's been a little while. There is a very simple way to reverse the direction if this is not it.

Scott

Svelte
05-02-2007, 11:56 PM
No. The settings are correct. If I press the <Page Down> button on the keyboard to activate the Z-axis it will begin to move down. If I let up on the button and press it again, most (but not all) of the time the motor will reverse. If I let up and press it again, it will reverse again. It will do the same thing with the <Page Up> button. Under program control, it will move in the direction that it chooses unless it bottoms out at the end of the travel. In that case, it will normally reverse and continue counting. This makes it end up somewhere in the middle of its travel.
I just rewired the Z-axis with more shielded wire to make sure that it was routed completely away from all other wires on the machine. The new wiring didn't help.
I know that I am showing my stupidity here, but just how do I go about checking the voltage as suggested above? The manual says to be VERY careful about hooking up meters to the control circuits as this may cause a catastrophic failure. So far, I only have one stepper that likes to choose its own direction. No smoke, yet.
Thanks for all of the help. This is VERY frustrating.

Svelte
05-05-2007, 12:37 PM
I just got an email reply from Xylotex. It seems that this symptom is the result of a loose connection somewhere on the Z-axis circuit. I checked all of my wiring and ran an entirely new line with no improvement.

Xylotex says that it is probably a problem with the control board. However, since I purchased this table from a private party (on eBay) and do not have the original invoice from Xylotex, they will not repair it even if I pay for it. That leaves me with no other choice but to purchase another controller at full retail. Since I have no run hours on this board, that seems a bit drastic. I guess I have learned my lesson about eBay and Xylotex.

I am going to purchase another three-axis controller, but certainly NOT from Xylotex!

Thanks for all of your help in diagnosing this problem. I hope that this will help someone else who may have the same problem.

dar303
05-06-2007, 12:17 PM
Don´t you have a friend who is into electronics that can help you diagnose the problem with the controller board or maybe you know someone on this forum that lives close by?
I checked their homepage and the card doesn´t seem to be that complicated, any electronics tech should be able to at least check for bad soler joints and such.
The manual says that you shouldnt connect oscilloscopes or multimeters to the motor terminals but it should be safe to measure the input signals, it sounds like your problem lays there.
I could have loked at it if i lived closer, i'm pretty much half a planet away... :)
Good luck

pminmo
05-07-2007, 01:02 PM
One axis failures on these all in one boards is one of the reasons to stay away from them.

Svelte
05-13-2007, 12:58 AM
This was my first foray into the world of CNC and I didn't know any better when I purchased this little machine. I now see the wisdom of purchasing separate controllers. The Gecko controllers look pretty good on their site and their customer support seems pretty good.

How do you feel about mounting the controllers near the motors on the machine? I saw this setup at a local supplier and didn't think much of it. Wouldn't it be better to mount the controllers together in an enclosure and keep them clean and cooled?

Does anyone have any suggestions other than Gecko?

I contacted their sales department (Gecko) and they told me that I could buy a 3-Axis setup and keep it for up to 2 weeks. During that time they would give me any tech support that I might need to get them up and running. If at the end of that time, I decided that I couldn't figure things out or didn't like their product, I could send them back for a full refund as long as I hadn't smoked them or beat them to a pulp. That almost seems too good to be true. If it is true, you sure can't get much better than that.

beausdn
05-16-2007, 02:22 PM
I had some problems on my first set up put 24v across the 5v logic... fried the driver. Mariss replaced it FREE best customer service anywhere, period! very worth the price and they are more then willing to help.

Thinwater
05-27-2007, 09:27 PM
If you are going to trash your current controller anyway you can't lose if you get a soldering iron with a fine point and re-flow any of the connections on the z axis part. If it is all in one spend 15 min and do the entire card. It can't hurt and most of these bad factory parts just have a cold solder joint in them somewhere.

Good luck, I think I am going to go with the Geco.

JIM

Bushman98
08-27-2007, 09:30 AM
Svelte:

Did you ever figure out the problem with your Z axis? I'm having the exact same issue with my brand new CNC. It worked fine for 24 hours, the next day I made some changes to the motor tuning and it seems that thats when the problems began. I went back to my original settings but the problems persisted. Did you find a solution? Any help would be apreciated.