PDA

View Full Version : Running with a wave driver , too fast?



Konstantin
03-30-2004, 03:31 PM
Hi, I am using unipolar motors with a wave drive and it seems that turbocnc energises the coils way too fast, in Motion Setup I get "Pulse width = N/A".

Do I miss anything ? Here is a snip from my ini file:

[AXIS1]
Designator=X
StepIncrement= 1.00000000000000E-0004
IsLinear=True
IsStep/Dir=False
Phases=4
Phase1=100000000000
Phase2=010000000000
Phase3=001000000000
Phase4=000100000000
Phase5=000000000000
Phase6=000000000000
Phase7=000000000000
Phase8=000000000000
Phase9=000000000000
Phase10=000000000000
Phase11=000000000000
Phase12=000000000000
Phase13=000000000000
Phase14=000000000000
Phase15=000000000000
Phase16=000000000000
PortAddress=$278
Acceleration= 3.00000000000000E+0002
StartSpeed= 1.00000000000000E+0002
MaxSpeed= 2.50000000000000E+0003
ABSPrescale= 1.00000000000000E+0000
Motor Resolution= 200
Leadscrew Pitch=20.0
Controller Microsteps= 1
Gear Reduction= 1.0000

[AXIS2]
Designator=Y
StepIncrement= 1.00000000000000E-0004
IsLinear=True
IsStep/Dir=False
Phases=4
Phase1=000010000000
Phase2=000001000000
Phase3=000000100000
Phase4=000000010000
Phase5=000000000000
Phase6=000000000000
Phase7=000000000000
Phase8=000000000000
Phase9=000000000000
Phase10=000000000000
Phase11=000000000000
Phase12=000000000000
Phase13=000000000000
Phase14=000000000000
Phase15=000000000000
Phase16=000000000000
PortAddress=$278
Acceleration= 3.00000000000000E+0002
StartSpeed= 1.00000000000000E+0002
MaxSpeed= 2.50000000000000E+0003
ABSPrescale= 1.00000000000000E+0000
Motor Resolution= 0
Leadscrew Pitch= 0.0
Controller Microsteps= 0
Gear Reduction= 0.0000

What I notice that in the ini file sez resolution = 200 but my steppers are 7.5 degrees step so res=48 is more correct, is it?
But within the program I cant see that option.

Ferenczyg
03-30-2004, 05:11 PM
You can try changing *.ini by hand I suppose..

Fer