PDA

View Full Version : CALIBRATION ISSUES



bsc95
11-03-2017, 07:29 AM
Hi there!

I am using a CNC 3020T with your USB CNC Controller software and I am having problems with the calibration process.
I have used the "axis SPU calibration" in File>>settings>>Axes. I am able to calibrate the distance on a displacement of 100mm on positive X direction after some iterations. However, after that, if I command it to move the same 100mm in the negative X, it travels way farther (around 145mm) and I ignore why.
First I thought it could have to do with a mechanical issue on the machine, but I reversed the direction of the axis so that a command to move in the positive would move in what previously was negative direction. then I calibrated in the positive direction just as before (but now physically moving in the opposite sense), and when I commanded it to move 100mm in the negative it still moved longer than it should.

The same occurs with the Y axis.
I tried the traversing at different speeds at it didn't solve it either.

I would appreciate if anyone could help me understand why the SPU seem to change depending on the direction of movement within the same axis, and how I could solve this problem. I have the feeling I am missing on something related to the settings of the device.

Thanks.

PlanetCNC
11-03-2017, 07:44 AM
I recommend that you carefully read this tutorial about SPU: https://planet-cnc.com/how-to-setup-cnc/

After reading it you should be able to set your SPU values correctly.