PDA

View Full Version : Newbie Z Limit Error



aziegler1961
10-27-2017, 09:34 PM
Hi All,

Got my first CNC machine a couple months ago. It's an older ShopSabre 4860. It came with WinCNC software I picked up VCarve Pro. I have successfully been able to carve a dozen projects so far but have much to learn. Today I programmed a couple projects and went to cut them and ran into an issue. With both projects as soon as I run the script the Z axis goes up to the top and hits the Z High Limit Switch which aborts the project. I have cycled the power, rebooted the PC, check material setup in VCarve, and I can't think of anything else to check. I have not changed any of the WINCNC setup files. Does anyone have any ideas for me to try?

THX, Andy

islaww
10-28-2017, 07:59 AM
Does it hit the limit (with red arrow on Z) or display a "Hi Z Limit" message?

In most cases a longer bit and/or thicker material combo combined with a clearance or home Z position that is too high will cause this. Assuming that the bit will actually clear the material by a reasonable amount, the solution is to adjust the Z heights in the material setup

aziegler1961
10-28-2017, 12:23 PM
Hi Gary, My Z Axis is traveling to the top and tripping my Z High Limit Switch which is triggering the red arrow in WinCNC next to the Z indicator. My machine is pretty large (48X60) and I have 5-6 inches of travel on the Z axis. I was running a 1/4 EM and my material was only 3/4 inch. I have run a couple old files that seemed to work fine, so I am looking more now at me .tap file and material set up but can't seen to find the culprit.

islaww
10-29-2017, 08:54 AM
Don't want to be Cap't Obvious here, but the code in the file is sending the Z farther than it is able to travel. This is either a result of an erroneous Z height in the file or improper setting of tool lengths and/or User Z offsets.

ShopSabre
11-04-2017, 09:28 AM
Hi All,

Got my first CNC machine a couple months ago. It's an older ShopSabre 4860. It came with WinCNC software I picked up VCarve Pro. I have successfully been able to carve a dozen projects so far but have much to learn. Today I programmed a couple projects and went to cut them and ran into an issue. With both projects as soon as I run the script the Z axis goes up to the top and hits the Z High Limit Switch which aborts the project. I have cycled the power, rebooted the PC, check material setup in VCarve, and I can't think of anything else to check. I have not changed any of the WINCNC setup files. Does anyone have any ideas for me to try?

THX, Andy


Hi Andy,

Feel free to contact our support team, we will happily try to help you through things as it seems it should be a fairly easy diagnosis.

Here is a link to our support request: https://www.shopsabre.com/support/

Thank you

- ShopSabre CNC