PDA

View Full Version : Wierd z axes problem



jonmessenger
03-01-2007, 04:49 PM
hello everyone, i am new to this forum, and would like a little input.
I am using turbocnc 4x

I have built, and been running a CNC Router of my own design, and all has been going pretty well. I bought an old 233mz Pentium laptop to run it, and that also has worked well. but this is where it gets weird. I wanted to put a different computer on it so i bought an old dell dimension for $40.

so now when i move x axis it is fine, z axis is fine, but y axis will move both y and z, z will go in the last direction that it went. my direction pin is not releasing, so when i move y, z will continue in the direction it went last. I can move z, with no problems but when i go back to y, it moves them both again

The port is set too bi-directional now, but i have tried them all, the address of the port is 0378h ...normal...i am using a stepperworld fet3 board.

i am assuming that the dell is the issue, but i am at a loss as how to resolve it, and would appreciate any insight you might posses.

Sorry i am so long winded, but all the info is relevant.

Thanks

JM