PDA

View Full Version : Is the Xpod inserted OK? it has ceased to respond...



lavalandiceland
12-22-2016, 02:55 PM
Good day, I have a Mach3 connected to a motion control card-MKX-V in my Omni Cnc machine and everything worked well untill now. The machine randomly stops and mach3 gives me this error message: "Is the Xpod inserted OK? it has ceased to respond" I have not changed anything and this suddenly starts and this has ruined many christmas projects that I have had going.
So I have checked all earth/ground connections,
I have tried to shut down everything else in the workshop except the pc and cnc machine so its not noise in the electricity.
I have changed usb cables,
I have put extra Ground wires,
restarted many times,
i have run many different codes and it just stops randomly.
I can press reset and turn the spindle back on and continue but sometimes the machine "moves the part!" and mills on wrong places..
It even stops when Im manually moving the machine. what could be the problem?

could it be the software? or the control card..

all the best from Iceland,

THOR

lavalandiceland
12-27-2016, 08:00 AM
Should this post be somewhere else? should i attach pics?

YeNyi
02-28-2017, 04:34 AM
Hi Friend
Do you solve the problem? Is the Xpod inserted ok?
I also got same problem as you and looking for solution.

Please share me if you solved the issue.

Thanks,
YeNyi

dharmic
02-28-2017, 04:49 AM
I had a similar issue where, after a few hours of running, my machine (not an Omni) would throw this error and shut down whenever the spindle was started up.

Turned out that the frame wasn't grounded. Grounding it - just clamping a wire under a screw on the frame and running it to a ground pin on the power board everything was plugged into - fixed it.

YeNyi
02-28-2017, 05:51 AM
Thanks a lot. I will do it and see how.

lavalandiceland
02-28-2017, 06:41 AM
Thanks a lot. I will do it and see how.


I talked to the ppl at Omni after going through all the advices that I could find in a few days on the internet. That Included grounding EVERYTHING back and forth.
Then the ppl at Omni told me it must be the computure so I went on and installed win 98 instead of vista that i was running ( was running fine for some months before this happened)
After that everything worked fine. Im not quite sure what happened in the first place but clearly some kind of software malfunction.
And yes, the I bought my OWN Mach 3. licenced to me but not some random dude :)

hope this helps

YeNyi
02-28-2017, 06:49 AM
Same for me.
It had been workings fine for months and problem come suddenly few days back. I also surf internet and followed some advises and suggestions, still not ok.
I will try grounding tomorrow.

Thanks a lot

YeNyi
02-28-2017, 11:54 PM
Dear Fri

Please let me share.

My problem (Is the XPod inserted ok? It has ceased to Respond) was solved. Still not 100 sure about what is the root cause.
I tried to isolate the problem.
Hardware
Change usb cable, check the usb port
Ground the spindle motor

Software
Reinstall the Mach 3 and Driver
Check the settings

All not working.
So, today, cleaned the CNC machine with blower, re-install the cables and wires. After that I test with new computer and it all ok.
So, I change back to old computer I used before. It is also ok now. I was amazed.

It may be because of some particles stuck on some wire connection cause the issue. I guess. Because I found the the spindle coolant pump on or off something stop the machine with same message.

Anyway, thanks for help friend
Ye Nyi







The best preparation for tomorrow is doing your best today. H. Jackson Brown, Jr.
Read more at: https://www.brainyquote.com/quotes/quotes/h/hjacksonb382774.html?src=t_inspirational