PDA

View Full Version : Homing X-Axis A-Slave



kaetamer
10-04-2015, 12:50 PM
Hi Guys,

I realize this is likely my singular problem but as a "public service" and as a way of stating the problem completely before my likely inevitable call to CNCRP I've been having the following problem. When attempting to "RefAllHome" the machine reacts appropriately (goes to machine X0, Y0, Z0) but does not complete the process in that a persistent message in the display states "Homing X-Axis A-Slave" as if some further process needs to happen. I've also noticed on the Diagnostics page the yellow indicator for M4 Home blinks intermittently and persistently until the gantry is moved away. The machine then appears to work normally.

I discovered the problem about two weeks ago when I attempted to profile cut a rectangle (in the 17 months I've owned the machine this was my first attempt at cutting this shape) and noticed it wasn't cutting 90* corners. Since the machine frame is square (by diagonals) I remembered the last line of Ahren's email (below) and attempted to "square" the gantry by use of the homing switches. This is when I discovered the problem.

By way of some history, when I first purchased the machine I had a problem with slaving the X and A motors. From an email at the time -

"When I "Ref All Home" the machine works exactly as it should but when the X movement comes to a stop the "X-" end of the gantry stops and then moves off the limit switch, as it should. The " X' " (X home ?) end of the gantry also comes to a stop, moves off the limit switch then does a ~ 1cm forward movement/backward movement before it comes to a rest. Looks like a "wiggle". Is this normal?"

I received the following from Ahren which solved the problem -

"After doing some research, it looks like in some cases the timing gets messed up a little during slaved homing, so it makes sense to change the homing script to a "Refcombination" instead of a "DoButton" for the X and A

If you open the 1024.set file in the screen designer and double
> click the "Ref All-Home" button, you will see the code is
>
> DoButton( 24 )
> DoButton( 23 )
> DoButton( 22 )
> DoButton( 25 )
>
> This basically calls the Z, then X then Y and A homes. This needs to be
> changed to ..
>
> DoButton( 24 ) ' this homes the Z
> DoButton( 23) ' this homes the Y
> RefCombination( 9 ) ' this will home the X and A at the same time.
>
> RefCombination accepts a number where X = 1 , Y = 2, Z = 4, A = 8, you
> simply add the values of the axis
> you wish to home, so X + A = 9..
>
> The squaring will be automatic and can be adjusted by your settings for
> the home position of the switches.."

I did this and the wiggle disappeared. Now this current problem. Related?

By way of reference:
1) The following is the contents of the script obtained by way of 'Operator' > 'Edit Button Script' > 'Ref All Home'
DoButton( 24 )
DoButton( 23 )
RefCombination( 9 )

DoOEMButton( 133 )
DoOEMButton( 134 )
DoOEMButton( 135 )

2) The "Abnormal Condition" indicator was always lit until I hit 'Set Normal Condition'. No change in M4 Home blink.

3) I tried swapping controller boards (I had a spare with a bad spindle relay) with no change.

4) I haven't switched limit switches reasoning it's supposed to sense the metal of the gantry and send a signal - the LED lights up and M4 Home blinks so I presume it's doing it's job.

Need some guidance please.
Thanks. Scott

ger21
10-04-2015, 01:09 PM
"Homing X-Axis A-Slave"

I think that this message is coming from your motion controller. Perhaps there are some settings in the plugin that you need to set?

kaetamer
10-04-2015, 03:56 PM
Thanks for your input.

By motion controller are you referring to the Smoother Stepper? I used the SCU v1.1 to configure it. Could you be more specific?
Thanks again. Scott

kaetamer
10-06-2015, 05:05 PM
Just to close the loop on this issue. I spoke to Ahren a few minutes ago and he discovered the sensor at the A-slave end of the gantry wasn't working as expected. I swapped it out with the sensor from the non-homing end of the Y axis and that solved it. The "wonky" sensor is still capable of sensing the metal of the gantry and should function as a simple limit switch. I guess my assumption that the limit switch sensor "is doing it's job" was incorrect.

Also, we changed the "Refallhome" script back to its original state owing to the latest version of the Smooth Stepper plugin - ESS_v10r2d1d.zip. That is -
DoButton( 24 )
DoButton( 23 )
DoButton( 22 )
DoButton( 25 )

DoOem Button...

Thanks again to the guys at CNCRP. The support I received today is why I purchased from them in the first place.
Scott