PDA

View Full Version : Strange G03 problem



sploo
11-14-2006, 04:57 PM
Hi all,

I've been having some problems converting DXF files to be cut in Mach. I'm using SheetCAM v4.0.0 and Mach3 v1.84.001.

I've attached a sample DXF file, and the resulting g-code, and the images show the path in SheetCAM, and Mach's Toolpath display.

For some reason, at line N0230 the G03 move causes Mach to take a large circular arc, but if I run the file through MicroTech's CncSimulator the simulated tool appears to behave as expected.

The source of the DXF is a little strange - it's come from 3D Studio Max, and was exploded twice in ProgeCAD before being exported out as an AutoCAD v2000 ASCII DXF file.

More complex files (with curved shapes) suffer from this problem very badly.

So... is the problem due to something odd in the DXF, SheetCAM doing something strange, or Mach not interpreting the g-code correctly?

Bit stumped on this one, so any help would be greatly appreciated.

ger21
11-14-2006, 05:41 PM
Change your I,J mode to incremental. Depending on what version of Mach you have, it's either in Config>State or the newer General Config.

HuFlungDung
11-14-2006, 05:57 PM
Hey Gerry,
You should add that answer to your signature. It seems like a common problem :D

sploo
11-14-2006, 06:15 PM
Doh!

In my defence... I've just checked the post file for SheetCAM, and, of course, it states incremental IJ for Mach. The default MachMill config, of course, also has IJ set to incremental.

The config file from which I based my setup has had that setting changed to absolute. I never touched it, honest!

It looks good in the Mach toolpath now and simulates OK. Unfortunately, it's now well past 11pm here in Blighty, so I'm going to have to wait until tomorrow night before I can test it :(

Glad it looks like I'm not the only one making that mistake though, thanks Gerry.

PS I pointed Les (SheetCAM's author) at this thread. Les - if you're reading... hopefully sorted (as you can probably see)... cheers.

ger21
11-14-2006, 06:24 PM
Hey Gerry,
You should add that answer to your signature. It seems like a common problem :D

I think that's twice this week, so far. ;)