PDA

View Full Version : Heeks 1.0 default language



cletero
10-30-2014, 08:19 PM
Hi, I'm trying the trial version of the new HeeksCAD (v1.0), which, IMHO seems GREAT so far, however, my only down side is that since my computer is in Spanish, the GUI is set to Spanish as default and to be honest, it's terribly translated.

Any way I can set the language to English? I tried looking in the options menu and others but couldn't find any way of changing this.

Meanwhile, I set my computers default language to English to solve the problem, but that doesn't seem right, and I'm not sure how it will affect other programs.

Thanks for any help.

Alfredo

itain
11-01-2014, 07:20 AM
Your language settings is doing nothing except setting an environment variable ($LANG on most systems) that is inherited by other programs.
It is possible to start a program with an environment variable other than the system's setting.

Try running (from bash)
LANG=en_US.UTF-8 heekscad
or
LANG=C heekscad

If that works, you can create a script or am alias that starts heekscad the way you like it.

Edit:
Since it's in the open-source forum and you did not specify which OS you were using, I assumed it's Linux.

cletero
11-01-2014, 01:21 PM
Hi, thanks for your answer.

Yeah, sorry, my mistake,I forgot to mention that this happens in Windows XP, I tried it yesterday in my Ubuntu Lucid install and it works as expected, so I will probably continue to use it in Linux ;)

Thanks anyway for your help, have a nice day :)