PDA

View Full Version : Okuma OSP2200 LSN-10



Russo1
08-24-2006, 03:24 PM
Hi

I bought a very old lathe. I'm trying to restore it to former glory and trying to get it into working shape. I am a IT specialist, so not much experience on lathes etc.

I do not have any diagrams of this lathe, nor any manuals. I've been searching and trying to find information (even pic's of working ones) and have not been succesfull.

I did decide that I won't use the tape reader and have bought a BTR.

I have a huge pile of cable, a hydraulic motor, cooling pump and the original "brain" box and the lathe.

I connected 380V 3 phase, and powered up, the hydraulics, nor cooling pump are connected. The console's lights came up. It said Out of tape or something similar. According to the guy who sold me the lathe, all the motors were tested and working.

Now this is to where I can take it.

Is there anybody that can help me. I can post pictures etc.

I will run this lathe on MasterCam XR2.

I will greatly appreciate, I've tried getting manuals, but at an average of $300 each, they're out my reach.

Thanx alot.

Al_The_Man
08-24-2006, 03:51 PM
What control is on it? some Okuma's were fitted with Fanuc 6T. If it has Fanuc, do you have the parameters etc?
Al.

mrainey
08-24-2006, 03:54 PM
When the time comes, I can help with OSP-2200 programming.

Russo1
08-24-2006, 03:59 PM
I'm actually not sure. What I could get on the Net is that apparently Okuma started using Fanuc controllers a few models later.

I've looked on all the boards, which seem to be VME to find any information, to no avail. I also sent a ton of mail to Okuma/Fanuc to see if they can give my any info. The only thing I could get a name on is that it has a Sanyo Denki Tape Reader. The servo motors are Yaskawa.

Where can I look to see if it is Fanuc? I greatly appreciate your trouble. I'll take some photographs tommorrow and post them. If it can help....

Thanx a million

Jarwalcot
08-24-2006, 06:01 PM
Here is a list of machine alarms that might help get you through the start up: http://www.homestead.com/mtsspecialservices/2200L_Alarm_List.pdf

Good Luck,

Yupower
11-09-2006, 08:31 PM
i am so glade that i finally find something usefull on the internet that can help me to fix my problem.
it's been a long time since i buy my okuma lsn-10 osp-2200 lathe but almost 6 years i can't get this thing started :(
i buy this as a undamaged and in a good condition mashine that has work in a workshop in switzerland,but from the first start i know that something was not ok.
many peopels and professionals try to fix the problem but nothing happend
1 year after my father and i buy this mashine we make a decision to call switzerland and tell about the problem and we came to the final decision to bespeak the binary and the program tape from japan.
and anybody now what happends next :P
the tapes dont fix the problem :(
after that,we send the tape reader to switzerland and the say that the tape reader are intact.
we also try to program the osp2200 with the klik klak switches on the front table of the osp2200 and nothing happends
we also detect that the tape do not stop on the position he should and he wont stop until i press reset.
now i find mastercam x2 and predator dnc on the internet and i am not sure that this programs can fix my problem-i also have a rs-422 connector on the osp2200
i almost forget-on the main display are no error codes just sevens and nines on all lamps and they dont changes all 6 years :)
i have the complet user guide of this mashine and we try everything step by step but nothing
soo if anybody can halp me to fix my problem then please write in this treath and i will be the happiest man on the world:) really
PS-sorry for my english,i try my best:rainfro:

Yupower
11-10-2006, 08:53 PM
have really nobody an answer for my question-please post if somebody can help me
thanx ;)

Jagermeister
11-13-2006, 07:49 PM
I have an okuma LS-N Big 10 sitting in sotage if you need a parts machine. Located in pennsylvania. Please get this thing out of here. LOL

Yupower
11-14-2006, 01:14 PM
hehe jagermeister you are really funny :)
look at my profile and you will see were i live LOL
no really-in what a condition are your lsn-10 and have you the osp2200???
thanx

Jagermeister
11-14-2006, 03:17 PM
The machine was in running condidtion when pulled from service. everything worked. It had a Mark Century 550 control.

Yupower
11-14-2006, 06:05 PM
and why you wont to get your machine out of your sotage???
my lsn-10 is ok (i think so) what i need is a specialist who knows exactly what's wrong with my osp2200 or an elektrical shema
but thank you jagermeister for your offer

rhino
11-16-2006, 03:20 AM
I have just printed this post out, i will have my OKUMA rep to have a look at it. then i'll let you know.

Yupower
11-16-2006, 05:50 PM
ok thank you rhino
if they are any indistinct in my post then let me now and i wil write exactly and step by step everything that im try

Yupower
12-07-2006, 04:59 PM
anything new about my okuma???

Russo1
02-01-2007, 03:17 PM
Well

I'm a little bit further. My machine powers up. The spindle is turning, the chuck is opening and closing, the turret turns correctly. The servo's are intact.

But I devoled a new problem. When ever I want to jog the axes, the Z axes just jump quickly from left to right (like it's loking for a position, which can't be found) and then stops and flash a Error 3, according to the alarm list provided in an earlier post it is a parity problem or the limits are outside of the feedback device. I've spoken to the Okuma agents in South Africa (not really anxious to help). Anyway, I swopped the encoders, as well as the drives. But exactly the same thing happen. When I disconnect the encoder, the servo runs extremely smooth until it hits the limit switch

I need to check some more, but at this stage I feel like it is the positioning card that is buggered, do you guys reckon the same, or might it be something else?

I can't get nothing registered on the keypads either, but one "expert" said I first need to get the axes right before anything else will happen.

I just feel that I'm quite close to actually cutting.

As always, all help is dearly appreciated.

Mstcnc
02-02-2007, 05:32 AM
If i remember right does this model of okuma use absolute encoders?
If yes, the encoders must show value inside machine work envelope when machine power is turned on.
Some old okuma lathes I have seen have machine origin position about 1,5m outside from machine! so you can not position machine axis physicaly in machine origo, the encoder position must be in right value straight from start up.

Regards Mika

Russo1
02-27-2007, 11:03 AM
Hi

Yes, they do have absolute encoders.

I finally got one Okuma engineer to talk to me on the phone for about 3 minutes. He thinks that the problem does not lie with the encoding or machine position, but with the tacho. Now I've actually took off the tacho, damn there can't be much wrong with it, it has a copper disc (tracked) and 5 magnets. Brushes seems OK, so now I'll start tracing and see if I get any voltage on the Tacho and its wires.

I must be honest I'm getting a little discouraged now. I'm so close, and now I sit with a machine which jumps on one axes. Everything else is now fine and working. Oh, that was a little lie, my front turrent is spitting out H fluid, think I burst a pipe the other night.

By the way, when my z axes jumps around, it actually is encoding / recording the position. I measured the distance from where I turned it to 0 and it actually is spot on!

I really need to get tjis now up and running. Got a PMAC (Delta Tau) ready for a transplant, but then I'll have to get rid of the encoders, and they seem so damn nice.

Anyway will keep posting.

ANd again thanks for the help.

Yopower, pm me, I found some electrical diagrams, which I can scan and send to you if you still need them.

Regards & keep well

keithorr
03-13-2007, 06:06 PM
What is the head bore on this machine?

Yupower
03-14-2007, 05:51 AM
hmm were can i read this-head bore???

keithorr
03-14-2007, 06:12 AM
hole through the spindle

Yupower
03-14-2007, 06:55 AM
you can place nothing true the spindle
there is no hole
the spindle is hidraulic

Yupower
07-26-2007, 04:31 PM
hello everyone,im still not further with my machine,i have done some tests with the osp 2200,the voltage an the cpu voltage are now in proper range.the binary tape stops at the last holes but the no1 control tape just want to stop stop at the last holes.
what i explore on the main switch board is that 2 leds dont work properly one light al the time and one newer,but when i place the memory switch in the up position then they work.but with the PC switch in up position-on then they dont work.i am 99% sure that a circuit board are bad.have anybody any idea???
i newer come to this conclusion without help from a friend from america and i thank him so much
Regard

Yupower
10-02-2007, 06:06 PM
Hello everybody

i have to update this treath with my newest results

i find some used pcb boards in finland and buy the
memory module (16K)
mother board
3D Board
Switch board and pcb board behind the switch panel

After i plug in the new boards i first try the flickering method (that dont work with my original boards)and try to feed the memory with the control tape NO1
The tape dont stop at the last transport holes so i try bootstraping the machine and load the binary tape.everything work just fine to the binary tape.and then when i try to load the control tape NO1,the tape dont stop at the end and just runs trough,i try everything about 50 times but i ever get the same results.
i think that there could be a problem with the 1F2C pcb Board that controls the work of the tape reader.but if so,why the biary tape stop at the correct place and the other tapes not.i also receive the tapes of the new memory module.
have anybode an idea what could be the problem here?????
i would really appreciate any kind of answer.
Thanks guys:D

Yupower
11-13-2007, 06:49 PM
Ok guys i got finally this machine started:rainfro:
sorry mods for updating this thread again but i just want to help some people (if there are still someone like me that uses osp2200) who maybe have the same problems so i can help them,cause the machines are really rare but reliable and still good working after 30 years.
i manage to fix my problems but i had to change all of the pc boards in my osp 2200.
after that everything went good and now i have a fully funktional machine:)
so if anybody have a problem with a osp2200 i would really like to help them
dont hesitate to contact me at

yupower1@hotmail.com
or
boracompany@gmail.com

Regards to everybody who read this thread

Respect to the CNCZone Forum

just keep on to do such a nice job

HeadsUp
03-09-2009, 02:52 AM
hey guys , anyone know the motor and controller specs on the LS-N ?

horsepower , maximum speed , and controller type , ie MOSFET , IGBT , inverter or star delta etc ???

Yupower
03-09-2009, 08:47 AM
hi
i have all manuals,do you maybe know if there are this specs writen,so i can look and scan you this pages
regards
Bora

HeadsUp
03-09-2009, 09:04 AM
hello

i dont know what page they are on

i am looking at if i can use the motor and controller in an electric vehicle

the horsepower for the motor should be there at least

is there a page for specifications or power consumption ?

any detail or pictures to connect to the motor controller ?


thankyou if you can help

Yupower
04-28-2009, 04:35 PM
Hello Friend
is me again with my old okuma :))))))))))))

my machine is running but i have still problems to use all of his options and i can only use G0 G1 G2 G3 and one tool

i will write again my problems and what kind of work iv'e don't on the machine



It's a long time ago since we bought the machine unfortunately in a bad condition.first we did,we order original tapes from okuma switzerland a tried every option to load the binary,#1 and #2 tape but with no success,only the binary loadet but the two others never.

After that i made contact to a man in USA and first of all we checked the voltages and everything else that have to be check't on the machine and we came to a conclusion that the memory board is death 100%

Then i found a man in finland who had 2 of the okumas and he was willing to send the memory,mother,switch and #3 board to serbia for a really fair price.

the boards arrive'd and i imediatelly change my old boards with the new ones.
unfortunately no luck.

i ordered the other 8 bards from finland and so i changed all pc boards on my okuma

bootstrap good
binary tape good
control tape #1 good
control tape #2 good

i power up the machine and i saw the first time only zeros on the display :)))))


after that i had to learn how to use and to program that machine and so i discover that some options are not working.

MDI don't work at all

tool offset also

after loading anykind of program to the memory its impossible to edit the program in the memory -error 79

lap programing also don't work,the machine don't shows any king of errors but shes not doing what she should.

Things that work

tool changer

changing spindel speeds,but only with help of a tape because the mdi dont respond

zero set

working with simple programs and one tool


ok that preatty much all

a big thing that i have to say is that it could be a hardware/software problem
i notice that the machine originaly only have 2 decimals (one nixie tube place on the pc board is empty) and by the original books you have to write programs with 2 decimals

i did that the first time i wrote a small program and run straight in the workpiece :)))))))
fortunately nothing bad happend so i discovered that i have to write programs with 3 decimals.

i also notice that the direct tool offset buttoms are empty by default and maybe my new boards have the options to DTO,there are cables behind the control panel right behind the holes where the DTO buttoms should be.

I think that are enough informations for some specialist and i really hope that someone can help me to fix my problem,i would really appreciate that.

PS:here are some pictures
I will also upload some pictures of the tapes that i have

Regards to all

Bora



http://i264.photobucket.com/albums/ii197/Yupower/DSC03759.jpg

http://i264.photobucket.com/albums/ii197/Yupower/DSC03760.jpg

http://i264.photobucket.com/albums/ii197/Yupower/DSC04082.jpg

http://i264.photobucket.com/albums/ii197/Yupower/DSC04083.jpg

http://i264.photobucket.com/albums/ii197/Yupower/Photo_0119.jpg

http://i264.photobucket.com/albums/ii197/Yupower/Photo_0120.jpg

sertec
05-11-2009, 05:14 AM
Hi,

If you cannot input data from keypad then please check the jumper on Slot IF2 and make sure that K-B is jumpered. This will then enable the keypad. Make sure that the connection next to K-B( on the left ) is cut.

sertec
05-11-2009, 05:20 AM
Hi,

I have just noticed the Tapes on your Photos.
Make sure that you only load the correct Tapes for that machine.
Control Tape No.2 is your "Options" Tape. There will only be one of these and not very long. If you have load the incorrect Tapes then you would be lucky to have anything running correctly.
Again, please check that you load the Tapes for that Machine.

Yupower
05-12-2009, 05:12 AM
Hello Sertec

Thanks for your reply,i check almost everyday this thread for new reply's and anykind of help makes a smile on my face :rainfro:

i pulled out the if2 board and it looks like that K-B is jumpet and jumber next to K-B is cut,but i have also notice that there is no option to change this because this is so made by stock,you understand what i try to say,there are no jumpers like on new computer's,i will also make a few pictures later this day.
I also notice that (K) on the back side is connected to the other jumper but i think that this is normal because this are dubble side printed boards.

About the tapes, i think that there are loadet correctly,#2 tape is almsot 3 times shorter then #1 tape
but there are also big differences between my original tapes and and tapes i bougth with my new boards.i will also make some pictures to clear what im talking about

Regards
Bora

sertec
05-12-2009, 06:37 AM
Is your Machine #1144?
If not then please use Original Tapes.
In fact I would use the Original Tapes first.
The Tapes that you bought with the other boards sound like they come from another machine. Don't use them.
Normally if Control Software Loads up ok and the computer runs, and there are still programming issues or machine is not running correctly, could mean that there is a problem with your tapes.
If there were any faults in Slot3~6 then machine would not run or in most cases you would not be able to load Control Software.
IF1 will affect the Panel and some Display functions. - could be a problem
IF2 will affect MDI Input and Tape Reader. - should be ok
IF3 is only Input / Output. - Possible problem but I think Unlikey as you have too many problems for this to be causing them all.
IF4 is ok as you can move axes around.
Are you running CMOS Memory( 16K ) or Core Memory( 2 x 8K )?
If CMOS( 16K ), has Slot 3C been changed to 3D and Modification to Motherboard been done?

Lots to check but we need to start form the beginning now to make sure all is correct.

Cheers

Yupower
05-12-2009, 08:52 AM
Hi sertec

First of all here are the pictures
right are the tapes i ordered from japan a few years ago and left are they i bought with the new boards

the other two pictures shows the jumpers on the board on front and backside on the IF2

i think this is clear now
http://i264.photobucket.com/albums/ii197/Yupower/Image0101.jpg

http://i264.photobucket.com/albums/ii197/Yupower/Image0100.jpg

http://i264.photobucket.com/albums/ii197/Yupower/Image0099.jpg





ok now to your questions

i have a 16K memory board but im not exactly sure if it is CMOS or core memory but i have all pictures of my new boards and i will upload them later this day.

i also have to say that i changed everyone of my boards including the motherboard and the switch board so i dont think that i have to make some changes on the motherboard.
i also have the 3D board next of the memory board where you can select the sice of the memory board and this is also ok

regards

Bora

Yupower
05-12-2009, 02:54 PM
ok its me again with some new pictures
i hope that this thread will also help other people who have problems with this machine:)

@sertec
here are all my pictures from my new boards


http://i264.photobucket.com/albums/ii197/Yupower/DSC03769.jpg

http://i264.photobucket.com/albums/ii197/Yupower/DSC03766.jpg

http://i264.photobucket.com/albums/ii197/Yupower/DSC03765.jpg

http://i264.photobucket.com/albums/ii197/Yupower/DSC03763.jpg

http://i264.photobucket.com/albums/ii197/Yupower/DSC03758.jpg

http://i264.photobucket.com/albums/ii197/Yupower/DSC03757.jpg

http://i264.photobucket.com/albums/ii197/Yupower/DSC03756.jpg

http://i264.photobucket.com/albums/ii197/Yupower/DSC03755.jpg

http://i264.photobucket.com/albums/ii197/Yupower/DSC03754.jpg

http://i264.photobucket.com/albums/ii197/Yupower/DSC03753.jpg

http://i264.photobucket.com/albums/ii197/Yupower/CIMG0388.jpg

http://i264.photobucket.com/albums/ii197/Yupower/CIMG0386.jpg

http://i264.photobucket.com/albums/ii197/Yupower/CIMG0385.jpg

http://i264.photobucket.com/albums/ii197/Yupower/CIMG0384.jpg

http://i264.photobucket.com/albums/ii197/Yupower/CIMG0383.jpg

http://i264.photobucket.com/albums/ii197/Yupower/CIMG0382.jpg

http://i264.photobucket.com/albums/ii197/Yupower/CIMG0381.jpg

http://i264.photobucket.com/albums/ii197/Yupower/CIMG0380.jpg

http://i264.photobucket.com/albums/ii197/Yupower/CIMG0379.jpg

http://i264.photobucket.com/albums/ii197/Yupower/CIMG0378-1.jpg


i have to notice that my old board are tan color so this are newer generation boards and i thank that everysingle one of them are in a good condition.

you told me that i should try to load my old tapes and today i think about that and i know that a few months ago nothing happend because the tapes dont stop on the last transport holes where it should stop if the tapes are properly loadet.

there is also a problem with the control tape #2 from my new boards because the tape was in such a bad condition that i had to fix the tape before i load it the first time in the memory
here are a few pictures

http://i264.photobucket.com/albums/ii197/Yupower/DSC04063.jpg

http://i264.photobucket.com/albums/ii197/Yupower/DSC04064.jpg

http://i264.photobucket.com/albums/ii197/Yupower/DSC04068.jpg

http://i264.photobucket.com/albums/ii197/Yupower/DSC04071.jpg

i fixed the whole tape and it run trough the tapereader and stop at the end,i think that is a clear sign that the tape is ok now,or maybe not???????
i really dont know i just want to run this machine

regards

sertec
05-12-2009, 03:32 PM
Thanks for the Photo's. Jut one thing, can you punch holes where you have used cellotape. Sometimes the Tape Reader will not read thru the cellotape.

Yupower
05-12-2009, 04:21 PM
i tought about that and i can do that with a soldering gun
i will try this next
do you have any other clues that i could try
thanks for your reply

sertec
05-12-2009, 09:32 PM
You are using Core Memory.
Can we go thru the steps again of how you have loaded the Control Tapes.
1. Start by using the switches as per instructions in manual
2. Then load binary Loader
3. Load Control Tape No. 1
4. Set Switches
5. Load Control Tape No.2
6. Power Off.
7. Power On.

do you get this far?

Yupower
05-13-2009, 04:40 AM
i done all this correct with the tapes of the new boards

the original tapes didn't stop at the end and run straight trough the reader so i went to the new tapes and get this far

sertec
05-13-2009, 04:48 AM
ok thats good.

Make sure of the following:

can you set your zero offsets?
can you set tool offsets?
can you edit program?
can you select speeds by MDI( is your machine 12 or 24 speed )?
can you select Tools( what config is your machine( V6 + H4 etc )?

if you can do all of the following then i would say you have a runner.

Yupower
05-13-2009, 06:01 AM
can you set your zero offsets? ------Yes
can you set tool offsets? ----------- No
can you edit program? -------------- No

can you select speeds by MDI( is your machine 12 or 24 speed )?
------i have 12 speeds and changing speed with the MDI dont work but it changes speeds when i load a program


can you select Tools( what config is your machine( V6 + H4 etc )?
------tool changing works good,it also work when i load a program
but i cannot change tools with the MDI

yes it is a V6 + H4

sertec
05-13-2009, 06:10 AM
You say you can set zero offset. ( Front and Rear Turrets )

Can You Type any Number when setting Zero Offset

eg 1234.56 WRITE

then press Slide hold to Calc Position

sertec
05-13-2009, 06:12 AM
Please explain how you ran a program

Yupower
05-13-2009, 08:27 AM
Hello Sertec
here is a link to rapidshare where i upload 2 videoclips,the quality on youtube is to bad so i decide to upload the original one's

http://rapidshare.de/files/47141737/Desktop.rar.html

you can see clearly there that zeroset works good but i can't write anything on the MDI

on the other clip you see a short program with a radius.
before i run any programm i first set the zero on the back of the workpiece by Z
and in the middle by X

i do that with every tool and i write seperate programs for each tool cause as you see tool offset and mdi dont work at all.

i hope that my problem is much clear now

thanks for your help

sertec
05-13-2009, 04:48 PM
Ok thanks for the Vids.

Your problem has got to be IF2 - This is the board which controls all MDI Function.
Even when you set your Zero Offset it looks like you cannot enter Data.
So either problem is in IF2 or The Data Keypad.
Can you double check to make sure that K-B is connected and the connection on the left of K-B is cut ( disconnected ).
Please use multimeter to check.

Yupower
05-13-2009, 05:09 PM
i will check this tomorrow it is late now
thanks for that information

sertec
05-13-2009, 08:54 PM
Also if all looks ok then check the wiring from Data Keypad to IF2.
Check connectors at IF2 and make sure all pins have pushed in.
Sometimes the pins will push out or have come loose.

Yupower
05-14-2009, 06:28 AM
hi sertec

i check everything you say

connectors are in a preatty good condition,cables are also good,the osp2200 case look very healty,there is really no sign that a cable could be snap'ed somewhere.
i also open the data keypad and there are also no sign's that anything bad happend.the pc board behing the mdi where the 10 digit's are is also good.

i will today try to load again the control tapse,but first i will clear the holes and get rid of the cellotape so the reader can easy read the data.

regards
Bora

Yupower
05-14-2009, 10:22 AM
Hello Sertec

here are the results from my todays research

first of all i cleaned the cellotape from the holes and i read the tapes with the flickering method.
everything went good but i have again the same results,no MDI,no tooloffset function.

then i went to my original tapes,i load them also with the flickering method and both tapes stop at the last transport holes.i restart the panel but the controls dont came up,nothing works,and the digit's show some wierd numbers.

after that i load again the tapes i bougth with my new boards and now im back again where i was :)))))))


i just want to say that i still have my old boards.
a few months ago i tryed to replace the IF2 board with my original IF2 board (thinking that maybe this board is not compatible with my display),as i power up the machine,the Z axis begone to jump violently back and forth and i immediately shut down the system.i install again the new board and everything was ok again,maybe this information gives you a clue?????

i really dont know what to do next :(((((
it looks hopeless.

do maybe someone know how i can contact okuma directly do get some informations?????

thanks to all
regards
Bora

sertec
05-14-2009, 02:55 PM
I still believe the problem is the IF2 Board.
Are you able to get another IF2 Board?

Yupower
05-14-2009, 04:01 PM
hmmm i dont think so because this boards are pulled out from a working machhine-that is what the seller told me i dont think he is lying.

unfortunately he sold all of the remaining parts he had and i dont think that i can find some boards again.
the IF2 board dont look much complex,is it hard to find any damage or bad integrated circuit????
i could maybe use some parts from my old boards if i manage to find any damage,but i have to send them to a professional to check them i dont think that i can do that.

sertec
05-14-2009, 04:10 PM
Can you contact me on sertec@surfer.co.nz
I have complete sets of OSP2200 PCB's

cheers

Peter

Yupower
05-14-2009, 04:11 PM
i installed scype right now
regards

virgoviggo
01-07-2010, 03:13 PM
did you guys ever get this machine up and running?
what was the problem?

do some one have somekind of boot (clickclack switches) info in pdf form?

manuals in any shape?

electrical schematics?

have a look at these old bits!!!!

http://www.cnczone.com/forums/showthread.php?t=91094

virgoviggo

Yupower
01-24-2010, 05:45 PM
contact me at

boracompany@gmail.com

i receive a lot of help from many people from the internet so i have many lot of documents for you

Regards

underthetire
01-25-2010, 11:11 AM
Dump the OSP2200 and do an upgrade. Most parts are not available any longer, almost no service guys alive any longer to fix it, and no CRT or memory. Last one I even looked at was ten years ago, and I think the repair bill at that time was 6K. 4K just being 2 boards.

Mrtoad962
01-25-2010, 01:29 PM
Contact
Service@robertemorris.com
they can help with your Okuma

Yupower
02-05-2010, 05:55 AM
I have one simple question

Is it possible to chance the tool offsets on the postprocessor for an okuma lathe?

Algirdas
02-08-2010, 03:46 AM
yes, it is possible

Yupower
02-08-2010, 05:16 AM
any clue :rainfro:

Algirdas
02-08-2010, 01:49 PM
clue:
use system variables

CNCZILLA
02-09-2010, 03:28 AM
underthetire is correct, you can't get anything or find anything for a machine this old and even at Okuma you would be lucky if you could find any help at all. It would have been nice for someone to have advised you against this purchase unless it was givin to you. Anything that happens with this machine at least from a electrical standpoint and you are stuck. Best advice is to get rid of it if possible while you still can before these machines become boat anchors. To upgrade this control to a new one would not evern be worth considering $$$$$$$$$$$. For what you would have in the machine plus the upgrade and you could have bought a decent one. Okuma was probably the best decision for a lathe purchase but i would recomend 700/7000 control or up for future reference.

Yupower
12-14-2013, 10:43 AM
Hello guy's

I hope you all are still well.
Im still stuck with my machine,but i use it now alot and work as much as it is possible with one tools,i become a professional to build parts with one tool :))))))))))))))))

I would be glade if any of you can find a little bit of free time to read my previous posts so you can remember my problem.
Im looking now at my IF2 board and i think that maybe i miss some cables from the display to that IF2 board,because my older boards didnt have direct tool offset.
In meantime i installed some switches for the direct tooloffset because originally my machine didnt have that,i also installed the buttom for machine lock and that one is working,the other tree dont show any since.

So,is it possible for somebody to make pictures of the connectors from the IF2 boards just to see if there are some cables missing in my machine.

B

fordav11
12-14-2013, 09:46 PM
I've been watching your posts for a long time. I worked the very same machine 25 years ago. Brings back memories (not all good ;-)
I have the manual if you need info from it.
I have a smaller PDF version of operator and programming manuals but it is only a few pages (approx 50 pages in each pdf compared to full manual which is over 1000 pages). I can upload it if you need.

For your problems I would guess you have PCB problems. The OSP2200 has no CPU, it is all just logic chips and such. the good thing about those old PCBs is the chips are all common TTL logic chips and can be bought for a few cents each. If you know how to remove the chips without damaging the PCB and you have the required equipment you could theoretically replace every chip or remove and test each chip and replace only the bad ones and it would be working. I've been repairing electronics for 15 years and I have never seen a machine that old that did not have chip problems. You really need someone who can help you with the electronics and preferably someone who works for beer not money, otherwise you will go broke with the repair costs. seriously you can buy a used working machine for about $10k or slightly less and start using it immediately. Your machine is really not worth the effort unless you have the knowledge to repair it yourself.

btw, the maintenance section of my manual mentions 2 test tapes (CPU, Interface). Do you have those? If yes it is possible to diagnose exactly which PCB is faulty. Your IF2 board is probably ok if your tape reader works and you can read in valid NC code.
there's also a lot of strange tests can be done with selecting 'CHECK' on the display selector switch and setting the various panel file switches up/down in different combinations. the manual has a large table of settings and checks... many many pages of maintenance and diagnostic info. it even tells you how to type in a bootstrap program via the switches (like the old early 70's computers... Altair 8800 etc). but the end result is mostly the same... replace this PCB or that PCB.

try to summarize everything so far. Tell us exactly what you CAN do. does the machine function? can you run a program? can you edit a program? can you manually run the machine? can you make it do something in MDI? can you change offsets. etc etc.
possibly most importantly the OSP2200 system is very strange and different to common Okuma and Fanuc systems available now so do you actually know how to operate it properly?

Yupower
12-15-2013, 04:34 AM
Hello Fordav11

Yesterday i took some time to make a few pictures just to clarify what i did the past few years on the machine,btw,i use the machine a lot,yesterday i was working all day long producing some glue nossles out of PE1000 plastics.
Everytime i work with the machine i ask myself what could be the problem with this machine :)))))))))

Here is again what i think the problem is.
About 5 years ago i changed all old PC boards because the machine was never working.
After installing the new boards and loading the binary tape and #1 and #2 tapes i notice that MDI function is not working.
My okuma was originaly from swiss,it didnt had direct tool offset and one nixie tube (the 3 one behinde comma) is missing (show picture)
So i found that behind the display panel some cables are free exactly at the position where the direct tool offset buttoms should be (notice that the buttom configuration is not the same like on US machines)
My friend installed some buttoms as you can see but only the machine lock buttom works.
I was thinking maybe the MDI is not working because the buttoms are missing.
Now i think that maybe some cables between the display and IF2 boards are missing,because Sertec mentioned in an earlier post thet he is almost sure that something is not ok with that IF2 board.

Here is a video i made yesterday just to show you exactly what the problem is.

https://www.youtube.com/watch?v=dGxtxuznKaY&feature=youtu.be

I also made a few pictures so it would be good if anybody who have still an old okuma can make some comparsion if there is some cable missing.

http://i264.photobucket.com/albums/ii197/Yupower/Okuma%20LS-N%2010%20OSP2200/th_DSC01942_zpsf29c64f7.jpg (http://s264.photobucket.com/user/Yupower/media/Okuma%20LS-N%2010%20OSP2200/DSC01942_zpsf29c64f7.jpg.html)http://i264.photobucket.com/albums/ii197/Yupower/Okuma%20LS-N%2010%20OSP2200/th_DSC01943_zps871bc5b3.jpg (http://s264.photobucket.com/user/Yupower/media/Okuma%20LS-N%2010%20OSP2200/DSC01943_zps871bc5b3.jpg.html)http://i264.photobucket.com/albums/ii197/Yupower/Okuma%20LS-N%2010%20OSP2200/th_DSC01944_zps0c643787.jpg (http://s264.photobucket.com/user/Yupower/media/Okuma%20LS-N%2010%20OSP2200/DSC01944_zps0c643787.jpg.html)

Here is my panel
Notice the 4 red buttoms i installed
http://i264.photobucket.com/albums/ii197/Yupower/Okuma%20LS-N%2010%20OSP2200/th_DSC01945_zps71a48816.jpg (http://s264.photobucket.com/user/Yupower/media/Okuma%20LS-N%2010%20OSP2200/DSC01945_zps71a48816.jpg.html)

Here is the missing nixie tube
http://i264.photobucket.com/albums/ii197/Yupower/Okuma%20LS-N%2010%20OSP2200/th_DSC01946_zps5bc6f4be.jpg (http://s264.photobucket.com/user/Yupower/media/Okuma%20LS-N%2010%20OSP2200/DSC01946_zps5bc6f4be.jpg.html)

And here are some random pictures if the panel
http://i264.photobucket.com/albums/ii197/Yupower/Okuma%20LS-N%2010%20OSP2200/th_DSC01947_zps3e76fff0.jpg (http://s264.photobucket.com/user/Yupower/media/Okuma%20LS-N%2010%20OSP2200/DSC01947_zps3e76fff0.jpg.html)http://i264.photobucket.com/albums/ii197/Yupower/Okuma%20LS-N%2010%20OSP2200/th_DSC01948_zps1cad2f25.jpg (http://s264.photobucket.com/user/Yupower/media/Okuma%20LS-N%2010%20OSP2200/DSC01948_zps1cad2f25.jpg.html)http://i264.photobucket.com/albums/ii197/Yupower/Okuma%20LS-N%2010%20OSP2200/th_DSC01949_zps872af5f7.jpg (http://s264.photobucket.com/user/Yupower/media/Okuma%20LS-N%2010%20OSP2200/DSC01949_zps872af5f7.jpg.html)

http://i264.photobucket.com/albums/ii197/Yupower/Okuma%20LS-N%2010%20OSP2200/th_DSC01950_zpsfc428ea0.jpg (http://s264.photobucket.com/user/Yupower/media/Okuma%20LS-N%2010%20OSP2200/DSC01950_zpsfc428ea0.jpg.html)http://i264.photobucket.com/albums/ii197/Yupower/Okuma%20LS-N%2010%20OSP2200/th_DSC01952_zps6a89f919.jpg (http://s264.photobucket.com/user/Yupower/media/Okuma%20LS-N%2010%20OSP2200/DSC01952_zps6a89f919.jpg.html)

This are the 4 buttoms i installed
http://i264.photobucket.com/albums/ii197/Yupower/Okuma%20LS-N%2010%20OSP2200/th_DSC01951_zps70d9c34f.jpg (http://s264.photobucket.com/user/Yupower/media/Okuma%20LS-N%2010%20OSP2200/DSC01951_zps70d9c34f.jpg.html)

This pictures show you how the cables where installed before i put these 4 buttoms
http://i264.photobucket.com/albums/ii197/Yupower/th_Photo_0120.jpg (http://s264.photobucket.com/user/Yupower/media/Photo_0120.jpg.html)

Panel before i installed these 4 buttoms
http://i264.photobucket.com/albums/ii197/Yupower/th_DSC04083.jpg (http://s264.photobucket.com/user/Yupower/media/DSC04083.jpg.html)

Here are some tapes i recieved with the boards
http://i264.photobucket.com/albums/ii197/Yupower/th_DSC03760.jpg (http://s264.photobucket.com/user/Yupower/media/DSC03760.jpg.html)http://i264.photobucket.com/albums/ii197/Yupower/th_DSC03759.jpg (http://s264.photobucket.com/user/Yupower/media/DSC03759.jpg.html)

I think that is enough to get some idea what could be the problem :)))))))))))))))
Btw,i have all manuals and documents of the machine

Regards and thanks to everybody
Bora

fordav11
12-15-2013, 05:21 AM
It's good to see you have the machine mostly working :-)

the red buttons are an option called 'Direct Tool Offset' which is enabled with G54 and G53. Otherwise they do nothing. they are not needed to adjust normal offsets. You can leave them unselected. in fact ENABLE button (1st one) should remain off. the missing components on that board are probably for this option so even with your switches wired in they do nothing. the option is basically useless anyway.

I watched the video. you certainly pressed and rotated many switches ;-)
it was too many years ago when I worked the machine so I have no idea what you were doing with the button pressing and switch turning, but it looked impressive ;-)
it also does not help that the panel is not in English.
Yes I could see the MDI panel and the offset number selector switch is non-functional.

Your panel is a little different to the one in my manual.

I see you have the Interface Test Tape so you can test IF2 and know exactly the fault.
you would need to follow the manual instructions how to use it. my manual has the info in 1938-E page 39
there is one item with a bunch of numbers and it says if you get those numbers the manual data input control is defective and to replace IF2. so at least we know IF2 controls MDI :-)
but also IF2 controls many things including the tape reader so it is at least partially working. it may not be faulty at all.

since you have no MDI input I would look where the MDI connection goes to and start with that PCB. check every wire of the cable connection for continuity at both ends. looking is not enough you must use a multimeter. if they are ok most likely one or more chips are non-working on whatever board the cable is connected to.
also check where the wires go to from the offset number selector switch. that can also give a hint to the location of the fault.
if you can supply a HQ photo (chips need to be readable) of that board I can advise where to go next.

you can diagnose the MDI button panel quickly. use a multimeter set to continuity to test each switch when pressed. I have no idea what the back of the switches look like but there could be 2 connections on each switch. put one probe on each connection and when the switch is pressed the switch will make contact together and a beep will be heard on your multimeter. if the switches are working your fault is on the board where the MDI panel connects.
if all of the switches don't work it could be as simple as a missing ground signal because usually multiple chips will accept inputs from the buttons unless they are multiplexed through one or maybe two chips. the likelihood of multiple chips that control the MDI input being bad is quite low. you could still have multiple chip faults but you would normally have multiple faults. all of your problems seem to be offset related so the faulty component seems to be common to both problems. the problem is probably easy to fix once we know where it is coming from. I'm guessing cable, connectors or chips.

technically you dont need offsets. you can change the G50 for each tool to get the size but of course that means making a new tape ;-)

you could also install a BTR to DNC the machine so you could run the programs via tape mode from a PC terminal program. then changing G50's is easy.

Yupower
12-23-2013, 12:07 PM
Hello Fordav11

How would the program look like with G50 if i use 2 tools,to do some simple diameter cutting like one pass with the first tool to diameter 20.5 at 100mm lenght
and second tool 20mm diameter also 100mm lenght
Lets say that the offset between these two tools is X10mm and Z10mm.

fordav11
12-23-2013, 10:55 PM
Does your zero-set work? Can you change the origin/zero point? If yes set the first tool Z to the zero of your part and the X to the center of the chuck (X0), rapid back to an index position (say X200.0 Z200.0), zero the position, index to your next tool and move your tool to the known part face Z0 and diameter. record the distance moved in X and Z. The Z distance is your next G50 Z value. The X distance moved + the diameter you touched is your next G50 X value. If you know how to set G50's on a Fanuc 6T then this will make sense :-)

G50's are generally used on a machine that has a zero return position. I dont think the LS-N had that but you can make one by bolting a dial indicator to the end of the bed so it touches the saddle. then manually rapid the saddle to the indicator so it turns a couple of revolutions and zero the dial. that can be your home position.

now you zero the position on your readout (zero set, if that works?) then rapid the turret to your work zero position. the distance the saddle moves is your G50 Z value (lets say it is 1200.0) and the distance from tool 1 to tool 2 is subtracted or added from the G50 to give the new G50 for your tool 2. after you have finished with T1 you rapid back to the home position for *that tool* (1200.0) then index your next tool and set the G50 from there for that tool.
it's been 25+ years since I wrote anything for an OSP2200 but here goes.....

N0010 G14
N0020 G50 X200.0 Z1200.0 S1000
N0030 S61 T11 M03
N0040 G00 X20.5 Z3.0 M08
N0050 G01 Z-100.0 F0.3
N0060 G00 X200.0 Z1200.0 M09 (GO BACK TO HOME FOR T1)
N0070 M05
N0080 M01
N0090 G14
N0100 G50 X190.0 Z1190.0 S1000 (NOTE G50 OFFSET IS 10MM DIFFERENT IN X AND Z FROM PREVIOUS TOOL)
N0110 S61 T22 M03
N0120 G00 X20.0 Z3.0 M08
N0130 G01 Z-100.0 F0.3
N0140 G00 X190.0 Z1190.0 M09 (GO BACK TO HOME FOR T2)
N0150 M05
N0160 M02


It's a bit of a hack but it'll probably work as long as you can establish a zero point and a home position and keep it. Note also you will need to establish some kind of X home position too because G50 can set both X and Z. If you dont want to set X with the G50 you can use G50 Z...... and omit the X

if you can set one tool ok you dont need to set a G50 for it. you can simply use it then rapid back to an index position, zero the readout and use that position to set your next G50. This is as per Fanuc 6T with G50's. You don't have to go back home for each tool if you dont want to.
but the trick here is at the end of your program you must set a G50 so the first tool knows where it is otherwise it'll be in the wrong place.
I believe if you press RESET the G50 is lost so you may be able to just press reset at the end of each part and you will automatically have your first tool coordinates correct.

Yupower
12-24-2013, 11:06 AM
Hello Fordav 11

Thank you for taking time to help me,i really appreciate that.
The good think about my okuma is that the encoders always know in which position they are,even when i unplug electricity from the machine and move one axis by hand,and when i turn on the machine,it will show you how much you moved that axis.
So i think that home position is not necessary.
Yes,my zero-set does work and i can change my zeropoint.

I will now make a small test program and see what will happend :)

Yupower
12-24-2013, 11:41 AM
It works :D

Here is your program with some changes
N1 G14
N2 G50 X100.000 Z100.000 S32
N3 S32 T11 M3
N4 G0 X20.500 Z3.000 M8
N5 G1 Z-100.000 F300
N6 G0 X100.000 Z100.000 M9 (GO BACK TO HOME FOR T1)
N7 M5
N8 M1
N9 G14
N10 G50 X90.000 Z90.000 S32 (NOTE G50 OFFSET IS 10MM DIFFERENT IN X AND Z FROM PREVIOUS TOOL)
N11 S32 T22 M3
N12 G0 X20.000 Z3.000 M8
N13 G1 Z-100.0
N14 G0 X90.000 Z90.000 M9 (GO BACK TO HOME FOR T2)
N15 M5
N16 M2

I notice that the display changed from X 100.000 to X90.000 when the machine called tool #6 , and also Z changed from 100.000 to 90.000
When the machine finished the program,it went back again to 100.000 :))))))))
Next step is to put a few tools in that machine and see how that will work.

I will come back ass soon i have some new informations.
Regards and thanks

fordav11
12-25-2013, 12:02 AM
to get the size you will need to make a new tape with changed G50's
but if you mount a tool like this you can fine adjust the size using the micro adjuster.....
3 500" 4 562" Vari Set Adjustable Boring Bar Micro Adjust Head Modco NMTB 40 | eBay (http://www.ebay.com/itm/111186294834)
you may need to custom mill a flat so you can bolt it in but it will work great and you dont need to make a new tape.

Yupower
12-25-2013, 04:32 PM
Hello
This is a good idea,but i have something different in my mind.
Because my zero-set is working,i will install 4 boring tools on the front turret and 6 tools on the back turret for external machining.
Tool number 1 and tool number 5 will be for finishing passes and with this tools i always do the zero--set and from these tools i calculate the difference between the other tools.
So i always can correct a few 0.01mm with the zeroset function if the measure of the finished part is not good.
I hope you understamd me.
What you think about that?

Yupower
12-25-2013, 04:59 PM
Hello
This is a good idea,but i have something different in my mind.
Because my zero-set is working,i will install 4 boring tools on the front turret and 6 tools on the back turret for external machining.
Tool number 1 and tool number 5 will be for finishing passes and with this tools i always do the zero--set and from these tools i calculate the difference between the other tools.
So i always can correct a few 0.01mm with the zeroset function if the measure of the finished part is not good.
I hope you understamd me.
What you think about that?

fordav11
12-27-2013, 06:09 AM
yes that would work ok. it would be easier to have a fixed set of tools that are not removed and adjust and fine tune the G50 so all tools cut to size then you can use the same G50s for all jobs.
just remember to always go back to the same position for the tool indexing that your G50 sets initially for the current tool before reading the next tool and G50. then you can use any tool from that point and the G50 will be correct and you wont have to recalculate it. if you don't go back to the same point and you read a G50 for a tool that is being used in a different order the G50 will be wrong and the tool will not move to the correct position, which will present a potential crash situation.
you can put all of the tools in the program with all of the G50s and use them in the same order. if you need to skip over a tool just remove the cutting but leave the G50 and rapid index position there so the following tool has the same G50. basically your index position should always be the same relative distance from your Z0 no matter what and your G50s will be ok as-is.