PDA

View Full Version : Need Help! - Aggravating Router Issue - Y-axis slippage/offset



jch13
05-11-2014, 08:36 AM
Machine-
Torchmate Small Shop Machine
3-axis stepper motor drive
USB Torchmate stepper motor controller
DeWalt 2.xxhp router, 8-24krpm

Software-
Torchmate 3 w/ Flashcut
Windows 7 Pro on Lenovo laptop

Cutting-
Polycarbonate
1/8in two-flute carbide router bit
98IPM
0.020in DOC

Issue-
I'll set up everything to run for an extended period of time with a large amount of cut time (vs rapid moves) and it will go fine for some time, but eventually the Y axis (the axis carrying the largest load) will appear to totally 'spazz out'. I.E. the machine will offset from its normal tool path, go through full-thickness material in a hap-hazard manor, and generally muck everything up. Nothing is repeatable other that it appears to be the Y-axis screwing up. After a screw-up it will continue onto the next cut as if nothing happened, but now with the Y coordinates offset.

Mechanical overload?
Stepper motors slipping?
Stepper motors overheating and slipping?
Any thoughts or suggestions on what to try next?

foam27
05-11-2014, 09:23 AM
Bad connection in white connectors on y axis motors.

Where the wire connects to the pin. It has been seen on yt.

coherent
05-11-2014, 10:52 AM
Sounds like a poor connection issue or interference from in cabling from something (possibly a power cord or?). Swap your X & Y cables at the controller and see if repeats at the X. (make your your design/work table will permit the rotation). Or possibly swap just cable, or stepper etc and see where the issue lies. Hopefully it's not the controller, but also check for overheat etc. If you check everything connection wise and find no problems, swapping stuff around is the quickest way to narrow down the source.

Jonasforssell
05-11-2014, 11:30 AM
I've got a similar issue on my Chinese CNC6040 router. It can run for over an hour without problems and then suddenly it is almost like a command is not executed. The motors are buzzing but there is no movement and the software (Mach3) thinks there is movement which in turn causes an offset when the next command is executed.
In my case it can be on both axis this happens and there is no clear pattern. It can happen anywhere.
Very frustating!
In normal use, the repeatability is excellent and the motors and screws turn easily. This problem occurs also when there is virually no load on the spindle.

coherent
05-11-2014, 12:20 PM
I've got a similar issue on my Chinese CNC6040 router.

Sound like similar issue but who knows.. if it's both axis, I'd lean toward controller problem... power issues or interference. If it always takes an hour or so to happen, could also be an overheating issue. Electronics can do weird stuff when they overheat. Doesn't always mean a part is bad. When parts get hot, something as simple as a poor solder connection can happen due to expansion and cause intermittent connection issues. Troubleshooting is just a process of elimination. Unless you have electronics experience and correct equipment, swapping parts is prob the most simple way. (of course hard to do unless you have another controller or breakout board). Sorry I can't offer more advice, but possibilities are beyond internet troubleshooting. I've seen posts regarding poor soldering (bad connections, shorting with next terminal etc) on some China boards... who knows, maybe a good look with a magnifying glass will show an issue.

Jonasforssell
05-11-2014, 01:22 PM
Thanks for feedback. I'll start with the computer I think. Replace it with another to see first.

jch13
05-11-2014, 06:46 PM
Bad connection in white connectors on y axis motors.

Where the wire connects to the pin. It has been seen on yt.

Went for broke and took apart both connectors. I did not find crimps that I liked. Not overtly bad, persay, but they' didn't look tight to me. I soldered everything together and reassembled, no huge 'biff out' issues since.

It did uncover an offsetting issue with the Y axis. I.e. after every rapid I was losing ~0.012in. I checked the feeds and ramp settings and they were crazy. Fixed those, table runs smoother and faster than before and I get well under 0.001 repeat-ability across the whole range of X and Y axes now. My dial indicator only does 0.001in resolution, sadly.

Have run two complete sets of parts (~16 minute program) with no issues and great part results. I put my hands on the motors after ~30min of running continuously and they were just barely above ambient.

Thanks for the suggestions! This forum never fails to deliver.

jch13
05-12-2014, 09:12 PM
Oops... declared victory too early.

It acted up in a rapid move while I was watching. The Y axis just stopped moving mid-G00 move.

It happened twice tonight all said and done. Immediately after the first occurrence I ran a full-table run and the y-axis repeated within 0.001, so I don't think it's mechanical.

Between the first and second occurrences I increased the USB buffer, changed from 'hi-speed' usb to 'full-speed' usb, changed the controller port for the Y axis, and zip-tied the motor-to-wire connector securely in place.

It biffed out during a rapid move, so I don't think it's a mechanical issue. When it biffed I heard a ****ty sound from the motor, like it was stalling, so I can't be 100% sure it isn't mechanical... but randomly intermittent and mechanical rarely go together.

Any further thoughts or suggestions?

foam27
05-12-2014, 09:19 PM
Make sure Power management is DISABLED for all USBs / LPTs in device manager.

(right click USBs in device manager- go to Power management- Uncheck the box.) - referring to win xp.

Same goes for all sleep functiions.

Disable all that crap everywhere.

jch13
05-13-2014, 02:03 PM
Thanks Foam, will try that.

Torchmate suggested checking that the table is square and to make sure I have the right amount of backlash in my gear sets.

They also do not recommend rapids over 200ipm, I had been using 300. So I'll dial that down too.

jch13
05-13-2014, 09:41 PM
I tried the shotgun approach. Limited rapids to 200ipm and adjusted the gear lash using a sheet of paper per Torchmate's suggestion; and disabled all USB power conservation settings. Ran for ~1hr with no issues, plus a bunch of rapid movements to check repeat-ability et. al. after the run. So far so good.

We'll see how it holds up.

jch13
05-21-2014, 08:57 AM
Well, I *think* I have finally solved the problem. Was running a big job last night, and it jammed up. I checked every electrical connection I could find, and went to restart it, and it jammed again. Exact same spot. A thorough check of the y-axis mechanics revealed a buildup of MDF dust on the bottom of one of the hardened steel plates that the axis rides on.

I don't really know how it got there, but I now have an extra maintenance item to check for. I also loosened the clearance on that pair of bearings to 0.010in from 0.006in. I *assume* that this never showed up on the many full-table rapids because the y-axis had enough inertia to carry through this tight spot.