PDA

View Full Version : Unloading the Mikini



Tinmuk
01-11-2014, 11:43 PM
With the help of some friends and a pallet jack I borrowed from work I have the Mikini unloaded and in fron of the garage. I ran power to it and it jogs and the spindle runs. However the spindle runs in reverse. I think I just need to reverse the wires from the spindle driver board.

I also noticed that sometime the macine does not change direction when the jog controller wheel changes direction. Do I need to release the button for direction changes?

It seems I will need some of the Omron sensors, some of them do not trip when I put a piece of steel nest to them (Z and X
). Where can I get these?

Next step is to clean the chips out and clean the coolant sump.I will also need to fab a new panel for behind the column. I dont know why it is missing... then I will move it into the garage.

BTW, I have not seen the spindle rpm drop yet. I will do some tests and see.

mcphill
01-12-2014, 08:44 PM
It runs in reverse from MACH or from the manual panel? If the manual panel you can swap spindle wires, but I doubt they were ever removed, right? If it is reverse ONLY in MACH, there is a setting in Mach you need to change.

Machine not changing direction is common. First, though, NEVER use the x10 setting. It is really buggy (just the way Phil wanted it - we tried to tell him how bad an idea it was to have it the way he wanted it) and you WILL lose steps if you use it. X1 and X100 are both pretty bullet proof. When you reverse directions, make sure you pause at a stop in between directions. If you go fast clockwise and then immediately reverse to fast counterclockwise, it will still think you are going clockwise. If you pause a fraction of a second before you turn the other direction, you should be good to go.

Limit sensor failure is common. Look for water-tight versions or make your own (there is a long thread on here for making sensors). The Mikini sourced ones fry pretty easy.

SWATH
01-12-2014, 09:26 PM
Mine came with the spindle wires reversed too. I just changed two of the three coming off of the motor driver. As I recall I told Phil about the spindle direction being backwards and he said it was backwards for some reason and that I shouldn't change it but if I insisted on changing it I should use M4 for forward and M3 for reverse...

Mike is right, don't use X10 at all.

Sent from my SCH-I545 using Tapatalk

Tinmuk
01-14-2014, 08:43 PM
I was having trouble replying from home, so I am doing this from work... the spindle is running in reverse both from the manual panel and Mach3. I have slowed down on the reversing with the pendant and now it seems much better. I will try to avoid x10. I am spoiled by my Hass at work!

As for the sensors. I have all of them working except the Z home. The light is on all the time and it wont trigger. I tried swapping with the Z limit and it does the same thing, so i am guessing it is the board. I tried plugging it into the C home and setting the pin, but I guess the C home pin is on port 2, which I don't have hooked up.

Any other recommendations for bypassing the Z home? After I get the Z home issue fixed I wan to add a C-axis. I am thinking about using a Gecko drive instead of the Tonman drives that are in it now.

BTW, I moved the table to center of travel and zeroed it out and ran a test program (a rectangle with Z moves in between) and it ran great.

mcphill
01-14-2014, 11:17 PM
To be honest most of my home and limit switches are not working. I just try to "stay safe"... I do need to get them on again, so I can do a real home, and use Mach's softlimits. That worked for me at one time, but coolant borked at least 3 of my sensors...

Tinmuk
01-15-2014, 02:33 AM
For now I am doing the same thing. I set Z about 10 inches up and set zero there. It will work for now.

Now for the weird stuff. I ran a program for my wifes jewelry tonight and it came out upside down! It shows ok in the toolpath screen...Probably a setting in Mach3?

I also noticed a lot of runout, abput .025 at the tool. So I blued the taper and put in a solid R8 and... nothing. No blue on the collet. so I checked a bit further and found that my import collets apear to be too long and are bottoming out before the taper engages. I could actually rock tje collet in the spindle while pushing it all the way in.

Very weird!

mcphill
01-15-2014, 08:36 AM
Upside down like Z is reversed? That certainly doesn't make sense... Surely the head went down to the material, so it had to keep going down to cut in the Z, right? Can you explain your "upside down" orientation comment so we fully understand the problem?

When you jog in Mach using the Jog flyout, does it go the right direction? If so, I would maybe ensure your CAM is outputting in the right orientation.

SWATH
01-28-2014, 02:08 PM
Anyone have a good source for limit switches of the same form factor that are basically plug and play? I lost two switches this week. They are not soaked in coolant or really even getting hit by it, they just decided to trigger and stay triggered.

mcphill
01-28-2014, 03:56 PM
One of mine "locked on" too, and when I reached a limit in the other direction I was totally stuck - could not move in either direction! Had to remove both then. I think when they dried out they worked again, but I still have them unplugged. When I DO get new switches, I am going to embed them in lacquer/urethane/caulk to ensure there can be no coolant ingress!!!

I was sent an Omron replacement by Phil, so he didn't skimp on the brand, but somehow it wasn't right for the application either.