PDA

View Full Version : Mach3 & DigiSpeed



Wm McNett
02-20-2006, 01:10 PM
Hi guys.
Maybe this is an easy fix.
A wile back I connected Peter's DigiSpeed to my Sieg (Cummins) 7x12 lathe.
I just got Arturo's Bi-directional, Mini Power Supply and Charge Pump boards because I didn't have any more available inputs on my HobbyCNC board.
The more I read, the more I thing I should run Step/Direction vers. PWM.
The Charge Pump is/was giving me fits (the relay is opening and closing really fast) so I disconnected it from the circuit. was set to Port 2 Pin 1

With the Bi-directional board connected to my second port (B800)
Enable for DigiSpeed - port 2 pin 16
PWM for DigiSpeed - port 2 pin 14
Mach3Turn Disable Spindle Relays box unchecked
Clockwise Output #1
CCW Output #1
checked Spindle Motor Output box
checked PWM Control
Enabled Output #1 port 2 pin 14

I am a lot confused as to what to do with the Enable for DigiSpeed
Enabled Enable1 port 2 pin 16

I tried both Active Low and High, all I get is a solid red LED on the DigiSpeed

Maybe it's my 2nd port? It's a SYBA (Model No. SB-PCI9715-2P) 2 parallel ports, I bought off Newegg a year ago. Or that long cable I'm using.

Thanks,
Bill

Wm McNett
02-20-2006, 01:12 PM
OK, laugh with me now.
Wile lying in bed last night thinking, I thought, I wonder ......
I got up this morning and had a look, sure enough I'd forgotten to plug the mini-Din cable into the DigiSpeed.
Now the other (correct) LED is a solid red.
But it still don't work.
I've been using Mach3 Ver. R1.83.044 and making chips with success.
Now I want to try Surface Feet and Threading.

On the Motor Outputs Tab, where should I have the Spindle set using PWM Control?
The DigiSpeed has Enable and PWM not Step and Dir.

Bill

Wm McNett
02-20-2006, 11:58 PM
K, after getting the mini-Din cable plugged in and setting Mach3 Spindle Step to pin 14 port 2 I'm getting a fast flashing red led.
Still no spindle on.
I put the switch in manual, turn the manual switch to forward and the manual pot on. As I turn the manual pot up the spindle starts turning and the led is now flashing green fast as well as the red.
Sounds like / looks like my spindle timing pulse it somehow tied to Step/Dir input mode.
I have Ver. 1a breakout board and I checked the pinouts on the cable/board to the manual. Everything look correct.

Bill

Wm McNett
02-21-2006, 01:04 PM
With some step by step from Peter and some scratching of my head, I got it.
My LPT2 is not the port on my SYBA 2 parallel port card, it's the second port that is attached by the ribbon cable to the card.
Now I just need to figure out why it wont turn the spindle on and why my timing/index circuit don't work the way I thought it would.

Bill

spotlite
07-04-2008, 01:30 PM
I have similiar problem.
Can not measure any impulses coming out of LPT for PWM spindle speed control.
I tested everything, Changed LPT pins, setting, etc. No luck!

Very funny, first day it worked OK. Next morning turn on the system, and this feature is OUT!
I lost 2 days trying to figure it out, but still no idea!

Anyone with similiar problems? And solutions?