PDA

View Full Version : Steppers stalling when backlash comp is on.



radicooldude
02-16-2006, 08:00 PM
If I understand this correctly, to turn on backlash comp, I need to set backlash in the "backlash" menu, then set backlash on. I also set backlash speed to be 20%. Then go to the "state" menu, and turn on backlash. I also need to set exact stop on in the "state" menu. Next, I exit mach2. Load mach 2 back up, and loaded some g-code. When it executes a circle, the stepper when changing direction will buzz very loudly, and not move until it came down to a certain speed, and would pick back up again. I tried changing the backlash speed from everything from 5-100%. Why in the world does it loose steps like that?

Is that the way backlash is set? Is there any reccomendations to prevent the stepper from buzzing and not moving when changing direction?

Also, if I import dfx, and use the wizard, does it automatically add backlash comp into it? If so, I wouldn't need backlash comp turned on in mach2 correct?

Many thanks for some help. - Zachery

ger21
02-16-2006, 08:09 PM
You might want to try Mach3 and see if it works any better. Are you sure your in Exact Stop Mode? Does the top of the screen show G61?

I believe Art has plans in the future to do what you describe. Add in the backlash moves to the g-code. But it's not available yet, and probably won't be for a few months.

Buzz9075
05-09-2007, 12:20 PM
I am using Mach 3 V 2.00.033 with a demo license and I am get the same problem. With back lash turned on the machine stalls and skips steps when the machine makes moves that I would expect would have backlash compensations in them. When I turn of back lash it work very nicely only I don't have back lash compensation values being implement.

This thread has a little more information:
http://www.cnczone.com/forums/showpost.php?p=295354&postcount=246

Does anyone have any suggestions for me?