PDA

View Full Version : toolpath is too faceted.



declanhalpin
03-19-2013, 11:14 AM
Hi all,

I have set my mesh setting according to this site (http://betterlivingthroughcnc.com/2011/10/14/maximizing-toolpath-quality-with-madcam/), and set my tool tolerance to .0001, but I am still getting a faceted toolpath. I am using simple, planar curves (drawn in Rhino as splines) and using 3d Profiling. I can hear and see the mill moving in a very 'jerky' motion, not a smooth, fluid cut. Am I missing some other settings?

tx,

dh

svenakela
03-19-2013, 04:16 PM
How does the path look in Rhino?

turmite
03-19-2013, 11:40 PM
dh if you are using Mach for the controller, are you set to constant velocity? If not, that can, might not in this case, but can cause jerkiness, and in the end, faceting.

Mike

andrewdenhaan
04-10-2013, 06:24 PM
Hi all
I am getting the same problems, where do I set the constant velocity? The controller or madcam?

Could it also be that the tool paths in madcam are straight lines and not curves?

Cheers
Andy

John Coloccia
04-10-2013, 07:40 PM
They ARE straight and they aren't curves. MadCAM only uses G01, but the motion is within your tolerance. Now you have to get your controller to connect the dots smoothly. What controller are you using and what are the settings? That will help others that are familiar with your controller smooth out the motion.

andrewdenhaan
04-11-2013, 07:53 PM
Ok, so I have a Chinese Dsp controller (excitech/tigertec).
Does anyone have much experience with these controlers?
I have changed my acceleration settings on the controller now, lines=500mm per min and curve=500, they were by default at 600.
My speed will be dependant on what I am cutting, say at the moment on Polystyrene I am going a bout 10,000mm per min. I also still get problems when I do run it slower.

svenakela
04-12-2013, 06:27 AM
No Chinese controllers here, but... Do they support G64 commands?
With G64 [tolerance value] you can get tremendously better result in the cutting without sacrificing speed. For example my large steel router is fast and pretty powerful, with exact mode (G61) I have to slow down the machine a lot to avoid vibrations when it comes to a corner or a stop. With G64 set to 0.01 (one hundred of a mm that is) I can cut at full speed with no vibrations at all. Small value, uge difference. You can read more about G64 here LinuxCNC Documentation Wiki: TrajectoryControl (http://wiki.linuxcnc.org/cgi-bin/wiki.pl?TrajectoryControl)

And BTW, you do know that the mesh settings are per file, right?
That means that if you want it continously you have to update your template file.

declanhalpin
04-17-2013, 07:42 PM
Hi all,

Original poster here. I did set the Constant Velocity "on" and seem to have much better curves. HOWEVER now I have another issue, which I believe is unrelated. If I trace a curve using 3-axis profiling (leaving 1mm stock), then re-trace the curve in the opposite direction leaving no stock, the feed rate seems to be set to rapid on the second toolpath. Even if I post process them separately, the second path is very strange. I am attaching the toolpath here.

declanhalpin
04-17-2013, 07:48 PM
... and here is the Rhino file.

John Coloccia
04-17-2013, 07:54 PM
It looks like your post processor is a little funny. For whatever reason, it's spitting out a G00 instead of a G01. In fact, it almost looks like G01 and G00 are reversed. Check your post processor closely, or at least post it here.

declanhalpin
04-17-2013, 09:20 PM
Thanks John! Post attached.

John Coloccia
04-17-2013, 10:30 PM
change:

*FIRST_CUT*
"x""y""z""a" F"feed"

to

*FIRST_CUT*
G01"x""y""z""a" F"feed"

It's never sending the initial G01, so whatever coordinates are there will just apply to whatever came last....the G00 rapid in this case. In this particular case, it will make line 8 of your GCode file read:

G01X-0.317Y-0.747F75

instead of

X-0.317Y-0.747F75