PDA

View Full Version : Newbie Up and running, a few bugs I need help with



p-j
02-07-2013, 10:27 AM
So my 4x8 with Candcnc bladerunner package is up and running. I made some cuts last night and mostly it seems to be working fine. However I have some bugs I need to work out.

I have set up the z axis offset in Sheetcam to 3.556 mm (.140") which is exactly what it is. When I run a g-code form sheet cam my pierces are weird.

lets say I have it set up to a pierce height of .250" and a cut height of 0.07". then cut at a voltage of 134. The Z will touch off, correct for my offset, raise to .250" and pierce with the correct delay, then plunge down into the material for a half second or so until DTHC takes over and raises it to 134v or (which is the correct voltage to cut at .07")

So basically, my switch offset works, my pierce height (.250") and delay is correct, but I have to set my cut height in sheetcam WAY higher (like almost as high as pierce height) to not plunge into the material until DTHC takes over??? I don't get why it would do this, Z has zeroed itself already with the correct toushoff sequence, then plunges way too far until DTHC takes over?



My other issue is jogging. It's something to do with the limits. My table is wired so all the limits on the x and y get joined together, with NO limits tripped in mach or the table I can only slow jog (10ipm) but when I trip a limit, hold it down, and reset mach, I can fast jog (100 ipm) with the limit light on???? WTF? something must be reversed there. I tried reversing the polarity of my X++ and y++. That let me fast jog (limit light on all the time) but when I went to cut, it faulted because of the constant limit setting.

Arrgghhhhh :rolleyes: I would GREATLY appreciate any help or suggestions, I will get a code snippet from my pierce sequence next time I get out in the shop (likely saturday)

Thanks guys.

p-j
02-28-2013, 10:32 AM
I figured out the jogging problem and have it jogging (it was just a setting in the mach menu)

But, I still have the damn thing plunging after pierces randomly. With the torch turned off it works perfectly, with it on it plunges. With DTHC tuned off, it still does the plunge into the material.

There is nothing in the g-code telling it to do this, I references the plate height, zeroes with the switch offset, raises to the correct pierce height, pierces, then plunges into the material (yes my cut height is set to .06+) and drags the damn tip until DTHC takes over and raises it to the correct height?

I've seen lots of people post this problem on many forums and none have a answer?

Also My plasma shuts of mid cut then re fires, leaving un-cut portions? same deal, other people have this problem lately too, but no solution.

I'm ready to junk this whole table, 10K in the hole is better then dealing with this, my hand torch is going to get more use than the CNC torch in the next week cutting this whole thing into 1"x1" bits.... :tired: :D