PDA

View Full Version : Why is my Z axis stalling all the time?



SWATH
08-24-2012, 01:21 PM
I haven't done much of anything with this stupid machine but today I had enough energy to try and engrave some wood for a friend. So far the Z axis has ruined the first 2 nice pieces of wood because the Z axis just randomly stalls and loses position, usually driving the cutter way too deep. When jogging the Z up and down it is fine and smooth 90% of the time then suddenly it doesn't move even though the motor is whining, like it's stuck. It happens going up and going down and seems to be random. I played with the acceleration setting ranging from 50 to 10 and it doesn't seem to matter. What can I do to troubleshoot this problem and fix it. I am so beyond sick of this worthless machine.:mad::mad::mad:

B-RAD
08-24-2012, 01:27 PM
Change the two right settings higher in motor tuning, forget the name of them. Mine are 5. Acceleration to 5 for now also

SWATH
08-24-2012, 01:31 PM
Thanks B-Rad.

Do you mean "Step Pulse" and "Dir Pulse"? Mine are currently 2 for both settings.

B-RAD
08-24-2012, 02:41 PM
Yes, its the length of the pulse.

SWATH
08-24-2012, 10:36 PM
Interestingly, I changed the two settings from 2 to 5 and then did an air cut. The Z didn't stall at all but I think it's too soon to tell because it doesn't happen that frequently. I'll try more cutting tomorrow to see.

So now my question is, what do those settings control and why would it affect the Z axis stalling?

B-RAD
08-25-2012, 11:05 AM
Length of pulse, depending on your setup it will help. I'm using sherline mode so my pulses are really really long, but I still use 5 in those settings, I think that actually puts me at 25... Lol

donwhit123
04-06-2013, 07:37 PM
If the Z axis stepper motor is still whining than It is still turning but your ball screw is not. The coupler from the motor shaft to the screw is probably loose and you need to check the keeper nut at the bottom of the ball screw also.

- - - Updated - - -

If the Z axis stepper motor is still whining than It is still turning but your ball screw is not. The coupler from the motor shaft to the screw is probably loose and you need to check the keeper nut at the bottom of the ball screw also.

SWATH
05-30-2013, 10:12 AM
I tried using the machine again last night to cut some text into wood again. It would go along fine but then randomly and out of nowhere the Z would make a funny stall sound on a retract then the next thing I know the cutter is plunged way too far into the wood when it comes back down. It is trying to move and the computer thinks it has moved when it actually hasn't, throwing my Z position way off. I've ruined another 2 good pieces of wood after a long engraving routine.

So I would pause the program and try jogging the Z up and down and it would still stall in both directions, then it wouldn't move at all. Mach still showed it moving but the the LEDs on the back of the Z axis driver quit flickering when I try to move it. The X and Y axes work fine. If I switch to manual mode the Z would work again and sound fine with no stalling, then if I switch back to Mach it would also work again for a while until the same thing would happen.

What is the problem here? I don't think it's the motor since it works in manual just fine. I don't know if it is the driver since, again the manual mode seems to work ok. It's almost as if the driver is getting mixed signals then no signal. I'm just trying to identify where in the stream the problem is originating from and it seems to me it is up stream from the at least the motor and maybe the driver.

This is so frustrating, the one time in forever someone is counting on me to make something for them in a soft material that the spindle motor can handle it still craps out. I can't even make one part without ruining it.

Should I just scrap the whole system and get all new electronics at this point?

edit: Ok I don't know if I can exactly afford to replace the whole system right now, but If I can do something to fix the Z stalling issue for now that would be ideal in this situation. Would a new Keling driver even be a plug and play part or would that necessitate other devices to be replaced like the breakout board too?

Also does anyone with the integrated Mikini computer know if the ethernet jack still works after you pick out the black silicone caulk they put in there? I'm think if I go ape and redo the whole freaking machine I may want to add an ethernet smooth stepper.

slowtwitch
05-30-2013, 05:06 PM
Swath, I feel for you. I wonder if the Z thing is a noise or software issue... For the noise thing...try this....After you home the machine, load a job that isn't to big to hit the limits switches. Then disconnect your limit switches from the rear board. If the job still has a problem, move on to your home switches. The home and limit proximity switches are only 5 volt. This low voltage makes them kinda noisy. I originally thought they were 12 volt, but, mine were not.

If it's software related, you may have a corrupt xml file or Mach has to be reloaded. (I already suffered a corrupt tool library, so I threw the software thing in there :)

SWATH
06-04-2013, 12:28 PM
Pete,
I'll try changing the stepper motor drivers tonight and cut air to see what happens. In the meantime I have pretty well decided to get a smooth stepper. I hear good things about the ethernet version over the USB version so I am thinking about this one from Warp9 (http://www.warp9td.com/).

Also If I wanted to get a more powerful stepper for the Z axis what is the best one I should get? It has a NEMA34 850oz/in currently and a 72v power supply. I don't know if the Mikini driver is digital but I would be willing to replace the driver with a better one if needs be but I don't want to if I don't need to right now.

slowtwitch
06-04-2013, 02:17 PM
The ethernet smoothstepper is really nice. I've been using it for some time. You can't go wrong with buying it from either warp or cnc4pc. Although the warp guys are the ones who designed the smoothstepper. As for the stepper, the 850 should be no problem. I would hold off changing it until you have tried switching the drivers.

Another thing you may want to look at is how many lines of code Mach reads ahead. I believe the default is 20 lines of code..maybe bump it up to 100 lines.

SWATH
06-04-2013, 02:28 PM
Thanks Pete,
I wasn't going to change the motor yet but I need to preload these things in my head in case I need to replace it quickly. I wondered about the look ahead but hadn't changed anything with it. It is set to 20, what impact will it have if I bump it up to 100? Why not do 200 or 1000 or 10,000? What is the trade off, more CPU load? If that is the case wouldn't a smooth stepper help that as well. I think the smooth stepper will help at least with piece of mind as I need to run long programs and walk away from the machine without thinking I'm going to come back to a broken endmill, a gouged vice or table, and a smoking spindle. Right now I don't feel comfortable taking my hand off the e-stop.

mcphill
06-04-2013, 02:35 PM
I am curious about the effects of the lookahead setting as well... Anyone have some real world experience/impacts?

mcphill
06-04-2013, 02:44 PM
"-General Configuration (LookaHead____ Lines)
Only applicable in CV mode. This determines how far “down the road” Mach-3's motion
planner is looking. Setting this to a low number is like driving your car while being very
nearsighted. A high setting is like 20/20 vision and using binoculars when necessary to
see far down the road. This allows the software to better able to adapt to sudden changes
in the motion path. It is recommended to keep this at around 200 for most cases. The
maximum value is 1000, and setting this high may cause problems depending on the
speed of your computer."

And:

"LookAhead determines the number of lines of GCode that the interpreter can buffer for execution. It
does not normally require tuning."

I found a post from 2008 that says the max you can set it is 1000...

SWATH
06-04-2013, 03:09 PM
I'll try bumping up the look ahead after I swap drives and cut air. I don't want to induce too many confounding fixes at one time.

Another development I forgot to mention was while cutting wood last night the spindle motor and light tower would blink off for a split second then back on every so often. It did not hurt anything since it was wood but had it been steel, I would have lost and endmill and got a spindle halt. It literally turned off for about half a second. Does not make me feel confident. I also noticed that during this time even though the program specified S3300 (my spindle max), it actually read 5250 both in Mach and on the Mikini LCD but the actual RPM was 3300. The motor sounded different. In Mach the increment scaling changed from 100 to 250 so once I changed it back it worked. I don't know what's going on here but it's dodgy.

SWATH
06-04-2013, 11:47 PM
I switched the Z and Y motor drivers and ran a particularly jittery program with lots of rapid Z retracts for 45min. When it returned it was within .001 of where it started. I don't know if that tells me anything yet. I need to run it again and maybe a few times before I get a stall. I also ran it with the spindle off, so maybe I'll try it with the spindle on as well. I'm also a little bummed that there doesn't seem to be an aux 5v supply of of the board for the smooth stepper, maybe I'm wrong about that though, no big deal. I assume the 5v PW going to the display is for the backlighting of the LCD.

The Mikini breakout board is weird as it seems to be broken into two parts, one in the chassis and the other behind the display. What I also don't get is that the parallel port is a 25 pin db25 but the header going into the front panel is 20 pins. How is anyone to know the pin outs for this, do I really need to get a continuity tester out and track down what each pin is? Also is such a cable even made (26 pin to 20 pin)?

How have you had yours hooked up Pete? I'm just trying to figure out how to wire it so I know what cables to get and where everything would go.

mcphill
06-05-2013, 08:36 AM
With my USB version, I just unplugged the parallel cable from the computer and plugged it in to the SS. Then plugged USB from the computer to the SS. You should not need to mess with anything on the Mikini. I would think/hope the ethernet version is the same way (exchange USB with ethernet cable)! The "other" end of the parallel cable takes care of where each pin goes on the Mikini side.

Also, you may be able to source 5V from a USB cable, or at worst from the power supply in your computer (tap in using a Molex connector) - you won't need to get a power supply for 5V. Very worst case you can use a 7805 chip to regulate down to 5V from any 12V source you have available.

SWATH
06-05-2013, 09:24 AM
I kind of figured it out. I can just reuse the parallel cable from the PC and connect it to the ESS as you said but I need to get a LPH26-to-DB25 ribbon cable to make the connection since the ESS does not have a DB25 connector on it. The 5v power supply I'm still a little confused about (should be 5v 1A supply) but I'll figure it out. Can I just wire in to the 5v going to the front LCD and have both devices powered from the same supply?

slowtwitch
06-05-2013, 09:55 AM
Swath, I'll put the cable ( lph26 to db25) I had in the box. As for the 5 volt dc, check the breakout board in the back of the machine..the one with the relays....I believe it's on the top left side of the board...you would probably have to splice it in. There's also another voltage output on the top right hand side of the same board. But, I don't know the voltage. I'll check it tonight when i get home from work.

mcphill
06-05-2013, 11:07 AM
It is in the PDF SWQTH posted for me here: http://www.cnczone.com/forums/mikinimech/182536-fried_coolant_pump_dont_ask-post1286420.html#poststop . On the Mikini CNC Interface Board, J2 is 5VDC OUT (this is the wire that runs to the LCD that was mentioned) - should be very easy to tap in to that.

I think the LPH to DB is normally included with the SS? They are available "for cheap" from Warp9: http://www.warp9td.com/index.php/order

SWATH
06-05-2013, 11:16 AM
It has 3 LPH26 male pin headers but no DB25 port for a standard parallel cable.

187038

mcphill
06-05-2013, 11:37 AM
Right, you can get the LPH26 to Parallel at Warp9 for $3-5 depending on which you want...

Order (http://www.warp9td.com/index.php/order)

SWATH
06-05-2013, 07:59 PM
Alright I switched the Z and Y axis drivers and ran the program again today. This time I heard a bunch of abrupt jolts, sort of like how it sounds when using the MPG set to 10x. I stopped the program prematurely because the Y axis went outside of the travel and hit hard stops. I repositioned to X0Y0Z0 to see which axis was off. The X axis was off 0.0011 and the Z was off 0.0001 but the Y was off almost 2.5 inches. It was the Y axis (using the Z axis driver) that was stalling.

What does this tell me? I think the Z driver is bad or perhaps something upstream from that. What can I test next?

mcphill
06-05-2013, 08:48 PM
I would say it is the Z axis driver. Would be a good time to swap it out for a digital driver, I don't think the Mikini would know/care if you didn't use a Mikini driver. All it does is process the steps. You will need to experiment to find out what microstepping Phil is using - he would not tell me what it was or how to change it on the Mikini driver (so he wouldn't be "liable" - ya right). I bought a new digital driver for my 5th axis from Automation Technologies: Stepper Motor Driver Automation Technology Inc (http://www.automationtechnologiesinc.com/products-page/digital-stepper-motor-driver/digital-stepper-driver-kl-8056d-heat-sink-is-included)

You can use the one step cheaper driver, as we only have 48 volts, for some reason when I was buying I thought we had 66 VDC. So you can save $30 by getting this one: http://www.automationtechnologiesinc.com/products-page/digital-stepper-motor-driver/digital-stepper-driver-kl-5056d-heat-sink-is-included

It is a driver from Keling. I haven't tried it out yet, so can't give feedback, but I liked what I read about it... These are digital drivers (like the new ones on the Tormach) and are supposed to be MUCH smoother than the older ones like on the Mikini. You could spend a good bit less for a cheaper non-digital driver.

mcphill
06-05-2013, 08:51 PM
BTW, how did you swap drivers? Did you physically move the driver keeping all Y and Z wiring where it was? If so, it is definitely the driver.

If you "just" swapped the motor output wires between drivers (but kept all the other wiring intact), there could be a chance that the wiring TO the driver could be defective... Could be a bad wire connection in a fitting, or wire running by a noisy part in the machine. If that is what you did, I suggest you physically swap the drivers from one position to the other. If the problem stays on the Y axis, definitely the driver. If when using the Z axis wiring on the Y axis driver you still have issues on the Z, then it is not the driver, but something upstream feeding the driver.

SWATH
06-05-2013, 10:18 PM
The drivers are bolted right next to each other in the cabinet, all I did was swap the output wires between the Z and Y drivers on the front panel and the driver outputs to the motors between the Z and Y so all Z output was going to the Y driver controlling the Z motor and all Y output was going to the Z driver controlling the Y motor. I also swapped the X and Z including the cables.

Something like this:

Before the swap

output.....driver......motor
X-----------X---------X PASS

Y-----------Y---------Y PASS

Z-----------Z---------Z FAIL Off about 0.2


After the swap

output.....driver......motor
X-----------X---------X PASS

Y-----------Z---------Y FAIL Off about 2.5

Z-----------Y---------Z PASS


output....driver......motor
X-----------Z---------X FAIL Off about .14

Y-----------Y----------Y PASS

Z-----------X---------Z PASS

So following the logic flow, the data point that is common to the FAIL condition and no PASS conditions is the Z driver.

My stepper power supply is exactly 72v. It seems they resized it. I'll try Pete's driver if it is high enough voltage but if not I'm looking at another driver. Any advantage to Gecko over Keling? Is there anything special that needs to be done with a digital drive?

mcphill
06-05-2013, 11:12 PM
Guess I better measure my voltage! The PDF of the schematic you posted states 48V. What'daya know, a mistake (?) on Mikini's documentation... Can't believe it! Glad I got the "oversize" driver now, that's for sure.

Following your technique as posted above, seems it certainly points to the driver. I do seen now a connection in the schematic between the driver and the LCD panel driver... Not sure how that is done or what would happen if you don't use a Mikini part... An unlabeled "pin" on the Mikini driver goes to a pin on the LCD board that corresponds to "N" axis. This may be needed for manual control? Or maybe an enable bit for when in Manual mode? Not sure but you would need to look in to that to ensure a non-Mikini part would work. I may have a chance to mess with my new driver tomorrow - I could try it out on an existing axis on my machine and I could give some initial feedback but I can't guarantee I can get to it...

slowtwitch
06-06-2013, 07:41 AM
When i was thinking of changing the mikini drives with digital ones, i to was kinda of confused with mikini's pinout. I did some searching and asked a couple questions. Lucas in Belgium helped out :)

This is the driver in question....
http://i46.photobucket.com/albums/f109/slowtwitch/tonmandriver_zps0a18fbca.jpg (http://s46.photobucket.com/user/slowtwitch/media/tonmandriver_zps0a18fbca.jpg.html)

Here is Lucas's response.....

"
Found this crappy translation but it helps.

57/86 stepper motor driver high subdivision 4.3A voltage: 60VDC-$48.33 (http://www.imendit.com/item/57-86-stepper-motor-driver-high-subdivision-4-3a-voltage-60vdc-12853688035.html)


Drive has 3 opto signal inputs, it can be either step/dir or CW/CCW control, Free is the enable signal.
There are also 2 outputs for drive faults.

Pulled and edited the relevant text:

CW- CW+ Pulse signal input: Drive response to the rising edge of the pulse signal (internal optocoupler current to flow through) signal is high, the range of 4-5V, low 0-0.5V. For reliable response to the pulse signal, the pulse width should be greater than 2.5ms.

DR/CC- DR / CC+ Direction of the signal / reverse pulse input: Single pulse signal for the direction, in order to ensure motor reliable commutation, the direction of the signal should be the pulse signal is at least 5ms establish.

FREE- FREE+ (6 feet) Off-line signal input: When this signal is active, the drive to force cut off the motor current, the motor is in a free active when this signal is in an invalid state, the normal current of the driver output, the motor is locked.

TIM Pole E-pole Motor relative to the origin of the signal output: This signal output and TIM light synchronization, in some specific occasions for.

O. H Pole E-pole Protection action signal output: This output signal is synchronized with the O.H indicator. Use this signal when the drive protected action can notify the host computer drive is faulty. "

I haven't tried switching over ...since I'm going with all new electronics. But, it seems that the only pins needed are the 2 dr/cc(Dir) and 2 CW(Pulse)pins. I would assume either the top two pins are positive and the bottom two pins being negative.. or their reversed.

mcphill
06-06-2013, 08:22 AM
Thanks! You link didn't work for me but I found this:

PD2064M-??????? (http://tonman.com/html/bjdjqdq_91_39.html) (Google can pseudo-translate to English for you)

slowtwitch
06-06-2013, 08:28 AM
The link has been repaired :)

SWATH
06-06-2013, 10:30 AM
Something else I might mention is that my stepper motors are always blazing hot, I mean you could fry an egg on them. Is that normal?

SWATH
06-06-2013, 03:51 PM
Has anyone thought about hybrid closed loop steppers like this one:
High-Torque Stepper Motor, Stepper Motor, Driver, Stepper Motor kit, DC Servo Motor, DC Servo Motor kit, Stepper Motor Power Supply, CNC Router, Spindle, and other Components. Automation Technology Inc (http://www.automationtechnologiesinc.com/products-page/hybrid-servo-system/nema-34-hybrid-servo-motor-kl34-8n-1000-rated-torque-1128-oz-in)

And one from Leadshine:
Hybrid Servo Drives - Leadshine Technology Co., Ltd. (http://www.leadshine.com/ProductList.aspx?Type=37) (they call them hybrid servos)

mcphill
06-06-2013, 04:01 PM
It is normal for steppers to be very hot. The use the most power when stationary, so I power down when I know it will not be in use for a long while. The driver I bought has a setting to drop current by 1/2 when stationary. I think that is to help drop the temps a bit.

mcphill
06-06-2013, 04:03 PM
That could be an interesting option for a rotary table...

SWATH
06-07-2013, 10:25 PM
So out of curiosity I swapped X and Z drivers and motors but this time I switched the input wire to the drivers instead of the side coming out of the front panel. I ran the 45min program twice and the X did not jump or lose position, nor did the Z. The Y did however even though I didn't even touch it. I didn't really hear it but the Y was off about .005 both runs. Though not catastrophic, still unacceptable. I should get the ESS tomorrow so hopefully I can hook it up without it being a comedy of errors (as is the Mikini theme).

On that note, I picked the silicone out of the ethernet jack on the Mikini computer and it came out fine, but there is a problem. When I plug an ethernet cable into the jack the LED doesn't light up. So I went into the BIOS and the onboard LAN is disabled and it is greyed out so I can't change it to enabled. What do I do now? Flash the BIOS with something else?

SWATH
06-08-2013, 02:16 AM
When poking around in the BIOS I found a message that says "Intel Integrated Toolkit has modified this BIOS". So It seems that Mikini in addition to filling the RJ45 connector with silicone they have also used the ITK to disable the LAN and lock it so it cannot be changed. I went ahead and flashed the BIOS with the latest version (1/15/13) but the LAN is still locked and it still says "Intel Integrated Toolkit has modified this BIOS." What a Mikini clusterfluck. The BIOS from Intel has the LAN unlocked and enabled so I don't know why the BIOS flash is not working. Any suggestions?

SWATH
06-08-2013, 02:17 AM
When poking around in the BIOS I found a message that says "Intel Integrated Toolkit has modified this BIOS". So It seems that Mikini in addition to filling the RJ45 connector with silicone they have also used the ITK to disable the LAN and lock it so it cannot be changed. I went ahead and flashed the BIOS with the latest version (1/15/13) but the LAN is still locked and it still says "Intel Integrated Toolkit has modified this BIOS." What a Mikini clusterfluck. The BIOS from Intel has the LAN unlocked and enabled so I don't know why the BIOS flash is not working. Any suggestions?

SWATH
06-09-2013, 01:31 AM
Well that was another lesson in WTF were they thinking. I spent all last night and most of today trying to unpimp ze auto so to speak to enable the onbord LAN so I could use the ethernet smoothstepper. I pulled out all sorts of mental gymnastics to figure it out but I did. I've unhacked the Mikini modified BIOS and the LAN is now enabled. I installed the smoothstepper and it works on the axis drives great but the spindle is still a little quirky and needs to be sorted out. It took me awhile playing with the PWM settings to get it to turn and now it does but it's backwards and its speed is not quite right so I might rewire the phases going to the motor or if there is a Mach feature that reverses M3 and M4.

I ran the test program twice and all axes were within .0004 at the end. Which is great (I wonder if it could be improved though). I wonder if the ESS will improve the overall precision of the machine. The homing works fine, but I don't think those home switches are accurate beyond about .001 or so. Does anyone have that little macro that pings them twice (the second time very slowly) and is supposed to get within something like 0.0002 repeatability? Thought I saw it on the Tormach forum somewhere.

The only other issue was during a test program when I started rotating the toolpath display and it hard stopped all the motors and gave a "ran out of data" error or something and said the PC was not able to keep up with the ESS demand. What should I set the Mach Kernel too with the ESS? It's on 45khz right now. Anyone have any idea of settings to optimize the ESS with the Mikini? Especially as it pertains to the spindle.

Also Pete, the drivers you have are the same as mine which begs the question...If yours are rated for 60VDC and mine are rated for 60VDC why do I have a 72VDC power supply?

slowtwitch
06-09-2013, 07:20 AM
Swath, the drivers will work with your supply...but I think the amps may be capped out at about 4.5 or 4.6 amps. The Mach issue your having may be the kernel speed, but instead of increasing it, lower it to 3500Hz.

My ESS settings with the Mikini spindle were... all my axis were set at 256Khz,.. my spindle ... 32Khz. PWM base Hz is set at 1000. Under ports and pins, my spindle was set at 1000 steps per...Velocity..60...Accleration..5000....G's..12.95...Step pulse..2..Dir pulse..2

Also double check your Spindle pulleys setup... The Mikini was set at 210 (low speed) 5259 (high speed). To reverse the rotation of the spindle you can switch any two wires of the three going into the motor....I think you can also do it in Mach..under ports and pins...motor outputs..spindle ...check the Dir low active.

SWATH
06-09-2013, 10:16 PM
Thanks Pete,
I got the spindle direction sorted out by unchecking the Dir Low active like you said. There are 2 problems now. One is that the commanded speed does not match the actual speed. I can put S1000, Mach says S1000, but the Mikini front panel says 824 or something and then that's the speed it goes to. Sometimes the front panel speed flashes between 2 numbers, like if I command S1000, then the front panel will flash between 824 and 786 like it doesn't quite know what the speed should be. In fact it is not accurate at any speed, it is always much lower than commanded. However when in manual mode the actual speed always matches the commanded speed. I don't know if this is a problem in Mach, the smoothstepper, or more Mikini voodoo. The other problem is that the minimum spindle speed is 500RPM. Not that the motor is even usable at that speed but anything below that either doesn't turn the spindle or gives a PWM signal too low error. The spindle still can only achieve a max speed of around 3300RPM. These are tentative issues as I will completely replace the spindle at some point but I need it to work as best as it can until then.

slowtwitch
06-12-2013, 06:40 PM
I found this some time ago and completely forgot about it. Look who else uses the secret Mikini stepper driver..

mcphill
06-12-2013, 08:31 PM
Awesome find! That manual should help.

SWATH
08-15-2013, 01:16 PM
I started another small batch of wood parts to cut and was hoping the Z axis issues have been resolved in light of adding a smooth stepper. No such luck. While the smooth stepper definitely makes things smoother, the Z was still glichy. Luckily I sort of expected it so I sat with my hand on the e-stop so I didn't ruin any parts. I yanked out the Z driver and put in the X driver I got from Slowtwitch. I used the X because he said he was having issues with his Z losing steps. I ran the machine for awhile and no more hiccups! It was definitely a bad driver. I actually felt comfortable leaving the machine for a few minutes and not having the worry I would come back to a smoking ER collet chuck and a disfigured vice.

Thanks again Pete, you saved the day!

I'm going to use these drivers for as long as I can then upgrade to something much better like the Kelings digital drives or those closed loop hybrid servo/stepper drive/motor combos I linked to. I'll Probably just go with the Z first though because of cost.

mcphill
08-15-2013, 01:32 PM
Good deal! I have not had the chance to play with my new driver yet...