PDA

View Full Version : Problem Rotary error when rotating around z axis.



Blackknight
05-21-2012, 09:27 AM
Hi guys,

I was ploting a program in wich my indexing head is rotating about the z axis. The program plotted alright. However the direction of the index was backwards. All my indexing heads are setup to rotate clockwise to the positive direction. I do know there is an option to reverse the direction. But it just get easy to forget specially when it rotates to the right direction when setup to rotate about the x axis. Can someone corroborate this ? As far as I understand I should not matter in wich axis the program is setup to rotate It should always rotate to the same direction. Am I right?

Thanks guys !

fordav11
05-22-2012, 05:15 AM
on a mill rotational axes are always optional and the machine tool builder has the power to do whatever it pleases. there's no standard for extra axes.
on a machine the direction of a positive rotation is set by parameters. its possible your machine is not set up correctly. or ncplot is wrong.
first you have to determine if a positive rotation is clockwise or anti-clockwise. then change the machine or ncplot to match.

Blackknight
05-22-2012, 08:35 AM
Hi fordav11,

When I said that our rotating heads are set up to rotate clockwise to the positive direction, I meant by parameters. I am aware the direction of rotation can be changed.
However, this post is not about how the machine is setup but rather about how ncplot plots the toolpaths. In that sense it should not matter how you setup the rotating head in ncplot settings ie. x axis, y axis or z axis, The direction of rotation should always be the same. I hope now people can understand better what my problem is. It seems I was not clear with my post the first time around.

Thank a lot for your response.

ArchieF
05-22-2012, 06:38 PM
Hi Blacknight

in the menu SETUP -> Machine Configuration -> Rotary 4th Axis -> 4th Axis Setup you can check ( or uncheck) Reverse Rotary Axis Direction.

Give this a try

Richard