PDA

View Full Version : First tool not listed and G28 U0 W0 not correct



fordav11
04-05-2012, 04:49 AM
two other possible bugs? see pic attached.

this is a very simple warm-up program.

problem 1 is the first tool is not listed in the tool list on the left?
the program was typed in by hand and plotted a few times. only 1 tool showed.
however after saving and re-loading the program it showed both tools so the
problem seems intermittent?

problem 2 is G28 U0 W0 is moving the tool in rapid to X0 Z0.
It should move in the opposite direction and go home directly.
To make this work you may need to set where 'home' is.
That could be added to the machine configuration as.....
Maximum Travel X = 300.0
Maximum Travel Z = 1000.0

then on reading a G28 U0 W0 it rapids to home at X300.0 Z1000.0. Or something :)

MetLHead
04-11-2012, 12:41 PM
I tried it here and confirmed that the first tool is not showing up in the tool list, don't know what's going there yet.

To have motion back to home position show up correctly you should set the work offsets in the machine configuration. Go to "Setup / Machine Configuration" then click the "Work Offsets" page. Set X and Z values for the G54 (or whatever offsets you use). You can then use the menu "Draw / Axis Lines" to set where the zero lines are displayed.

Thanks,
Scott

fordav11
04-13-2012, 05:22 AM
hmmm. it kind of works *visually* but it's not the correct way as far as a real machine would do it.

On a lathe the G54 X is always 0. Each tool has a geometry offset that sets the diameter. There is no need for an additional work offset to shift *ALL* of the tools an extra amount (i.e. basically a turret shift). S0 G54 X should always be 0 which does not fix the problem.

See the pics.


1st pic is with my real G54 workshift from the machine (X0 Z355.720)
NCPlot thinks the machine zero is on the left of the part (not correct)

2nd pic is with G54 X0 Z-355.720
Now NCPlot puts the Z on the right side of the part (correct) but U0 still goes to X0
However the G54 Z on the machine is really a positive number.

3rd pic is with faked G54 X-250.0 Z-355.720
Now NCPlot rapids the tool to the fake machine home but still displays 'X0 Z0'
It *looks* ok and is usable like that but it isn't right.
At least now the tool is not rapiding to the work X0 Z0 so OK I suppose that problem is solved ;)