PDA

View Full Version : need help with limit switch



rebrumm
11-11-2005, 06:14 PM
hi all
I set up a test limit switch on my mill X on pin 11 and configured it the software. after resetting the ports i hit F8 and jog< to my surprise the mill took off at full speed. i hit<esc> and stopped it. then i tried a jog> and it took off again so i pressed the limit switch but no cigar so i aborted again. i manually centered the table and set both the mill and software DRO,s to zero and tried again this time i let it go and it stopped on it,s own with the mill DRO at 3.981 and software DRP at .00106. i went back and forth a few times with exactly the same results.
can anyone tell me what i'm doing wrong?

russ
clairton PA

Bubba
11-11-2005, 07:16 PM
Rebrumm,
First off, was the system working properly before you set up the limit switch or is this a total new installation?
Second, were you in continious or discrete jog? I discrete, what increment did you have it set to move and is Normal or Rapid highlighted?
If in continious, assumming you pressed only the '->' or '<-" key what is your slog jog set to? For example mine is set to slog jog at 1IPM and fast about 28IPM
Also, did you have Limits turned on or off?

Just some thoughts to get this figured out!

rebrumm
11-11-2005, 08:42 PM
yes both X and Y worked before i started messing with the limit switch. Y still works normal. the limit is for X. I pulled the motors off last nite to get the brackets anodized but the are still wired to my driver. it doesn't much matter whether i am in normal or rapid, discrete or continous it still does the same thing. one thing i did notice is if i -> and let it stop and -> again it will jog normal. if i <- then it takes off again and stops always 3.981" then it will jog <- normal. the limits were on

the limit is a roller type i got at the local RS to try to get it to work. the switch is not mounted to the machine .just a couple of wires running from my enclousure to the switch. the switch is powered from the 5v rail of an old AT PS i also have my EAS driver connected to the same PS 12v rail for the logic supply. it has its own 7805.

i read your write up on the microwave xformers and built one for this project. it works great and runs quiet and about 100F. i found a very easy way to get the old copper off and had it ready to wind in 10 minutes. filtered and under load i get 43.6V witch works out well for the LMD18245 chips on the driver.

Bubba
11-11-2005, 09:12 PM
Youv'e got me going now, will have to sleep on this one. [Do my best thinking when I suddenly wake up at 2:AM and have a flash of an idea.

Will try to think of something by in the morning!