PDA

View Full Version : Getting started with Madcam/post to .nc?



fieldse
12-09-2011, 03:34 PM
Hi community,
Just trying to get started with Madcam, posting to .nc file to use in WinCNC. I created toolpaths for a test file and exported to .nc, but upon import into WinCNC I don't see anything.

For what it's worth, I'm using Rhino 4 with MadCam plugin v2.1, exporting to WinCNC.

Any suggestions to troubleshoot / getting started?
Thanks!

williamsmotower
12-09-2011, 04:28 PM
After posting, click folder icon

fieldse
12-09-2011, 10:31 PM
Thanks williamsmotower, I did already do that and it exported to g-code without any (apparent) issues, but the problem is that the .NC file does not import into WinCNC.

The madCAM postprocessor I used is "Iso_G_Code.txt". I do not know whether this is correct, or if I have to use a different post processor for the WinCNC mill.

Error message in WinCNC upon attempting to open the exported .nc file is "Command or File not found". IE, it won't open it.

Anyone else had any trouble importing files into their mill program? Can you give me any guidance or suggestions?

williamsmotower
12-09-2011, 11:41 PM
isn't wincnc a proprietary program, that uses it's own control box and software?

Dan B
12-10-2011, 05:36 AM
Post an example of the code which includes the header (safety lines, comments etc.), a sample of the body of the code, and the end. It should be fairly simple to make a post that will work. Our Trak LPM has a proprietary controller, but we are driving it with madCAM every day.

Dan