PDA

View Full Version : Need Help! Ever heard of inputs going bad on a C11



mrcodewiz
09-15-2011, 07:56 AM
I have a c11 that for some reason, the inputs have stopped working. I moved my machine this weekend so it seems strangely coincidental but I didn't change anything about the controller box. Everything else seems to be working - the charge pump, the outputs to the motors, etc.

I only had the e-stop and limit switches (wired together) hooked up to the inputs. At first, I noticed the e-stop wasn't triggering mach3 when it was pushed. I tried moving the limits off to another pin and mach3 wouldn't recognize them on any other pin. When I say activate - I am just talking about the input pin lights on the mach 3 diagnostics screen and not setting them up in ports and pins. The board also has LEDs by each input that are supposed to turn on/off depending on state.

I tried all other pins and none were working except the original (#11). Now, not even that one works. When the board fires up with nothing wired to the inputs, all of the LEDs are lit except the last one. Now if I have the limits wired up to #11 when i power the board up and the switch is closed, all LEDs will be lit up but opening the switch doesn't change any lights (on mach or on the board). If I start it up with limit switch on #11 and open, the #10 LED is not lit and if I close the switch the #10 LED will light but then it will remain that way regardless of the state of the switch. I get no visible behavior at all from any other pins. Also, all 5V pins on the input side appear to have 5V.