PDA

View Full Version : Help! It doen't work anymore?



boxwood
08-03-2003, 10:52 PM
Hi

I have a homemade router, uses the 4 axis Hobby CNC board
Desknc controller program. It has worked fine for the last few weeks since finishin it.
Ok here is what happened I started to run a program and it moved to position and paused wait 5 seconds went next position
and paused again etc etc , So I stopped it and decided the pc needed to be rebooted since I usually leave it on BTW desknc is DOS. so powered down and restarted windows98se but error came up said command.com was corrupted, checked dir from c: and the whole hard drive was scrambled weird characters etc
so I tried to format and start over but it said the drive was not useable so I had another smaller HD laying around so I put it in formated and installed windows98se then desknc and set desknc just the way it was before, but now when I try to jog x the z moves and when I move jog y the c axis moves rechecked the pin outs and they are set properly. could something have scrambled the drive chips? open to suggestions on how to trouble shoot this

Ray

boxwood
08-04-2003, 01:29 PM
Ok

checked the setup yet again this time with with desknc .doc and duh..... I had it all wrong I had the correct pins set but desknc does not use pin assignments it assigns each pin a bit number not sure why? but once the bit numbers where plugged in CORRECTLY it all works again :-) again did I say duh
anyway, thanks for aall the help.

Ray