PDA

View Full Version : Need Help! plunge feed for lathe



bala955
03-08-2011, 11:03 PM
how can i change plunge feed as per below example with fanuc post.


G0 X15.565 Z-.8375 M8
G1 X15.505 F.015
G3 X15.4252 Z-.9567 R.198 F.03
G1 Z-2.0333 (have feed in above line appear in this line instead)
G3 X15.505 Z-2.1525 R.198
G0 X15.565

lowjoe
03-31-2011, 10:23 AM
I believe you need to add a line to post. The post im guessing looks as follows


Infeed # Enable cutter comp
G1 G41 X[V] Z[H] F[FRate]
End

Outfeed # Disable cutter comp
G1 G40 X[V] Z[H] F[FRate]
End
try changing it to look like this

Infeed # Enable cutter comp
G1 G41 X[V] Z[H] F[FRate]
Z[H] F[Plunge]
End

Outfeed # Disable cutter comp
G1 G40 X[V] Z[H] F[FRate]
Z[H] F[Plunge]
End


if this doesnt work you need to add a custom section to your post stating that a Z move is to use the plung rate.

bala955
04-13-2011, 09:10 PM
this did not work, what would custom lines look like

Thanks

lowjoe
05-09-2011, 09:28 AM
I think I figured this out in the nc operation if you go to lathe options. You can change the infeed to plunge feed or rapid. Its hard to tell without seeing the file that you are using. But I think this is where change this. The defult is set to feed.