PDA

View Full Version : Makerbot #253 (trials and tribulations)



g00bd0g
12-31-2010, 05:07 PM
So I built my ToM in two evenings (about 14 hours total) and everything went together as it should and worked right off the bat. I was like "Yay!". Then I printed some of the basic calibration objects and they came out great and I was like "awesome". Then I was trying some raftless objects and the extruder drive died 1/2 way through my 20mm cube and I was like "WTF"?

The motor spun fine on a 7.2v LiPo battery. So I then put a voltmeter
on the motor lines from the extruder controller and it shows 12.2v.
However it does not seem to put out enough amperage to spin the motor.
It will, on occasion, sort of cough and sputter for a few seconds but
then dies again. I was watching the amps during this and the
controller never put out more than .15 amps which was just enough to
make the motor sort of move, but then it would drop to about .05 amps
which wasn't enough to make the motor spin anymore.

I assume this controller should be capable of putting out at least an
amp or so. Following this assumption I would presume I have a bad extruder controller.

Some other random notes.

The extruder would not run at ANYTHING less than 255. Not even 254.
The "debug" light on the extruder board now flashes constantly. Maybe I didn't notice it before?
I think I was fighting the dying extruder the whole time as I kept dropping my feed rate and seeing only marginal improvements in fill density.
I also swear I could hear the extruder RPM varying pretty much the whole time I had it running.
Quite a few other people are reporting similar problems.


I am awaiting makerbots support response.

On the whole I am actually pretty pleased with how well everything went together and that it actually worked right away. The quality was on-par, or even perhaps exceeding my expectations. And I have yet to even try .3 or .2 mm layers.

Hopefully this is just "teething" problems which you sort of have to expect when being an early adopter of bleeding edge technology.

Here are some pics and further notes from my experiences so far.

http://www.cnczone.com/forums/attachment.php?attachmentid=122582&stc=1&d=1293833299
Current state of T-o-M. Diagnosing extruder drive issues.

http://www.cnczone.com/forums/attachment.php?attachmentid=122583&stc=1&d=1293833299
Progression of 20mm calibration cubes from Left to Right, top and then bottom rows. 1st cube is with default settings, last is where I ended up after slowing the feed rate and adjusting the perimeter and fill width/height variables a smidge.

http://www.cnczone.com/forums/attachment.php?attachmentid=122584&stc=1&d=1293833299
Pretty happy with this cube! Now just gotta get my raft settings dialed in.

http://www.cnczone.com/forums/attachment.php?attachmentid=122585&stc=1&d=1293833299
0.5mm wall calibration cube. 1st attempt, notice "sagging".

http://www.cnczone.com/forums/attachment.php?attachmentid=122586&stc=1&d=1293833299
Exact same settings as the 1st attempt, but this time I try blowing on it when it starts sagging. You can see an immediate and obvious difference. Time to incorporate a small fan to help cool thin-featured objects.

http://www.cnczone.com/forums/attachment.php?attachmentid=122587&stc=1&d=1293833299
Man it looks good with enough airflow.

g00bd0g
01-02-2011, 05:06 PM
Cross-posted from http://wiki.makerbot.com/forum/t-294403/thing-o-matic-extruder-controller-problem#post-962887

There is some good info there as well.

*******************

More thoughts. I had wired in some LED lighting during all this and noticed a distinct flicker and drop in in the light level as the motor coughed and sputtered. I also noticed the same thing when the extruder or ABP heaters turned on. I never had a volt meter on the PS but I assume it's not maintaining a constant voltage.

Upon inspection I discovered the included PS was only rated to 22 amps on the 12v lines. And these power supplies are frequently "dual rail" or "triple rail" which means there may actually be two 11 amp or three 7amp 12v (or some combination) of supplies inside. I had the extruder controller and a stepper controller on one pigtail and the two other stepper controllers on the other. If this is indeed a dual or triple rail PS, I think we could easily be overloading it, especially as indicated by the flickering LED's. I also assume this could kill power components pretty fast if you driving them from an under-volted and unstable PS. In retrospect I should have thrown the voltmeter on the 12v lines to see what they were doing, but hind-sight is always 20-20 :)

So, I upgraded the PS to a Corsair 650w "single rail" PS. I like single-rail PS's much better because you don't have to pay attention to what's getting plugged in where, to keep it load balanced. There is now, no noticeable LED flickering under any combination of loads and I am quite positive that the included PS is marginal at best. If someone is really interested I could pull the bottom off, again (for like the 15th time), and plug in the old PS and see what the actual 12v voltages are under load.

Also during this testing I have discovered my ABP no longer gets up to temp, it can only mange about 95c. Yet another symptom of a dying extruder controller board I suspect.

g00bd0g
01-02-2011, 05:15 PM
I was bored and Idle Hands are the devils tools :) So I plugged in the original PS to get some numbers.

http://www.cnczone.com/forums/attachment.php?attachmentid=122884&stc=1&d=1294006080
1st pigtail plugged into the Z stepper and extruder controllers. 10.88 Volts! Ugh. This is with both heaters and the extruder drive on. Looks like I was correct about the PS being "marginal" to be polite.

http://www.cnczone.com/forums/attachment.php?attachmentid=122885&stc=1&d=1294006080
2nd pigtail plugged into X and Y stepper controllers. 11.31 Volts. Again, Ugh! This while the other pigtail is reading 10.88 so it looks like we are working with a "dual-rail" PS here.

Given that my extruder never worked at less than 255 I am still unsure if that is a symptom of the low voltage or a separate issue entirely.

If you haven't fired up your T-o-M on the included PS, DON'T. At the least it's inadequate, at worst it's frying extruder controllers. I'm very curious if any of these new extruder controller can PWM at less than 255 when equipped with a proper PS.

g00bd0g
01-23-2011, 05:30 PM
Makerbot finally sent me a solenoid kit which has resolved my motor drive issues. It was undeniably an extruder board issue as the original motor now works great. I have lost the variable speed and reverse options, which I find quite annoying, but at least I am able to print parts.

g00bd0g
01-30-2011, 03:57 PM
After my recent success with the dodecahedron, I tried to print another one. I guess I just got lucky on the 1st try.

In about 6 consecutive attempts I have yet to be able to print another.

All of my prints are skipping in the X axis, despite my messing with the "ref" trim pots. I marked my belts and pulleys and motor shaft and they are not slipping.

Once again, it's funky electronics. Any thoughts are appreciated.

SSC1
06-02-2011, 05:56 PM
good lookin prints. I'll have to post up some of my makerbot creations.

g00bd0g
07-16-2011, 05:50 PM
I am testing the waters to see if anyone is interested in my makerbot. It is fully functional with MK6 Stepper Extruder, heated glass build surface, and lots of extras.

You can see the stuff I've designed and built with it here:

About g00bd0g - Thingiverse (http://www.thingiverse.com/g00bd0g)

I have close to $2000 into it. Comes with extra extruder controller board, makerbot spool box, and over 10 lbs of assorted ABS and PLA. It truly works awesome and I have several profiles for down to .3mm layer height builds.

triplett969
08-26-2011, 10:11 PM
Hey, if you are still trying to sell your Makerbot let me know. If the price is right I might jump.
triplett969@gmail.com